summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJim Ramsay <lack@gentoo.org>2006-10-23 14:27:45 +0000
committerJim Ramsay <lack@gentoo.org>2006-10-23 14:27:45 +0000
commitbf8a60ad1c630c27e2c4296ad26ea29dc2fcdcaa (patch)
tree31d6a6645eabc3dd144e4e8c1cb275d87aaeacac /rox-base/rox
parentUpdate description (diff)
downloadgentoo-2-bf8a60ad1c630c27e2c4296ad26ea29dc2fcdcaa.tar.gz
gentoo-2-bf8a60ad1c630c27e2c4296ad26ea29dc2fcdcaa.tar.bz2
gentoo-2-bf8a60ad1c630c27e2c4296ad26ea29dc2fcdcaa.zip
Bug 152419: Added dev-util/pkgconfig to DEPEND and remove the 'read' call temporarily to prevent the ebuild going interactive if the compile fails.
(Portage version: 2.1.2_pre3-r3)
Diffstat (limited to 'rox-base/rox')
-rw-r--r--rox-base/rox/ChangeLog7
-rw-r--r--rox-base/rox/files/digest-rox-2.2.02
-rw-r--r--rox-base/rox/rox-2.2.0.ebuild23
-rw-r--r--rox-base/rox/rox-2.3.ebuild17
-rw-r--r--rox-base/rox/rox-2.4.1-r1.ebuild18
-rw-r--r--rox-base/rox/rox-2.4.1.ebuild18
-rw-r--r--rox-base/rox/rox-2.5.ebuild18
7 files changed, 95 insertions, 8 deletions
diff --git a/rox-base/rox/ChangeLog b/rox-base/rox/ChangeLog
index fccef96b21d2..21e4cbf2187d 100644
--- a/rox-base/rox/ChangeLog
+++ b/rox-base/rox/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for rox-base/rox
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/rox-base/rox/ChangeLog,v 1.21 2006/10/05 17:24:22 lack Exp $
+# $Header: /var/cvsroot/gentoo-x86/rox-base/rox/ChangeLog,v 1.22 2006/10/23 14:27:45 lack Exp $
+
+ 23 Oct 2006; Jim Ramsay <lack@gentoo.org> rox-2.2.0.ebuild,
+ rox-2.3.ebuild, rox-2.4.1.ebuild, rox-2.4.1-r1.ebuild, rox-2.5.ebuild:
+ Bug 152419, Added dev-util/pkgconfig to DEPEND and remove the 'read' call
+ temporarily to prevent the ebuild going interactive if the compile fails.
05 Oct 2006; Jim Ramsay <lack@gentoo.org> metadata.xml, -rox-2.1.3.ebuild,
-rox-2.1.4.ebuild, -rox-2.1.5.ebuild:
diff --git a/rox-base/rox/files/digest-rox-2.2.0 b/rox-base/rox/files/digest-rox-2.2.0
index 3770cd08d083..fbdb0f20dd9a 100644
--- a/rox-base/rox/files/digest-rox-2.2.0
+++ b/rox-base/rox/files/digest-rox-2.2.0
@@ -1 +1,3 @@
MD5 0deefd9e7edd4e79cd0f18f423264ebb rox-2.2.0.tgz 2033724
+RMD160 6fe46202ddd3f04c07a0eaaabde88eb776c535dd rox-2.2.0.tgz 2033724
+SHA256 31bdaa795c4b166a665460289db8adaea2708bc67c1fe8b3d34a569a784d3d2a rox-2.2.0.tgz 2033724
diff --git a/rox-base/rox/rox-2.2.0.ebuild b/rox-base/rox/rox-2.2.0.ebuild
index 4a86e30dcdac..c5ebc0a019a4 100644
--- a/rox-base/rox/rox-2.2.0.ebuild
+++ b/rox-base/rox/rox-2.2.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/rox-base/rox/rox-2.2.0.ebuild,v 1.8 2006/08/15 23:14:16 wormo Exp $
+# $Header: /var/cvsroot/gentoo-x86/rox-base/rox/rox-2.2.0.ebuild,v 1.9 2006/10/23 14:27:45 lack Exp $
inherit eutils
@@ -16,6 +16,13 @@ DEPEND=">=x11-libs/gtk+-2.2
>=dev-libs/glib-2.2
>=dev-libs/libxml2-2.4.23
>=x11-misc/shared-mime-info-0.9
+ >=dev-util/pkgconfig-0.20
+ svg? ( gnome-base/librsvg )"
+
+RDEPEND=">=x11-libs/gtk+-2.2
+ >=dev-libs/glib-2.2
+ >=dev-libs/libxml2-2.4.23
+ >=x11-misc/shared-mime-info-0.9
svg? ( gnome-base/librsvg )"
IUSE="svg"
@@ -35,8 +42,18 @@ src_compile() {
# not be able to find a proper executable to run.
use sparc && unset PLATFORM
- ROX-Filer/AppRun --compile || die "make failed"
- (cd ROX-Filer/src; make clean) > /dev/null
+ cd ROX-Filer
+
+ # Most rox self-compiles have a 'read' call to wait for the user to
+ # press return if the compile fails.
+ # Find and remove this:
+ sed -i.bak -e 's/\<read WAIT\>/#read/' AppRun
+
+ ./AppRun --compile || die "make failed"
+ (cd src; make clean) > /dev/null
+
+ # Restore the original AppRun
+ mv AppRun.bak AppRun
}
src_install() {
diff --git a/rox-base/rox/rox-2.3.ebuild b/rox-base/rox/rox-2.3.ebuild
index 45374a321a92..4b58bcc4fe50 100644
--- a/rox-base/rox/rox-2.3.ebuild
+++ b/rox-base/rox/rox-2.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/rox-base/rox/rox-2.3.ebuild,v 1.2 2006/08/15 23:14:16 wormo Exp $
+# $Header: /var/cvsroot/gentoo-x86/rox-base/rox/rox-2.3.ebuild,v 1.3 2006/10/23 14:27:45 lack Exp $
inherit eutils
@@ -18,6 +18,12 @@ KEYWORDS="~x86 ~ppc ~alpha ~sparc ~amd64"
DEPEND=">=x11-libs/gtk+-2.4
>=dev-libs/libxml2-2.4.23
>=x11-misc/shared-mime-info-0.14
+ >=dev-util/pkgconfig-0.20
+ svg? ( gnome-base/librsvg )"
+
+RDEPEND=">=x11-libs/gtk+-2.4
+ >=dev-libs/libxml2-2.4.23
+ >=x11-misc/shared-mime-info-0.14
svg? ( gnome-base/librsvg )"
IUSE="svg"
@@ -43,8 +49,17 @@ src_compile() {
use sparc && unset PLATFORM
cd ${WORKDIR}/${P}/ROX-Filer
+
+ # Most rox self-compiles have a 'read' call to wait for the user to
+ # press return if the compile fails.
+ # Find and remove this:
+ sed -i.bak -e 's/\<read WAIT\>/#read/' AppRun
+
./AppRun --compile || die "make failed"
(cd src; make clean) > /dev/null
+
+ # Restore the original AppRun
+ mv AppRun.bak AppRun
}
src_install() {
diff --git a/rox-base/rox/rox-2.4.1-r1.ebuild b/rox-base/rox/rox-2.4.1-r1.ebuild
index 43636d855388..87234cee6311 100644
--- a/rox-base/rox/rox-2.4.1-r1.ebuild
+++ b/rox-base/rox/rox-2.4.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/rox-base/rox/rox-2.4.1-r1.ebuild,v 1.1 2006/06/11 13:07:02 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/rox-base/rox/rox-2.4.1-r1.ebuild,v 1.2 2006/10/23 14:27:45 lack Exp $
inherit eutils
@@ -17,6 +17,13 @@ DEPEND=">=x11-libs/gtk+-2.4
>=dev-libs/glib-2.2
>=dev-libs/libxml2-2.4.23
>=x11-misc/shared-mime-info-0.14
+ >=dev-util/pkgconfig-0.20
+ svg? ( gnome-base/librsvg )"
+
+RDEPEND=">=x11-libs/gtk+-2.4
+ >=dev-libs/glib-2.2
+ >=dev-libs/libxml2-2.4.23
+ >=x11-misc/shared-mime-info-0.14
svg? ( gnome-base/librsvg )"
IUSE="svg"
@@ -27,10 +34,19 @@ MIMECONFDIR="/etc/xdg/rox.sourceforge.net"
src_compile() {
cd ROX-Filer
+
+ # Most rox self-compiles have a 'read' call to wait for the user to
+ # press return if the compile fails.
+ # Find and remove this:
+ sed -i.bak -e 's/\<read WAIT\>/#read/' AppRun
+
./AppRun --compile || die "make failed"
(cd src; make clean) > /dev/null
# don't need this directory anymore
rm -fr build
+
+ # Restore the original AppRun
+ mv AppRun.bak AppRun
}
# new streamlined install
diff --git a/rox-base/rox/rox-2.4.1.ebuild b/rox-base/rox/rox-2.4.1.ebuild
index e013f897e48f..84fef757cf0e 100644
--- a/rox-base/rox/rox-2.4.1.ebuild
+++ b/rox-base/rox/rox-2.4.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/rox-base/rox/rox-2.4.1.ebuild,v 1.3 2006/04/27 04:31:48 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/rox-base/rox/rox-2.4.1.ebuild,v 1.4 2006/10/23 14:27:45 lack Exp $
inherit eutils
@@ -17,6 +17,13 @@ DEPEND=">=x11-libs/gtk+-2.4
>=dev-libs/glib-2.2
>=dev-libs/libxml2-2.4.23
>=x11-misc/shared-mime-info-0.14
+ >=dev-util/pkgconfig-0.20
+ svg? ( gnome-base/librsvg )"
+
+RDEPEND=">=x11-libs/gtk+-2.4
+ >=dev-libs/glib-2.2
+ >=dev-libs/libxml2-2.4.23
+ >=x11-misc/shared-mime-info-0.14
svg? ( gnome-base/librsvg )"
IUSE="svg"
@@ -31,10 +38,19 @@ src_compile() {
# use sparc && unset PLATFORM
cd ROX-Filer
+
+ # Most rox self-compiles have a 'read' call to wait for the user to
+ # press return if the compile fails.
+ # Find and remove this:
+ sed -i.bak -e 's/\<read WAIT\>/#read/' AppRun
+
./AppRun --compile || die "make failed"
(cd src; make clean) > /dev/null
# don't need this directory anymore
rm -fr build
+
+ # Restore the original AppRun
+ mv AppRun.bak AppRun
}
# new streamlined install
diff --git a/rox-base/rox/rox-2.5.ebuild b/rox-base/rox/rox-2.5.ebuild
index c2554dc664f1..ce14b3bf9dfb 100644
--- a/rox-base/rox/rox-2.5.ebuild
+++ b/rox-base/rox/rox-2.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/rox-base/rox/rox-2.5.ebuild,v 1.1 2006/08/15 23:14:16 wormo Exp $
+# $Header: /var/cvsroot/gentoo-x86/rox-base/rox/rox-2.5.ebuild,v 1.2 2006/10/23 14:27:45 lack Exp $
inherit eutils
@@ -20,6 +20,13 @@ DEPEND=">=x11-libs/gtk+-2.4
>=dev-libs/glib-2.2
>=dev-libs/libxml2-2.4.23
>=x11-misc/shared-mime-info-0.14
+ >=dev-util/pkgconfig-0.20
+ svg? ( gnome-base/librsvg )"
+
+RDEPEND=">=x11-libs/gtk+-2.4
+ >=dev-libs/glib-2.2
+ >=dev-libs/libxml2-2.4.23
+ >=x11-misc/shared-mime-info-0.14
svg? ( gnome-base/librsvg )"
IUSE="svg"
@@ -30,10 +37,19 @@ MIMECONFDIR="/etc/xdg/rox.sourceforge.net"
src_compile() {
cd ROX-Filer
+
+ # Most rox self-compiles have a 'read' call to wait for the user to
+ # press return if the compile fails.
+ # Find and remove this:
+ sed -i.bak -e 's/\<read WAIT\>/#read/' AppRun
+
./AppRun --compile || die "make failed"
(cd src; make clean) > /dev/null
# don't need this directory anymore
rm -fr build
+
+ # Restore the original AppRun
+ mv AppRun.bak AppRun
}
# new streamlined install