summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2011-07-09 17:37:48 +0000
committerTorsten Veller <tove@gentoo.org>2011-07-09 17:37:48 +0000
commit0ceb798471284ed4813692012ec754c6351df712 (patch)
tree4af6729eca12ef8337cb6c108dc34b61b2170667 /perl-core/ExtUtils-MakeMaker
parentppc64 stable wrt #370845 (diff)
downloadgentoo-2-0ceb798471284ed4813692012ec754c6351df712.tar.gz
gentoo-2-0ceb798471284ed4813692012ec754c6351df712.tar.bz2
gentoo-2-0ceb798471284ed4813692012ec754c6351df712.zip
Version bump
(Portage version: 2.2.0_alpha43/cvs/Linux x86_64)
Diffstat (limited to 'perl-core/ExtUtils-MakeMaker')
-rw-r--r--perl-core/ExtUtils-MakeMaker/ChangeLog9
-rw-r--r--perl-core/ExtUtils-MakeMaker/ExtUtils-MakeMaker-6.580.0.ebuild47
-rw-r--r--perl-core/ExtUtils-MakeMaker/files/6.58-RUNPATH.patch16
-rw-r--r--perl-core/ExtUtils-MakeMaker/files/6.58-delete_packlist_podlocal.patch76
4 files changed, 147 insertions, 1 deletions
diff --git a/perl-core/ExtUtils-MakeMaker/ChangeLog b/perl-core/ExtUtils-MakeMaker/ChangeLog
index b8fdc4700262..206eed20cca4 100644
--- a/perl-core/ExtUtils-MakeMaker/ChangeLog
+++ b/perl-core/ExtUtils-MakeMaker/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for perl-core/ExtUtils-MakeMaker
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/perl-core/ExtUtils-MakeMaker/ChangeLog,v 1.22 2011/01/17 08:11:00 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/perl-core/ExtUtils-MakeMaker/ChangeLog,v 1.23 2011/07/09 17:37:47 tove Exp $
+
+*ExtUtils-MakeMaker-6.580.0 (09 Jul 2011)
+
+ 09 Jul 2011; Torsten Veller <tove@gentoo.org> +files/6.58-RUNPATH.patch,
+ +files/6.58-delete_packlist_podlocal.patch,
+ +ExtUtils-MakeMaker-6.580.0.ebuild:
+ Version bump
17 Jan 2011; Torsten Veller <tove@gentoo.org>
-ExtUtils-MakeMaker-6.56.ebuild:
diff --git a/perl-core/ExtUtils-MakeMaker/ExtUtils-MakeMaker-6.580.0.ebuild b/perl-core/ExtUtils-MakeMaker/ExtUtils-MakeMaker-6.580.0.ebuild
new file mode 100644
index 000000000000..81a380f81b04
--- /dev/null
+++ b/perl-core/ExtUtils-MakeMaker/ExtUtils-MakeMaker-6.580.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/perl-core/ExtUtils-MakeMaker/ExtUtils-MakeMaker-6.580.0.ebuild,v 1.1 2011/07/09 17:37:47 tove Exp $
+
+EAPI=4
+MODULE_VERSION="6.58"
+MODULE_AUTHOR=MSCHWERN
+inherit eutils perl-module
+
+DESCRIPTION="Create a module Makefile"
+HOMEPAGE="http://makemaker.org ${HOMEPAGE}"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="
+ >=virtual/perl-CPAN-Meta-2.110.930
+ >=virtual/perl-ExtUtils-Command-1.16
+ >=virtual/perl-ExtUtils-Install-1.52
+ >=virtual/perl-ExtUtils-Manifest-1.58
+ >=virtual/perl-Parse-CPAN-Meta-1.440.100
+ >=virtual/perl-File-Spec-0.8
+"
+RDEPEND="${DEPEND}
+ !!<dev-lang/perl-5.8.8-r7"
+
+PATCHES=(
+ "${FILESDIR}/6.58-delete_packlist_podlocal.patch"
+ "${FILESDIR}/6.58-RUNPATH.patch"
+)
+SRC_TEST=do
+
+src_prepare (){
+ edos2unix "${S}/lib/ExtUtils/MM_Unix.pm"
+ edos2unix "${S}/lib/ExtUtils/MM_Any.pm"
+
+ perl-module_src_prepare
+}
+
+src_install() {
+ perl-module_src_install
+
+ # remove all the bundled distributions
+ pushd "${D}" >/dev/null
+ find ".${VENDOR_LIB}" -mindepth 1 -maxdepth 1 -not -name "ExtUtils" -exec rm -rf {} \+
+ popd >/dev/null
+}
diff --git a/perl-core/ExtUtils-MakeMaker/files/6.58-RUNPATH.patch b/perl-core/ExtUtils-MakeMaker/files/6.58-RUNPATH.patch
new file mode 100644
index 000000000000..41f26098b2bd
--- /dev/null
+++ b/perl-core/ExtUtils-MakeMaker/files/6.58-RUNPATH.patch
@@ -0,0 +1,16 @@
+--- a/lib/ExtUtils/MM_Any.pm
++++ b/lib/ExtUtils/MM_Any.pm
+@@ -1900,6 +1900,13 @@ CODE
+ # LD_RUN_PATH now computed by ExtUtils::Liblist
+ ($self->{EXTRALIBS}, $self->{BSLOADLIBS},
+ $self->{LDLOADLIBS}, $self->{LD_RUN_PATH}) = @libs;
++ # We do not want the build root in RPATH
++ if ( exists $ENV{PORTAGE_TMPDIR} ){
++ # If we have a PORTAGE_TMPDIR set, strip that, as just testing for
++ # /usr and /opt might not be sufficient.
++ $self->{LD_RUN_PATH} = join ':', grep !/^\Q$ENV{PORTAGE_TMPDIR}/,
++ split /:/, $self->{LD_RUN_PATH};
++ }
+ last;
+ }
+ }
diff --git a/perl-core/ExtUtils-MakeMaker/files/6.58-delete_packlist_podlocal.patch b/perl-core/ExtUtils-MakeMaker/files/6.58-delete_packlist_podlocal.patch
new file mode 100644
index 000000000000..c42d1d2c9f45
--- /dev/null
+++ b/perl-core/ExtUtils-MakeMaker/files/6.58-delete_packlist_podlocal.patch
@@ -0,0 +1,76 @@
+Don't install .packlist or perllocal.pod for perl or vendor.
+Extracted from the debian patchset.
+See also bug #241834
+---
+ lib/ExtUtils/MM_Unix.pm | 25 +------------------------
+ 1 files changed, 1 insertions(+), 24 deletions(-)
+
+diff --git a/lib/ExtUtils/MM_Unix.pm b/lib/ExtUtils/MM_Unix.pm
+index 10fcdf4..642b677 100644
+--- a/lib/ExtUtils/MM_Unix.pm
++++ b/lib/ExtUtils/MM_Unix.pm
+@@ -2047,8 +2047,6 @@ doc__install : doc_site_install
+
+ pure_perl_install :: all
+ $(NOECHO) $(MOD_INSTALL) \
+- read }.$self->catfile('$(PERL_ARCHLIB)','auto','$(FULLEXT)','.packlist').q{ \
+- write }.$self->catfile('$(DESTINSTALLARCHLIB)','auto','$(FULLEXT)','.packlist').q{ \
+ $(INST_LIB) $(DESTINSTALLPRIVLIB) \
+ $(INST_ARCHLIB) $(DESTINSTALLARCHLIB) \
+ $(INST_BIN) $(DESTINSTALLBIN) \
+@@ -2074,8 +2072,6 @@ pure_site_install :: all
+
+ pure_vendor_install :: all
+ $(NOECHO) $(MOD_INSTALL) \
+- read }.$self->catfile('$(VENDORARCHEXP)','auto','$(FULLEXT)','.packlist').q{ \
+- write }.$self->catfile('$(DESTINSTALLVENDORARCH)','auto','$(FULLEXT)','.packlist').q{ \
+ $(INST_LIB) $(DESTINSTALLVENDORLIB) \
+ $(INST_ARCHLIB) $(DESTINSTALLVENDORARCH) \
+ $(INST_BIN) $(DESTINSTALLVENDORBIN) \
+@@ -2084,15 +2080,6 @@ pure_vendor_install :: all
+ $(INST_MAN3DIR) $(DESTINSTALLVENDORMAN3DIR)
+
+ doc_perl_install :: all
+- $(NOECHO) $(ECHO) Appending installation info to $(DESTINSTALLARCHLIB)/perllocal.pod
+- -$(NOECHO) $(MKPATH) $(DESTINSTALLARCHLIB)
+- -$(NOECHO) $(DOC_INSTALL) \
+- "Module" "$(NAME)" \
+- "installed into" "$(INSTALLPRIVLIB)" \
+- LINKTYPE "$(LINKTYPE)" \
+- VERSION "$(VERSION)" \
+- EXE_FILES "$(EXE_FILES)" \
+- >> }.$self->catfile('$(DESTINSTALLARCHLIB)','perllocal.pod').q{
+
+ doc_site_install :: all
+ $(NOECHO) $(ECHO) Appending installation info to $(DESTINSTALLARCHLIB)/perllocal.pod
+@@ -2106,15 +2093,6 @@ doc_site_install :: all
+ >> }.$self->catfile('$(DESTINSTALLARCHLIB)','perllocal.pod').q{
+
+ doc_vendor_install :: all
+- $(NOECHO) $(ECHO) Appending installation info to $(DESTINSTALLARCHLIB)/perllocal.pod
+- -$(NOECHO) $(MKPATH) $(DESTINSTALLARCHLIB)
+- -$(NOECHO) $(DOC_INSTALL) \
+- "Module" "$(NAME)" \
+- "installed into" "$(INSTALLVENDORLIB)" \
+- LINKTYPE "$(LINKTYPE)" \
+- VERSION "$(VERSION)" \
+- EXE_FILES "$(EXE_FILES)" \
+- >> }.$self->catfile('$(DESTINSTALLARCHLIB)','perllocal.pod').q{
+
+ };
+
+@@ -2123,13 +2101,12 @@ uninstall :: uninstall_from_$(INSTALLDIRS)dirs
+ $(NOECHO) $(NOOP)
+
+ uninstall_from_perldirs ::
+- $(NOECHO) $(UNINSTALL) }.$self->catfile('$(PERL_ARCHLIB)','auto','$(FULLEXT)','.packlist').q{
+
+ uninstall_from_sitedirs ::
+ $(NOECHO) $(UNINSTALL) }.$self->catfile('$(SITEARCHEXP)','auto','$(FULLEXT)','.packlist').q{
+
+ uninstall_from_vendordirs ::
+- $(NOECHO) $(UNINSTALL) }.$self->catfile('$(VENDORARCHEXP)','auto','$(FULLEXT)','.packlist').q{
++
+ };
+
+ join("",@m);