summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2012-12-08 15:16:37 +0000
committerTorsten Veller <tove@gentoo.org>2012-12-08 15:16:37 +0000
commit389a0d0d68548a614590a5f0a2ef47381d940bd2 (patch)
tree6b2cca441664be3f9c25c72200517e3788298dbf /perl-core/Compress-Raw-Zlib
parentMigrate to distutils-r1. (diff)
downloadgentoo-2-389a0d0d68548a614590a5f0a2ef47381d940bd2.tar.gz
gentoo-2-389a0d0d68548a614590a5f0a2ef47381d940bd2.tar.bz2
gentoo-2-389a0d0d68548a614590a5f0a2ef47381d940bd2.zip
[bump] perl-core/Compress-Raw-Zlib-2.59.0
(Portage version: 2.2.0_alpha144/cvs/Linux x86_64, signed Manifest commit with key 0x5772769F4E046AEC)
Diffstat (limited to 'perl-core/Compress-Raw-Zlib')
-rw-r--r--perl-core/Compress-Raw-Zlib/ChangeLog8
-rw-r--r--perl-core/Compress-Raw-Zlib/Compress-Raw-Zlib-2.59.0.ebuild34
2 files changed, 41 insertions, 1 deletions
diff --git a/perl-core/Compress-Raw-Zlib/ChangeLog b/perl-core/Compress-Raw-Zlib/ChangeLog
index 4f3801a7bbc2..2fb9870a1c79 100644
--- a/perl-core/Compress-Raw-Zlib/ChangeLog
+++ b/perl-core/Compress-Raw-Zlib/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for perl-core/Compress-Raw-Zlib
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/perl-core/Compress-Raw-Zlib/ChangeLog,v 1.50 2012/08/22 17:24:37 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/perl-core/Compress-Raw-Zlib/ChangeLog,v 1.51 2012/12/08 15:16:37 tove Exp $
+
+*Compress-Raw-Zlib-2.59.0 (08 Dec 2012)
+
+ 08 Dec 2012; Torsten Veller <tove@gentoo.org>
+ +Compress-Raw-Zlib-2.59.0.ebuild:
+ Version bump
*Compress-Raw-Zlib-2.56.0 (22 Aug 2012)
diff --git a/perl-core/Compress-Raw-Zlib/Compress-Raw-Zlib-2.59.0.ebuild b/perl-core/Compress-Raw-Zlib/Compress-Raw-Zlib-2.59.0.ebuild
new file mode 100644
index 000000000000..666460453999
--- /dev/null
+++ b/perl-core/Compress-Raw-Zlib/Compress-Raw-Zlib-2.59.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/perl-core/Compress-Raw-Zlib/Compress-Raw-Zlib-2.59.0.ebuild,v 1.1 2012/12/08 15:16:37 tove Exp $
+
+EAPI=4
+
+MODULE_AUTHOR=PMQS
+MODULE_VERSION=2.059
+inherit multilib perl-module
+
+DESCRIPTION="Low-Level Interface to zlib compression library"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND=">=sys-libs/zlib-1.2.5"
+DEPEND="${RDEPEND}"
+# test? ( dev-perl/Test-Pod )"
+
+SRC_TEST=parallel
+
+src_prepare() {
+ rm -rf "${S}"/zlib-src/ || die
+ sed -i '/^zlib-src/d' "${S}"/MANIFEST || die
+ perl-module_src_prepare
+}
+
+src_configure() {
+ BUILD_ZLIB=False \
+ ZLIB_INCLUDE="${EPREFIX}"/usr/include \
+ ZLIB_LIB="${EPREFIX}"/usr/$(get_libdir) \
+ perl-module_src_configure
+}