summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-04-03 19:00:00 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-04-03 19:00:00 +0000
commit796199721fa402460bc4a94355eebd709919b53f (patch)
tree0298aebbe8671a2e029511709447993572d2b471 /net-zope
parentDelete older ebuild. (diff)
downloadgentoo-2-796199721fa402460bc4a94355eebd709919b53f.tar.gz
gentoo-2-796199721fa402460bc4a94355eebd709919b53f.tar.bz2
gentoo-2-796199721fa402460bc4a94355eebd709919b53f.zip
Version bump.
(Portage version: 2.2.0_alpha29_p8/cvs/Linux x86_64)
Diffstat (limited to 'net-zope')
-rw-r--r--net-zope/zcatalog/ChangeLog8
-rw-r--r--net-zope/zcatalog/zcatalog-2.13.8.ebuild48
2 files changed, 55 insertions, 1 deletions
diff --git a/net-zope/zcatalog/ChangeLog b/net-zope/zcatalog/ChangeLog
index 82079ca5da73..3e26627e84f7 100644
--- a/net-zope/zcatalog/ChangeLog
+++ b/net-zope/zcatalog/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-zope/zcatalog
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-zope/zcatalog/ChangeLog,v 1.4 2011/02/15 20:27:32 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zcatalog/ChangeLog,v 1.5 2011/04/03 19:00:00 arfrever Exp $
+
+*zcatalog-2.13.8 (03 Apr 2011)
+
+ 03 Apr 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +zcatalog-2.13.8.ebuild:
+ Version bump.
*zcatalog-2.13.7 (15 Feb 2011)
diff --git a/net-zope/zcatalog/zcatalog-2.13.8.ebuild b/net-zope/zcatalog/zcatalog-2.13.8.ebuild
new file mode 100644
index 000000000000..0daf26d86d67
--- /dev/null
+++ b/net-zope/zcatalog/zcatalog-2.13.8.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zcatalog/zcatalog-2.13.8.ebuild,v 1.1 2011/04/03 19:00:00 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2:2.6"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 2.5 3.* *-jython"
+
+inherit distutils
+
+MY_PN="Products.ZCatalog"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Zope 2's indexing and search solution."
+HOMEPAGE="http://pypi.python.org/pypi/Products.ZCatalog"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.zip"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="dev-python/restrictedpython
+ net-zope/accesscontrol
+ net-zope/acquisition
+ net-zope/datetime
+ net-zope/documenttemplate
+ net-zope/extensionclass
+ net-zope/missing
+ net-zope/persistence
+ net-zope/record
+ net-zope/zexceptions
+ net-zope/zodb
+ >=net-zope/zope-2.12
+ net-zope/zope-dottedname
+ net-zope/zope-interface
+ net-zope/zope-schema
+ net-zope/zope-testing"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ dev-python/setuptools"
+PDEPEND="net-zope/zctextindex"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS="CHANGES.txt README.txt"
+PYTHON_MODNAME="Products/PluginIndexes ${MY_PN/.//}"