summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeth Chandler <sethbc@gentoo.org>2003-02-10 08:53:16 +0000
committerSeth Chandler <sethbc@gentoo.org>2003-02-10 08:53:16 +0000
commitf3dbbcb08f04c11beb59f5606e4f765ce631effc (patch)
treedd7f1b08677fd742ece673170a12e01c176dfcff /net-www
parentadded wsmake to portage (diff)
downloadgentoo-2-f3dbbcb08f04c11beb59f5606e4f765ce631effc.tar.gz
gentoo-2-f3dbbcb08f04c11beb59f5606e4f765ce631effc.tar.bz2
gentoo-2-f3dbbcb08f04c11beb59f5606e4f765ce631effc.zip
added httrack to portage
Diffstat (limited to 'net-www')
-rw-r--r--net-www/httrack/ChangeLog9
-rw-r--r--net-www/httrack/files/digest-httrack-3.221
-rw-r--r--net-www/httrack/httrack-3.22.ebuild54
3 files changed, 64 insertions, 0 deletions
diff --git a/net-www/httrack/ChangeLog b/net-www/httrack/ChangeLog
new file mode 100644
index 000000000000..b44b509dae70
--- /dev/null
+++ b/net-www/httrack/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for net-im/gaim-cvs
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/httrack/ChangeLog,v 1.1 2003/02/10 08:53:16 sethbc Exp $
+
+*httrack-3.22-3 (09 Feb 2003)
+
+ 09 Feb 2003; Seth Chandler <sethbc@gentoo.org>: httrack-3.22.ebuild
+ added httrack to portage thanks to Ricardo Cordeiro
+ <Ricardo.Cordeiro@iscte.pt> among others who submitted ebuilds
diff --git a/net-www/httrack/files/digest-httrack-3.22 b/net-www/httrack/files/digest-httrack-3.22
new file mode 100644
index 000000000000..96d47ce15f51
--- /dev/null
+++ b/net-www/httrack/files/digest-httrack-3.22
@@ -0,0 +1 @@
+MD5 f983978573b245e2340c3d3ddf8c4bc1 httrack-3.22-3.tar.gz 975672
diff --git a/net-www/httrack/httrack-3.22.ebuild b/net-www/httrack/httrack-3.22.ebuild
new file mode 100644
index 000000000000..0d8504aaefa6
--- /dev/null
+++ b/net-www/httrack/httrack-3.22.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/httrack/httrack-3.22.ebuild,v 1.1 2003/02/10 08:53:16 sethbc Exp $
+
+DESCRIPTION="HTTrack Website Copier, Open Source Offline Browser"
+HOMEPAGE="http://www.httrack.com/"
+SRC_URI="http://www.httrack.com/${P}-3.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="virtual/glibc"
+S="${WORKDIR}/${P}"
+
+src_compile() {
+
+ #First create libhttrack.so
+
+ econf --host=${CHOST} || die "1st econf failed"
+ cd src
+ emake libhttrack.la || die "failed making libhttrack.so"
+ cp .libs/libhttrack.so.1.0.0 ${WORKDIR}
+ cd ${WORKDIR}
+ rm -rf ${P}
+ unpack ${A}
+ cp libhttrack.so.1.0.0 ${P}/src/libhttrack.so.1.0.0
+ cd ${P}/src
+ ln -s libhttrack.so.1.0.0 libhttrack.so
+ cd ${S}
+
+ #Doing the complete compilation
+
+ econf --host=${CHOST} || die "2nd econf failed"
+ make || die "make failed"
+}
+
+src_install() {
+
+ einstall || die "Failed on einstall"
+ cd ${D}/usr/share/doc/
+ mv httrack ${P}
+ cd ${S}
+ dodoc AUTHORS COPYING INSTALL NEWS README ChangeLog
+ dodoc greetings.txt history.txt httrack-doc.html
+ cd ${D}/usr/share/doc/${P}/html
+ gzip -f -9 *.html
+ cd div
+ gzip -f -9 *
+ cd ../../templates
+ gzip -f -9 *
+ cd ../libtest
+ gzip -f -9 *
+}