summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorParag Mehta <pm@gentoo.org>2001-07-11 09:53:05 +0000
committerParag Mehta <pm@gentoo.org>2001-07-11 09:53:05 +0000
commitc1436b3811568d68360f349471cef452285c114c (patch)
tree84a211d0c0aa4122d44515b17bb9f7d94711343f /net-www
parentOops, forgot to dodoc. (diff)
downloadgentoo-2-c1436b3811568d68360f349471cef452285c114c.tar.gz
gentoo-2-c1436b3811568d68360f349471cef452285c114c.tar.bz2
gentoo-2-c1436b3811568d68360f349471cef452285c114c.zip
added digest files and modified squid compile options to also use -arp-acl, ipf-transperant and cache-manager.
Diffstat (limited to 'net-www')
-rw-r--r--net-www/squid/files/digest-squid-2.3.4s-r48
-rw-r--r--net-www/squid/squid-2.3.4s-r4.ebuild108
2 files changed, 116 insertions, 0 deletions
diff --git a/net-www/squid/files/digest-squid-2.3.4s-r4 b/net-www/squid/files/digest-squid-2.3.4s-r4
new file mode 100644
index 000000000000..07ec56d9073a
--- /dev/null
+++ b/net-www/squid/files/digest-squid-2.3.4s-r4
@@ -0,0 +1,8 @@
+MD5 c38c083f44c222a8d026fa129c30b98f squid-2.3.STABLE4-src.tar.gz
+MD5 db8e4eb9c1712a4adde7e9aaed0b5249 squid-2.3.stable4-accel_only_access.patch
+MD5 c3d48a2b4fc26c0d90eb4c30ae34d3d6 squid-2.3.stable4-carp-assertion.patch
+MD5 f1383b24672f9a8317c2c16302a94eaa squid-2.3.stable4-ftp_icon_not_found.patch
+MD5 68228709d011c93c2cccd9ac723fb462 squid-2.3.stable4-html_quoting.patch
+MD5 bec46f5a1fcbd9aa1deb9d518c5c11a5 squid-2.3.stable4-internal_dns_rcode_table_formatting.patch
+MD5 436eb77056bed5d45547c739d1123bd3 squid-2.3.stable4-invalid_ip_acl_entry.patch
+MD5 4453c53a712280a26fdca42c950bc94f squid-2.3.stable4-ipfw_configure.patch
diff --git a/net-www/squid/squid-2.3.4s-r4.ebuild b/net-www/squid/squid-2.3.4s-r4.ebuild
new file mode 100644
index 000000000000..33da7f3c10c5
--- /dev/null
+++ b/net-www/squid/squid-2.3.4s-r4.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# Modified by Parag Mehta <pm@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-www/squid/squid-2.3.4s-r4.ebuild,v 1.1 2001/07/11 09:53:05 pm Exp $
+
+P=squid-2.3.STABLE4
+
+A0=squid-2.3.stable4-ftp_icon_not_found.patch
+A1=squid-2.3.stable4-internal_dns_rcode_table_formatting.patch
+A2=squid-2.3.stable4-ipfw_configure.patch
+A3=squid-2.3.stable4-invalid_ip_acl_entry.patch
+A4=squid-2.3.stable4-accel_only_access.patch
+A5=squid-2.3.stable4-html_quoting.patch
+A6=squid-2.3.stable4-carp-assertion.patch
+
+S=${WORKDIR}/${P}
+DESCRIPTION="SQUID - Web Proxy Server"
+SRC_URI0="http://www.squid-cache.org/Versions/v2/2.3"
+SRC_URI="$SRC_URI0/${P}-src.tar.gz
+ $SRC_URI0/bugs/$A0 $SRC_URI0/bugs/$A1 $SRC_URI0/bugs/$A2
+ $SRC_URI0/bugs/$A3 $SRC_URI0/bugs/$A4 $SRC_URI0/bugs/$A5
+ $SRC_URI0/bugs/$A6"
+
+HOMEPAGE="http://www.squid-cache.org/"
+
+RDEPEND="virtual/glibc
+ >=sys-libs/pam-0.72
+ ldap? ( >=net-nds/openldap-1.2.11 )"
+DEPEND="$RDEPEND sys-devel/perl"
+
+src_unpack() {
+ unpack ${P}-src.tar.gz
+ cd ${S}
+ patch -p0 < ${DISTDIR}/${A0}
+ patch -p0 < ${DISTDIR}/${A1}
+ patch -p0 < ${DISTDIR}/${A2}
+ patch -p0 < ${DISTDIR}/${A3}
+ patch -p0 < ${DISTDIR}/${A4}
+ patch -p0 < ${DISTDIR}/${A5}
+
+}
+
+src_compile() {
+
+ LDFLAGS="$LDFLAGS -lresolv" try ./configure --host=${CHOST} \
+ --prefix=/usr --sysconfdir=/etc/squid \
+ --localstatedir=/var/state/squid \
+ --libexecdir=/usr/lib/squid \
+ --enable-useragent-log \
+ --enable-async-io --enable-icmp \
+ --enable-ipf-transparent --enable-cachemgr-hostname=${CHOST} \
+ --enable-arp-acl
+ try make
+ cd ${S}/auth_modules/PAM
+ try make
+ cd ../SMB
+ try make
+ if [ "`use ldap`" ] ; then
+ cd ../LDAP
+ try make
+ fi
+ cd ../NCSA
+ try make
+
+}
+
+src_install() {
+
+
+ dodir /usr/{bin,lib/squid}
+ dodir /etc/squid
+ dodir /var/squid
+ chown squid.daemon ${D}/var/squid
+ try make install prefix=${D}/usr sysconfdir=${D}/etc/squid \
+ localstatedir=${D}/var/state/squid libexecdir=${D}/usr/lib/squid
+ into /usr
+ cd auth_modules
+ if [ "`use ldap`" ] ; then
+ dobin LDAP/squid_ldap_auth
+ fi
+ dobin PAM/pam_auth SMB/smb_auth NCSA/ncsa_auth
+ cd ../doc
+ doman tree.3
+ dodoc *.txt
+ cd ..
+ dodoc README QUICKSTART CONTRIBUTORS COPYRIGHT COPYING CREDITS
+ dodoc ChangeLog TODO
+ cp ${FILESDIR}/squid.conf ${D}/etc/squid
+ dodir /etc/rc.d/init.d
+ cp ${FILESDIR}/squid ${D}/etc/rc.d/init.d
+# rm -r ${D}/var/squid
+ dodir /var/log/squid
+ dodir /var/cache/squid
+ fowners squid.daemon /var/log/squid
+ fowners squid.daemon /var/cache/squid
+ fperms 755 /var/log/squid
+ fperms 755 /var/cache/squid
+}
+
+pkg_config() {
+
+ . ${ROOT}/etc/rc.d/config/functions
+
+ einfo "Generating symlinks..."
+ ${ROOT}/usr/sbin/rc-update add squid
+
+}