summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrad Teaford Cowan <bcowan@gentoo.org>2003-05-05 05:36:36 +0000
committerBrad Teaford Cowan <bcowan@gentoo.org>2003-05-05 05:36:36 +0000
commitb7dba4fa5ff29e6abebac7faf8895dd870722dd5 (patch)
tree41ecee171b7946a7fe8ff09af60e7c44602fc141 /net-www
parentversion bump (diff)
downloadgentoo-2-b7dba4fa5ff29e6abebac7faf8895dd870722dd5.tar.gz
gentoo-2-b7dba4fa5ff29e6abebac7faf8895dd870722dd5.tar.bz2
gentoo-2-b7dba4fa5ff29e6abebac7faf8895dd870722dd5.zip
version bump with copy/paste support
Diffstat (limited to 'net-www')
-rw-r--r--net-www/dillo/ChangeLog7
-rw-r--r--net-www/dillo/dillo-0.7.2.ebuild99
-rw-r--r--net-www/dillo/files/digest-dillo-0.7.22
3 files changed, 107 insertions, 1 deletions
diff --git a/net-www/dillo/ChangeLog b/net-www/dillo/ChangeLog
index a2ba9ea5b703..6fdc487c652e 100644
--- a/net-www/dillo/ChangeLog
+++ b/net-www/dillo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-www/dillo
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/dillo/ChangeLog,v 1.17 2003/03/14 09:45:57 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/dillo/ChangeLog,v 1.18 2003/05/05 05:36:36 bcowan Exp $
+
+*dillo-0.7.2 (5 May 2003)
+
+ 5 May 2003; Brad Cowan <bcowan@gentoo.org> dillo-0.7.2.ebuild:
+ version bump with copy/paste support.
*dillo-0.7.1.2 (13 Mar 2003)
diff --git a/net-www/dillo/dillo-0.7.2.ebuild b/net-www/dillo/dillo-0.7.2.ebuild
new file mode 100644
index 000000000000..dd619416bbd8
--- /dev/null
+++ b/net-www/dillo/dillo-0.7.2.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/dillo/dillo-0.7.2.ebuild,v 1.1 2003/05/05 05:36:36 bcowan Exp $
+
+inherit flag-o-matic
+
+IUSE="ipv6 kde gnome mozilla"
+
+S=${WORKDIR}/${P}
+S2=${WORKDIR}/gentoo-dillo-extras-patch
+
+DESCRIPTION="Lean GTK+-based web browser"
+HOMEPAGE="http://dillo.auriga.wearlab.de/"
+SRC_URI="http://dillo.auriga.wearlab.de/download/${P}.tar.bz2
+ mirror://gentoo/dillo-gentoo-extras-patch.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~mips ~hppa"
+
+replace-flags "-O2 -mcpu=k6" "-O2 -mcpu=pentium"
+
+DEPEND="=x11-libs/gtk+-1.2*
+ >=media-libs/jpeg-6b
+ >=sys-libs/zlib-1.1.3
+ >=media-libs/libpng-1.2.1"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ if [ "${DILLO_ICONSET}" = "kde" ]
+ then
+ ebegin "Using Konqueror style icon set"
+ cp ${S2}/pixmaps.konq.h ${S}/src/pixmaps.h
+ eend 0
+ elif [ "${DILLO_ICONSET}" = "gnome" ]
+ then
+ ebegin "Using Ximian style icon set"
+ cp ${S2}/pixmaps.ximian.h ${S}/src/pixmaps.h
+ eend 0
+ elif [ "${DILLO_ICONSET}" = "mozilla" ]
+ then
+ ebegin "Using Netscape style icon set"
+ cp ${S2}/pixmaps.netscape.h ${S}/src/pixmaps.h
+ eend 0
+ elif [ "${DILLO_ICONSET}" = "bold" ]
+ then
+ ebegin "Using bold style icon set"
+ cp ${S2}/pixmaps.bold.h ${S}/src/pixmaps.h
+ eend 0
+ elif [ "${DILLO_ICONSET}" = "trans" ]
+ then
+ ebegin "Using transparent style icon set"
+ cp ${S2}/pixmaps.trans.h ${S}/src/pixmaps.h
+ eend 0
+ else
+ ebegin "Using default Dillo icon set"
+ eend 0
+ fi
+}
+
+src_compile() {
+ econf `use_enable ipv6` || die
+ emake || make || die
+}
+
+src_install() {
+ dodir /etc
+ einstall
+ dodoc AUTHORS COPYING ChangeLog* INSTALL README NEWS
+ docinto doc
+ dodoc doc/*.txt doc/README
+}
+
+pkg_postinst() {
+ einfo "This ebuild for dillo comes with different toolbar icons"
+ einfo "If you want mozilla style icons then try"
+ einfo " DILLO_ICONSET=\"mozilla\" emerge dillo"
+ einfo
+ einfo "If you prefer konqueror style icons then try"
+ einfo " DILLO_ICONSET=\"kde\" emerge dillo"
+ einfo
+ einfo "If you prefer ximian gnome style icons then try"
+ einfo " DILLO_ICONSET=\"gnome\" emerge dillo"
+ einfo
+ einfo "If you prefer bold style icons then try"
+ einfo " DILLO_ICONSET=\"bold\" emerge dillo"
+ einfo
+ einfo "If you prefer transparent style icons then try"
+ einfo " DILLO_ICONSET=\"trans\" emerge dillo"
+ einfo
+ einfo "If the DILLO_ICONSET variable is not set, you will get the"
+ einfo "default iconset"
+ einfo
+ einfo "To see what the icons look like, please point your browser to:"
+ einfo "http://dillo.auriga.wearlab.de/Icons/"
+ einfo
+}
diff --git a/net-www/dillo/files/digest-dillo-0.7.2 b/net-www/dillo/files/digest-dillo-0.7.2
new file mode 100644
index 000000000000..7fab05f191af
--- /dev/null
+++ b/net-www/dillo/files/digest-dillo-0.7.2
@@ -0,0 +1,2 @@
+MD5 8072ff85bde54f9e421ddadd642d6722 dillo-0.7.2.tar.bz2 329088
+MD5 e803699d5472790046837e8d33b3db39 dillo-gentoo-extras-patch.tar.bz2 26644