summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2006-05-11 08:14:18 +0000
committerStefan Schweizer <genstef@gentoo.org>2006-05-11 08:14:18 +0000
commit7dea00721c6ac24891b3bd29fef303af950bdc47 (patch)
tree17b7a1667395fb2ed11d615f8cb5da4cacfb6f78 /net-www
parentCompile fix - clean up usage of LDFLAGS/CC/CXX to allow them to work with mul... (diff)
downloadgentoo-2-7dea00721c6ac24891b3bd29fef303af950bdc47.tar.gz
gentoo-2-7dea00721c6ac24891b3bd29fef303af950bdc47.tar.bz2
gentoo-2-7dea00721c6ac24891b3bd29fef303af950bdc47.zip
more complete as-needed, ebuild cleanups
(Portage version: 2.1_pre10-r4)
Diffstat (limited to 'net-www')
-rw-r--r--net-www/gnash/files/gnash-as-needed.diff17
-rw-r--r--net-www/gnash/gnash-0.7.1.ebuild8
2 files changed, 19 insertions, 6 deletions
diff --git a/net-www/gnash/files/gnash-as-needed.diff b/net-www/gnash/files/gnash-as-needed.diff
index 1b64cc802189..627f348f6873 100644
--- a/net-www/gnash/files/gnash-as-needed.diff
+++ b/net-www/gnash/files/gnash-as-needed.diff
@@ -5,7 +5,7 @@ diff -u gnash-0.7.1/libbase/Makefile.am.orig gnash-0.7.1/libbase/Makefile.am
utf8.cpp \
utility.cpp \
zlib_adapter.cpp
-+libgnashbase_la_LIBADD = $(JPEG_LIBS)
++libgnashbase_la_LIBADD = $(JPEG_LIBS) $(ZLIB_LIBS)
noinst_HEADERS = \
container.h \
@@ -16,7 +16,20 @@ diff -u gnash-0.7.1/server/Makefile.am.orig gnash-0.7.1/server/Makefile.am
text.cpp \
array.cpp \
types.cpp $(MP3_HANDLER)
-+libgnashserver_la_LIBADD = libgnashasobjs.la $(MAD_LIBS) $(LIBXML_LIBS) $(OPENGL_LIBS)
++libgnashserver_la_LIBADD = libgnashasobjs.la $(MP3_LIBS) $(LIBXML_LIBS) $(OPENGL_LIBS) $(ZLIB_LIBS)
noinst_HEADERS = $(as_incls) \
action.h \
+diff -u gnash-0.7.1/plugin/klash/Makefile.am.orig gnash-0.7.1/plugin/klash/Makefile.am
+--- gnash-0.7.1/plugin/klash/Makefile.am.orig 2006-05-11 01:08:17.000000000 +0200
++++ gnash-0.7.1/plugin/klash/Makefile.am 2006-05-11 01:10:37.000000000 +0200
+@@ -116,7 +116,8 @@
+ ../../server/libgnashserver.la \
+ ../../server/libgnashasobjs.la \
+ ../../libgeometry/libgnashgeo.la \
+- ../../libbase/libgnashbase.la
++ ../../libbase/libgnashbase.la \
++ $(LIB_QT)
+
+
+ CLEANFILES = klash_part.moc klash.moc
diff --git a/net-www/gnash/gnash-0.7.1.ebuild b/net-www/gnash/gnash-0.7.1.ebuild
index 6a968780ecbe..7f8dc864a535 100644
--- a/net-www/gnash/gnash-0.7.1.ebuild
+++ b/net-www/gnash/gnash-0.7.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/gnash/gnash-0.7.1.ebuild,v 1.2 2006/05/10 00:27:36 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/gnash/gnash-0.7.1.ebuild,v 1.3 2006/05/11 08:14:18 genstef Exp $
inherit nsplugins kde-functions autotools
@@ -11,7 +11,7 @@ SRC_URI="ftp://ftp.gnu.org/pub/gnu/${PN}/${PV}/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~ppc ~x86"
-IUSE="dmalloc mp3 nsplugin nptl xml kde gtk"
+IUSE="dmalloc mp3 nsplugin nptl xml kde gtk video_cards_i810"
DEPEND="sys-libs/zlib
media-libs/jpeg
@@ -55,8 +55,8 @@ src_compile() {
$(use_enable nptl pthreads) \
$(use_enable xml) \
$(use_enable gtk glext) \
+ $(use_enable video_cards_i810 i810-lod-bias) \
--with-plugindir=/opt/netscape/plugins \
- ${myconf} \
|| die "econf failed"
emake || die "emake failed"
# fails when disabled
@@ -67,7 +67,7 @@ src_compile() {
src_install() {
make DESTDIR=${D} install || die "make install failed"
use nsplugin && inst_plugin /opt/netscape/plugins/libgnashplugin.so \
- || rm ${D}//opt/netscape/plugins/libgnashplugin.so
+ || rm ${D}/opt/netscape/plugins/libgnashplugin.so
dodoc AUTHORS ChangeLog NEWS README
}