summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorD.M.D. Ljungmark <spider@gentoo.org>2002-04-23 22:27:02 +0000
committerD.M.D. Ljungmark <spider@gentoo.org>2002-04-23 22:27:02 +0000
commit75b70a34350b21544e65a03c9e0299adcea89f47 (patch)
treefaaf0436d651eb30b793fb19cd9cc84583f33fb9 /net-www
parentfix build errors (diff)
downloadgentoo-2-75b70a34350b21544e65a03c9e0299adcea89f47.tar.gz
gentoo-2-75b70a34350b21544e65a03c9e0299adcea89f47.tar.bz2
gentoo-2-75b70a34350b21544e65a03c9e0299adcea89f47.zip
new galeon that works with mozilla 1.0-rc
Diffstat (limited to 'net-www')
-rw-r--r--net-www/galeon/ChangeLog7
-rw-r--r--net-www/galeon/files/digest-galeon-1.2.11
-rw-r--r--net-www/galeon/galeon-1.2.1.ebuild86
3 files changed, 93 insertions, 1 deletions
diff --git a/net-www/galeon/ChangeLog b/net-www/galeon/ChangeLog
index ce885a56233a..592bba54ccf2 100644
--- a/net-www/galeon/ChangeLog
+++ b/net-www/galeon/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-www/galeon
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-www/galeon/ChangeLog,v 1.6 2002/03/31 10:14:05 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/galeon/ChangeLog,v 1.7 2002/04/23 22:27:02 spider Exp $
+
+*galeon-1.2.1 (24 Apr 2002)
+ 24 Apr 2002; Spider <spider@gentoo.org> galeon-1.2.1.ebuild :
+ add --disable-werror to the build
+ update with latest and greatest mozilla
*galeon-1.2.0-r3 (31 Mar 2002)
diff --git a/net-www/galeon/files/digest-galeon-1.2.1 b/net-www/galeon/files/digest-galeon-1.2.1
new file mode 100644
index 000000000000..7989f634d596
--- /dev/null
+++ b/net-www/galeon/files/digest-galeon-1.2.1
@@ -0,0 +1 @@
+MD5 4d058f47f0f626dac3fda70c1c332052 galeon-1.2.1.tar.gz 3931284
diff --git a/net-www/galeon/galeon-1.2.1.ebuild b/net-www/galeon/galeon-1.2.1.ebuild
new file mode 100644
index 000000000000..23b5ed13df7a
--- /dev/null
+++ b/net-www/galeon/galeon-1.2.1.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Martin Schlemmer <azarah@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-www/galeon/galeon-1.2.1.ebuild,v 1.1 2002/04/23 22:27:02 spider Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A small web-browser for gnome that uses mozillas render engine"
+SRC_URI="http://download.sourceforge.net/${PN}/${P}.tar.gz
+ http://prdownloads.sourceforge.net/${PN}/${P}.tar.gz"
+HOMEPAGE="http://galeon.sourceforge.net"
+
+DEPEND="~net-www/mozilla-1.0_rc1
+ >=gnome-base/gnome-libs-1.4.1.4
+ >=gnome-base/libglade-0.17-r1
+ >=gnome-base/gnome-vfs-1.0.2-r1
+ >=gnome-base/gconf-1.0.7-r2
+ >=gnome-base/oaf-0.6.7
+ >=dev-libs/libxml-1.8.16
+ >=media-libs/gdk-pixbuf-0.16.0-r1
+ nls? ( sys-devel/gettext
+ >=dev-util/intltool-0.11 )"
+
+ # bonobo? ( >=gnome-base/bonobo-1.0.19-r1 )
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+ patch -p1 < ${FILESDIR}/galeon-1.2.0-gcc3.patch || die
+
+}
+
+src_compile() {
+
+ local myconf
+
+ use nls || myconf="${myconf} --disable-nls"
+ # use bonobo && myconf="${myconf} --enable-gnome-file-selector"
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --sysconfdir=/etc \
+ --localstatedir=/var/lib \
+ --with-mozilla-libs=${MOZILLA_FIVE_HOME} \
+ --with-mozilla-includes=${MOZILLA_FIVE_HOME}/include \
+ --without-debug --disable-werror \
+ --disable-applet \
+ --disable-install-schemas \
+ --enable-nautilus-view=auto \
+ ${myconf} || die
+
+ emake || die
+}
+
+src_install() {
+
+ # galeon-config-tool was rewritten for 1.2.0 and causes sandbox
+ # violations if gconfd is shut down... The schemas seem to install
+ # fine without it (at least it seems like it... *sigh*)
+ #gconftool --shutdown
+
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ sysconfdir=${D}/etc \
+ localstatedir=${D}/var/lib \
+ install || die
+
+ dodoc AUTHORS ChangeLog COPYING* FAQ NEWS README TODO THANKS
+}
+
+pkg_postinst() {
+
+ galeon-config-tool --fix-gconf-permissions
+ galeon-config-tool --pkg-install-schemas
+ scrollkeeper-update
+
+ if [ -z "`use gnome`" ]
+ then
+ einfo "Please remerge libglade with gnome support, or else galeon"
+ einfo "will not be able to start up."
+ einfo
+ einfo 'To do this, type: '
+ einfo 'USE="gnome" emerge libglade'
+ fi
+}