summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-04-15 11:12:07 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-04-15 11:12:07 +0000
commit742bb34fb3ab8ec2f7ae3552e115db8c4728cc12 (patch)
tree74baf00eb873857b5b331bc8e63eb13e18391f66 /net-www
parentRemoved voodoo4 and voodoo5 as they are not being used anywhere (diff)
downloadgentoo-2-742bb34fb3ab8ec2f7ae3552e115db8c4728cc12.tar.gz
gentoo-2-742bb34fb3ab8ec2f7ae3552e115db8c4728cc12.tar.bz2
gentoo-2-742bb34fb3ab8ec2f7ae3552e115db8c4728cc12.zip
Version bump
Diffstat (limited to 'net-www')
-rw-r--r--net-www/htdig/ChangeLog10
-rw-r--r--net-www/htdig/files/digest-htdig-3.1.63
-rw-r--r--net-www/htdig/htdig-3.1.6.ebuild58
3 files changed, 70 insertions, 1 deletions
diff --git a/net-www/htdig/ChangeLog b/net-www/htdig/ChangeLog
index 06cb50beb1b6..8145b0441f1a 100644
--- a/net-www/htdig/ChangeLog
+++ b/net-www/htdig/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-www/htdig
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-www/htdig/ChangeLog,v 1.3 2002/03/15 12:10:18 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/htdig/ChangeLog,v 1.4 2002/04/15 11:12:07 seemant Exp $
+
+*htdig-3.1.6 (15 Apr 2002)
+
+ 15 Apr 2002; Seemant Kulleen <seemant@gentoo.org> htdig-3.1.6.ebuild
+ files/digest-htdig-3.1.6
+
+ Version bump. This puts the config files properly, etc etc. Needs heavy
+ testing, though.
9 Mar 2002; Dan Armak <danarmak@gentoo.org> changelog:
diff --git a/net-www/htdig/files/digest-htdig-3.1.6 b/net-www/htdig/files/digest-htdig-3.1.6
new file mode 100644
index 000000000000..5bb67f4431af
--- /dev/null
+++ b/net-www/htdig/files/digest-htdig-3.1.6
@@ -0,0 +1,3 @@
+MD5 7a2f20d8d6149efd8d119bb2ebf55f23 htdig-3.1.6.tar.gz 2068675
+MD5 99538310638935aff7cacc98b430f6bb htdig_3_1_x.diff.zip 1521
+MD5 c9b976f90a0f5cf68802770d0183c906 htdig_3_1_x_noindex.diff.zip 530
diff --git a/net-www/htdig/htdig-3.1.6.ebuild b/net-www/htdig/htdig-3.1.6.ebuild
new file mode 100644
index 000000000000..ce1f625d318c
--- /dev/null
+++ b/net-www/htdig/htdig-3.1.6.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-www/htdig/htdig-3.1.6.ebuild,v 1.1 2002/04/15 11:12:07 seemant Exp ${PN}/${PN}-3.1.5-r2.ebuild,v 1.2 2002/03/15 12:10:18 danarmak Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="HTTP/HTML indexing and searching system"
+SRC_URI="http://www.htdig.org/files/${P}.tar.gz"
+HOMEPAGE="http://www.htdig.org"
+
+DEPEND=">=sys-libs/zlib-1.1.3
+ app-arch/unzip"
+
+src_compile() {
+
+cd ${S}
+ ./configure \
+ --prefix=/usr \
+ --with-config-dir=/etc/${PN} \
+ --with-image-dir=/home/httpd/htdocs/${PN} \
+ --with-search-dir=/home/httpd/htdocs/${PN} \
+ --with-cgi-bin-dir=/home/httpd \
+ --with-common-dir=/usr/share/${PN} \
+ --with-database-dir=/var/${PN} \
+ --with-image-dir=/home/httpd/images/${PN} \
+ --with-search-dir=/home/httpd/htdocs/${PN} \
+ --with-default-config-file=/etc/${PN}/${PN}.conf \
+ || die
+
+ emake || die
+
+}
+
+src_install () {
+
+ make \
+ DESTDIR=${D} \
+ CONFIG_DIR=${D}/etc/${PN} \
+ IMAGE_DIR=${D}/home/httpd/htdocs/${PN} \
+ SEARCH_DIR=${D}/home/httpd/htdocs/${PN} \
+ CGIBIN_DIR=${D}/home/httpd \
+ COMMON_DIR=${D}/usr/share/${PN} \
+ DATABASE_DIR=${D}/var/${PN} \
+ IMAGE_DIR=${D}/home/httpd/images/${PN} \
+ SEARCH_DIR=${D}/home/httpd/htdocs/htdig \
+ DEFAULT_CONFIG_FILE=${D}/etc/${PN}/${PN}.conf \
+ exec_prefix=${D}/usr/bin \
+ install || die
+
+ dodoc ChangeLog COPYING README
+ dohtml -r htdoc
+
+ insinto /etc/conf.d
+ doins installdir/htdig.conf
+
+ dosed /etc/httpd/htdig.conf
+ dosed /usr/bin/rundig
+}