summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoseph Jezak <josejx@gentoo.org>2005-09-29 07:07:30 +0000
committerJoseph Jezak <josejx@gentoo.org>2005-09-29 07:07:30 +0000
commit6678394249e369b46eaf34c661f7de7dfda83e8e (patch)
treeb8c7d5dcceeb9c09042f5a979acbfd7d1f23b3a2 /net-www
parentAdded gecko-sdk for mplayerplug-in. (diff)
downloadgentoo-2-6678394249e369b46eaf34c661f7de7dfda83e8e.tar.gz
gentoo-2-6678394249e369b46eaf34c661f7de7dfda83e8e.tar.bz2
gentoo-2-6678394249e369b46eaf34c661f7de7dfda83e8e.zip
Added latest version, see bug #100809.
(Portage version: 2.0.52-r1)
Diffstat (limited to 'net-www')
-rw-r--r--net-www/mplayerplug-in/Manifest8
-rw-r--r--net-www/mplayerplug-in/files/digest-mplayerplug-in-3.111
-rw-r--r--net-www/mplayerplug-in/mplayerplug-in-3.11.ebuild67
3 files changed, 73 insertions, 3 deletions
diff --git a/net-www/mplayerplug-in/Manifest b/net-www/mplayerplug-in/Manifest
index 2bc4bc5c032a..f4d8d68d101e 100644
--- a/net-www/mplayerplug-in/Manifest
+++ b/net-www/mplayerplug-in/Manifest
@@ -1,6 +1,8 @@
-MD5 66c156160ef60780ee4c80a28873e766 metadata.xml 250
-MD5 a93db3f864de724c0408dc08506f2d90 mplayerplug-in-2.80.ebuild 1458
MD5 2184d7fa0813c1a889168efe9b8957ba ChangeLog 7499
+MD5 66c156160ef60780ee4c80a28873e766 metadata.xml 250
MD5 dd12cc307a2fc2c00237b06a38cd20c5 mplayerplug-in-2.85.ebuild 1464
-MD5 8642e3be6b1af51cbbf7e7790cc8ba12 files/digest-mplayerplug-in-2.80 71
+MD5 a93db3f864de724c0408dc08506f2d90 mplayerplug-in-2.80.ebuild 1458
+MD5 3f1883b6d8c2c3f8af8569c87d78f32b mplayerplug-in-3.11.ebuild 1921
MD5 c2e30e3c9bd430344299015704bc28b6 files/digest-mplayerplug-in-2.85 71
+MD5 8c3b348cd7951d7c21c115f602e22f31 files/digest-mplayerplug-in-3.11 71
+MD5 8642e3be6b1af51cbbf7e7790cc8ba12 files/digest-mplayerplug-in-2.80 71
diff --git a/net-www/mplayerplug-in/files/digest-mplayerplug-in-3.11 b/net-www/mplayerplug-in/files/digest-mplayerplug-in-3.11
new file mode 100644
index 000000000000..80f4a762dc19
--- /dev/null
+++ b/net-www/mplayerplug-in/files/digest-mplayerplug-in-3.11
@@ -0,0 +1 @@
+MD5 41970663e6855beb5205077f4cb0ae29 mplayerplug-in-3.11.tar.gz 197034
diff --git a/net-www/mplayerplug-in/mplayerplug-in-3.11.ebuild b/net-www/mplayerplug-in/mplayerplug-in-3.11.ebuild
new file mode 100644
index 000000000000..9aa3849933f6
--- /dev/null
+++ b/net-www/mplayerplug-in/mplayerplug-in-3.11.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/mplayerplug-in/mplayerplug-in-3.11.ebuild,v 1.1 2005/09/29 07:07:30 josejx Exp $
+
+inherit nsplugins toolchain-funcs multilib
+
+DESCRIPTION="mplayer plug-in for Gecko based browsers"
+HOMEPAGE="http://mplayerplug-in.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 -hppa ~ia64 ~ppc ~sparc ~x86"
+IUSE="gecko-sdk"
+
+DEPEND=">=media-video/mplayer-0.92
+ gecko-sdk? ( net-libs/gecko-sdk )
+ !gecko-sdk? || ( >=www-client/mozilla-1.6 www-client/mozilla-firefox)
+ >=x11-libs/gtk+-2.2.0
+ dev-libs/atk*
+ >=dev-libs/glib-2.2.0
+ >=x11-libs/pango-1.2.1"
+
+S=${WORKDIR}/${PN}
+
+PLUGINS="gmp rm qt wmp"
+
+src_compile() {
+ local myconf
+
+ if ! use gecko-sdk; then
+ einfo Configuring to build using gecko-sdk
+ myconf="${myconf} --with-gecko-sdk=/usr/$(get_libdir)/gecko-sdk"
+ fi
+
+ ### Force gtk2 since mozilla only uses gtk2 now
+ econf --enable-gtk2
+ ${myconf} || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ exeinto /opt/netscape/plugins
+ doexe mplayerplug-in.so || die "plugin failed"
+ inst_plugin /opt/netscape/plugins/mplayerplug-in.so
+
+ insinto /opt/netscape/plugins
+ doins mplayerplug-in.xpt || die "xpt failed"
+ inst_plugin /opt/netscape/plugins/mplayerplug-in.xpt
+
+ for plugin in ${PLUGINS}; do
+ ### Install the plugin
+ exeinto /opt/netscape/plugins
+ doexe "mplayerplug-in-${plugin}.so" || die "plugin ${plugin} failed"
+ inst_plugin "/opt/netscape/plugins/mplayerplug-in-${plugin}.so"
+ ### Install the xpt
+ insinto /opt/netscape/plugins
+ doins "mplayerplug-in-${plugin}.xpt" || die "plugin ${plugin} xpt failed"
+ inst_plugin "/opt/netscape/plugins/mplayerplug-in-${plugin}.xpt"
+ done
+
+ insinto /etc
+ doins mplayerplug-in.conf
+
+ dodoc ChangeLog INSTALL README DOCS/tech/*.txt
+}