summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2003-08-15 06:14:03 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2003-08-15 06:14:03 +0000
commita9c6b8a2dd3a130abe864d65e47abab1e8fdcb5a (patch)
treed592c42e2693e6cb908be659ebf81b367910da0f /net-www/pcgi
parentinitial commit (diff)
downloadgentoo-2-a9c6b8a2dd3a130abe864d65e47abab1e8fdcb5a.tar.gz
gentoo-2-a9c6b8a2dd3a130abe864d65e47abab1e8fdcb5a.tar.bz2
gentoo-2-a9c6b8a2dd3a130abe864d65e47abab1e8fdcb5a.zip
initial commit
Diffstat (limited to 'net-www/pcgi')
-rw-r--r--net-www/pcgi/ChangeLog10
-rw-r--r--net-www/pcgi/Manifest3
-rw-r--r--net-www/pcgi/files/digest-pcgi-2.0_alpha52
-rw-r--r--net-www/pcgi/metadata.xml9
-rw-r--r--net-www/pcgi/pcgi-2.0_alpha5.ebuild50
5 files changed, 73 insertions, 1 deletions
diff --git a/net-www/pcgi/ChangeLog b/net-www/pcgi/ChangeLog
new file mode 100644
index 000000000000..9c5e849c7f49
--- /dev/null
+++ b/net-www/pcgi/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-www/pcgi
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/pcgi/ChangeLog,v 1.1 2003/08/15 06:13:59 robbat2 Exp $
+
+*pcgi-2.0_alpha5 (14 Aug 2003)
+
+ 14 Aug 2003; Robin H. Johnson <robbat2@gentoo.org> metadata.xml,
+ pcgi-2.0_alpha5.ebuild:
+ initial commit
+
diff --git a/net-www/pcgi/Manifest b/net-www/pcgi/Manifest
index 1486b1fcdac7..861c87cc3602 100644
--- a/net-www/pcgi/Manifest
+++ b/net-www/pcgi/Manifest
@@ -1,3 +1,4 @@
-MD5 63a36b6a6937ed5e25a4da6cec0fd5ab pcgi-2.0_alpha5.ebuild 1285
+MD5 c664d2c27dd0e77ec3c6e24a3a0715f8 pcgi-2.0_alpha5.ebuild 1606
+MD5 c905bd409985cdc70bf755dfaacf1a68 ChangeLog 349
MD5 60e3a7ee1268e32bce296a6076f736c6 metadata.xml 252
MD5 6cdcecf891e772282d2a8a46abcfb09b files/digest-pcgi-2.0_alpha5 137
diff --git a/net-www/pcgi/files/digest-pcgi-2.0_alpha5 b/net-www/pcgi/files/digest-pcgi-2.0_alpha5
new file mode 100644
index 000000000000..e9f0d46e7c1c
--- /dev/null
+++ b/net-www/pcgi/files/digest-pcgi-2.0_alpha5
@@ -0,0 +1,2 @@
+MD5 a17f36b86b6e489797d8e52f1ba48efe Zope-2.6.1-src.tgz 2318685
+MD5 b9fa9dd4d8de4e3428974f63360dc679 PCGI-HOWTO-1998-08-13.html.bz2 6483
diff --git a/net-www/pcgi/metadata.xml b/net-www/pcgi/metadata.xml
new file mode 100644
index 000000000000..243bb419b1ee
--- /dev/null
+++ b/net-www/pcgi/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>net-www</herd>
+<maintainer>
+ <email>robbat2@gentoo.org</email>
+ <name>Robin Johnson</name>
+</maintainer>
+</pkgmetadata>
diff --git a/net-www/pcgi/pcgi-2.0_alpha5.ebuild b/net-www/pcgi/pcgi-2.0_alpha5.ebuild
new file mode 100644
index 000000000000..9c7f425a65d6
--- /dev/null
+++ b/net-www/pcgi/pcgi-2.0_alpha5.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/pcgi/pcgi-2.0_alpha5.ebuild,v 1.1 2003/08/15 06:13:59 robbat2 Exp $
+
+# this package is ONLY available inside the Zope tarball!!!
+ZOPE_PV=2.6.1
+ZOPE_P=Zope-${ZOPE_PV}-src
+S="${WORKDIR}/${ZOPE_P}/pcgi"
+
+# the only real docs about it are on the author's homepage
+# the html.bz2 file is a copy of http://starship.python.net/crew/jbauer/persistcgi/howto/index.html, renamed.
+# this is specifically done as every link I have seen is to the old URL of the
+# author
+DOCDATE="1998-08-13"
+
+MY_PV="${PV/_alpha/a}"
+
+DESCRIPTION="Jeff Bauer's Persistent CGI"
+HOMEPAGE="http://starship.python.net/crew/jbauer/persistcgi/"
+SRC_URI="http://www.zope.org/Products/Zope/${ZOPE_PV}/${ZOPE_P}.tgz
+ mirror://gentoo/PCGI-HOWTO-${DOCDATE}.html.bz2"
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND="${DEPEND}
+ virtual/glibc"
+RDEPEND="${RDEPEND}
+ virtual/glibc
+ virtual/python"
+
+src_compile() {
+ econf || die "econf failed"
+ emake all creosote || die "emake failed"
+}
+
+src_install() {
+ into /usr
+ dodir /usr/bin
+ dodoc ${WORKDIR}/CGI-HOWTO-1998-08-13.html
+ newbin pcgi-wrapper pcgi-wrapper${MY_PV}
+ dosym /usr/bin/pcgi-wrapper${MY_PV} /usr/bin/pcgi-wrapper
+ dodoc MrCreosote/README.MrCreosote README Test/README.parseinfo
+ newdoc Util/README README.Util
+ dobin MrCreosote/pcgi-creosote MrCreosote/creosote.py
+ dobin Util/killpcgi.py Util/pcgifile.py
+ dobin pcgi_publisher.py
+ newbin Test/parseinfo pcgi-parseinfo
+ cp -ra Example ${D}/usr/share/doc/${PF}/
+}