summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-12-25 19:39:30 +0000
committerMike Frysinger <vapier@gentoo.org>2003-12-25 19:39:30 +0000
commit7aa95a89700a87f047e0aa4f1768ec77ca1b92c6 (patch)
tree0930a3f0aa9bd3b9240b67af16bae923d381da50 /net-www/monkeyd
parenticc support #36002 (diff)
downloadgentoo-2-7aa95a89700a87f047e0aa4f1768ec77ca1b92c6.tar.gz
gentoo-2-7aa95a89700a87f047e0aa4f1768ec77ca1b92c6.tar.bz2
gentoo-2-7aa95a89700a87f047e0aa4f1768ec77ca1b92c6.zip
ver bump
Diffstat (limited to 'net-www/monkeyd')
-rw-r--r--net-www/monkeyd/ChangeLog7
-rw-r--r--net-www/monkeyd/files/digest-monkeyd-0.8.01
-rw-r--r--net-www/monkeyd/monkeyd-0.8.0.ebuild49
3 files changed, 56 insertions, 1 deletions
diff --git a/net-www/monkeyd/ChangeLog b/net-www/monkeyd/ChangeLog
index c93e574d4738..6ce7177b384d 100644
--- a/net-www/monkeyd/ChangeLog
+++ b/net-www/monkeyd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-www/monkeyd
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/monkeyd/ChangeLog,v 1.4 2003/06/13 18:40:53 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/monkeyd/ChangeLog,v 1.5 2003/12/25 19:39:30 vapier Exp $
+
+*monkeyd-0.8.0 (25 Dec 2003)
+
+ 25 Dec 2003; Mike Frysinger <vapier@gentoo.org> :
+ Version bump + move to /var/www + index.html overwrite fix #35712.
*monkeyd-0.7.1 (13 Jun 2003)
diff --git a/net-www/monkeyd/files/digest-monkeyd-0.8.0 b/net-www/monkeyd/files/digest-monkeyd-0.8.0
new file mode 100644
index 000000000000..86448bbcabfe
--- /dev/null
+++ b/net-www/monkeyd/files/digest-monkeyd-0.8.0
@@ -0,0 +1 @@
+MD5 fa0afd215e9189db534b3c9537543c30 monkey-0.8.0.tar.gz 76178
diff --git a/net-www/monkeyd/monkeyd-0.8.0.ebuild b/net-www/monkeyd/monkeyd-0.8.0.ebuild
new file mode 100644
index 000000000000..a5da9686e5b2
--- /dev/null
+++ b/net-www/monkeyd/monkeyd-0.8.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/monkeyd/monkeyd-0.8.0.ebuild,v 1.1 2003/12/25 19:39:30 vapier Exp $
+
+WEBROOT=/var/www/localhost
+
+MY_P="${PN/d}-${PV}"
+DESCRIPTION="fast, efficient, (REALLY) small, and easy to configure web server"
+HOMEPAGE="http://monkeyd.sourceforge.net/"
+SRC_URI="http://monkeyd.sourceforge.net/versions/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND="virtual/glibc"
+RDEPEND="virtual/glibc"
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ ./configure \
+ --prefix=/usr \
+ --bindir=/usr/bin \
+ --cgibin=${WEBROOT}/cgi-bin \
+ --sysconfdir=/etc/${PN} \
+ --datadir=${WEBROOT}/htdocs \
+ --logdir=/var/log/${PN} \
+ --lang=en \
+ || die
+ emake CFLAGS="${CFLAGS}" || die
+}
+
+src_install() {
+ make \
+ PREFIX=${D}/usr \
+ BINDIR=${D}/usr/bin \
+ CGIBIN=${D}${WEBROOT}/cgi-bin \
+ SYSCONFDIR=${D}/etc/${PN} \
+ DATADIR=${D}${WEBROOT}/htdocs \
+ LOGDIR=${D}/var/log/${PN} \
+ install \
+ || die
+ [ -e ${ROOT}/${WEBROOT}/htdocs/index.html ] && mv ${D}${WEBROOT}/htdocs/{index,index-monkey}.html
+ dosed "s:/var/log/monkeyd/monkey.pid:/var/run/monkey.pid:" /etc/monkeyd/monkey.conf
+ exeinto /etc/init.d ; newexe ${FILESDIR}/monkeyd.init.d monkeyd
+ insinto /etc/conf.d ; newins ${FILESDIR}/monkeyd.conf.d monkeyd
+ dodoc MODULES HowItWorks.txt README ChangeLog
+}