summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicholas Jones <carpaski@gentoo.org>2002-06-24 16:11:58 +0000
committerNicholas Jones <carpaski@gentoo.org>2002-06-24 16:11:58 +0000
commit08c1c59eb671907effdc64df6b73c5f7a9853ebb (patch)
treec7c7a8593a85ab8d9d27f67d1a8b4c9d950ca532 /net-www/mod_ssl
parentmasked out drip (x86 asm probs) (diff)
downloadgentoo-2-08c1c59eb671907effdc64df6b73c5f7a9853ebb.tar.gz
gentoo-2-08c1c59eb671907effdc64df6b73c5f7a9853ebb.tar.bz2
gentoo-2-08c1c59eb671907effdc64df6b73c5f7a9853ebb.zip
Version bump. Overflow fix.
Diffstat (limited to 'net-www/mod_ssl')
-rw-r--r--net-www/mod_ssl/ChangeLog8
-rw-r--r--net-www/mod_ssl/files/digest-mod_ssl-2.8.101
-rw-r--r--net-www/mod_ssl/mod_ssl-2.8.10.ebuild74
-rw-r--r--net-www/mod_ssl/mod_ssl-2.8.9-r1.ebuild2
4 files changed, 83 insertions, 2 deletions
diff --git a/net-www/mod_ssl/ChangeLog b/net-www/mod_ssl/ChangeLog
index 06f2dd7ae31c..1b71f208f05b 100644
--- a/net-www/mod_ssl/ChangeLog
+++ b/net-www/mod_ssl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-www/mod_ssl
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-www/mod_ssl/ChangeLog,v 1.3 2002/06/21 21:26:44 carpaski Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_ssl/ChangeLog,v 1.4 2002/06/24 16:11:53 carpaski Exp $
+
+*mod_ssl-2.8.10 (24 Jun 2002)
+
+ 24 Jun 2002; Nicholas Jones <carpaski@gentoo.org> mod_ssl-2.8.10.ebuild
+
+ o Version bump. Overflow fix.
*mod_ssl-2.8.9-r1 (21 Jun 2002)
diff --git a/net-www/mod_ssl/files/digest-mod_ssl-2.8.10 b/net-www/mod_ssl/files/digest-mod_ssl-2.8.10
new file mode 100644
index 000000000000..2e23236f8db5
--- /dev/null
+++ b/net-www/mod_ssl/files/digest-mod_ssl-2.8.10
@@ -0,0 +1 @@
+MD5 11260700ab52fb7ff54a25f14052eed4 mod_ssl-2.8.10-1.3.26.tar.gz 753241
diff --git a/net-www/mod_ssl/mod_ssl-2.8.10.ebuild b/net-www/mod_ssl/mod_ssl-2.8.10.ebuild
new file mode 100644
index 000000000000..58debde8e1eb
--- /dev/null
+++ b/net-www/mod_ssl/mod_ssl-2.8.10.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_ssl/mod_ssl-2.8.10.ebuild,v 1.1 2002/06/24 16:11:54 carpaski Exp $
+
+MY_P=${P}-1.3.26
+
+DESCRIPTION="An SSL module for the Apache Web server"
+HOMEPAGE="http://www.modssl.org"
+
+S=${WORKDIR}/${MY_P}
+SRC_URI="http://www.modssl.org/source/${MY_P}.tar.gz"
+
+DEPEND="virtual/glibc =net-www/apache-1.3.26* >=dev-libs/openssl-0.9.6c"
+LICENSE="as-is"
+SLOT="0"
+
+src_unpack() {
+ unpack ${A} ; cd ${S}
+ # proper path to openssl
+ cp pkg.contrib/cca.sh pkg.contrib/cca.sh.orig
+ sed -e 's%^\(openssl=\).*%\1"/usr/bin/openssl"%' \
+ pkg.contrib/cca.sh.orig > pkg.contrib/cca.sh
+}
+
+src_compile() {
+ SSL_BASE=SYSTEM \
+ ./configure \
+ --with-apxs=/usr/sbin/apxs || die "bad ./configure"
+ make || die "compile problem"
+}
+
+src_install() {
+ exeinto /usr/lib/apache-extramodules
+ doexe pkg.sslmod/libssl.so
+
+ exeinto /usr/lib/ssl/mod_ssl
+ doexe pkg.contrib/*.sh ${FILESDIR}/gentestcrt.sh
+
+ dodoc ANNOUNCE CHANGES CREDITS LICENSE NEWS README*
+ mkdir -p ${D}/usr/share/doc/${PF}/html
+ cp -a pkg.ssldoc/* ${D}/usr/share/doc/${PF}/html
+
+ insinto /etc/apache/conf/vhosts
+ doins ${FILESDIR}/ssl.default-vhost.conf
+
+ insinto /etc/apache/conf/addon-modules
+ doins ${FILESDIR}/mod_ssl.conf
+}
+
+pkg_postinst() {
+ install -d -o root -g root -m0755 ${ROOT}/etc/apache/conf/ssl
+
+ einfo
+ einfo "Execute \"ebuild /var/db/pkg/${CATEGORY}/${PF}/${PF}.ebuild config\""
+ einfo "to have your apache.conf auto-updated for use with this module."
+ einfo "You should then edit your /etc/conf.d/apache file to suit."
+ einfo
+
+ cd ${ROOT}/etc/apache/conf/ssl
+ einfo "Generating self-signed test certificate in /etc/apache/conf/ssl..."
+ einfo "(Ignore any message from the yes command below)"
+ yes "" | ${ROOT}/usr/lib/ssl/mod_ssl/gentestcrt.sh >/dev/null 2>&1
+ einfo
+}
+
+pkg_config() {
+ ${ROOT}/usr/sbin/apacheaddmod \
+ ${ROOT}/etc/apache/conf/apache.conf \
+ extramodules/libssl.so mod_ssl.c ssl_module \
+ define=SSL addconf=conf/addon-modules/mod_ssl.conf
+
+ echo "Include conf/vhosts/ssl.default-vhost.conf" \
+ >> ${ROOT}/etc/apache/conf/apache.conf
+}
diff --git a/net-www/mod_ssl/mod_ssl-2.8.9-r1.ebuild b/net-www/mod_ssl/mod_ssl-2.8.9-r1.ebuild
index 95bfd154da8c..f7b3ce50fa3a 100644
--- a/net-www/mod_ssl/mod_ssl-2.8.9-r1.ebuild
+++ b/net-www/mod_ssl/mod_ssl-2.8.9-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# /space/gentoo/cvsroot/gentoo-x86/net-www/mod_ssl/mod_ssl-2.8.9.ebuild,v 1.1 2002/06/20 15:45:45 bangert Exp
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_ssl/mod_ssl-2.8.9-r1.ebuild,v 1.2 2002/06/24 16:11:54 carpaski Exp $
MY_P=${P}-1.3.26