summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2002-09-18 20:23:52 +0000
committerNick Hadaway <raker@gentoo.org>2002-09-18 20:23:52 +0000
commit6d63bca9cbcd561a6dbd300b1f3d20ee56c0b0e6 (patch)
treef7ee72c639f29931f15d072e86098ce5e458f9c1 /net-www/fnord
parentVersion bump. Closes bug #8053 (diff)
downloadgentoo-2-6d63bca9cbcd561a6dbd300b1f3d20ee56c0b0e6.tar.gz
gentoo-2-6d63bca9cbcd561a6dbd300b1f3d20ee56c0b0e6.tar.bz2
gentoo-2-6d63bca9cbcd561a6dbd300b1f3d20ee56c0b0e6.zip
Version bump. Bug fix release. Thanks to fridtjof@fbunet.de on bug
#8034
Diffstat (limited to 'net-www/fnord')
-rw-r--r--net-www/fnord/ChangeLog9
-rw-r--r--net-www/fnord/files/digest-fnord-1.51
-rw-r--r--net-www/fnord/files/fnord-1.5-gentoo.diff31
-rw-r--r--net-www/fnord/fnord-1.5.ebuild54
4 files changed, 93 insertions, 2 deletions
diff --git a/net-www/fnord/ChangeLog b/net-www/fnord/ChangeLog
index 06bbff425448..ad286a85253e 100644
--- a/net-www/fnord/ChangeLog
+++ b/net-www/fnord/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-www/fnord
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-www/fnord/ChangeLog,v 1.3 2002/07/14 20:25:23 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/fnord/ChangeLog,v 1.4 2002/09/18 20:23:52 raker Exp $
+
+*fnord-1.5 (18 Sep 2002)
+
+ 11 Sep 2002; Fridtjof Busse <fridtjof@fbunet.de> fnord-1.5.ebuild,
+ files/digest-fnord-1.5, files/fnord-1.5-gentoo.diff :
+ Added fnord/fnordlog user. Corrected small bug in fnord-conf.
*fnord-1.2 (30 Mar 2002)
@@ -8,5 +14,4 @@
Added LICENSE, KEYWORDS, SLOT.
30 Mar 2002; Thilo Bangert <thilo.bangert@gmx.net> ChangeLog :
-
initial release ;-)
diff --git a/net-www/fnord/files/digest-fnord-1.5 b/net-www/fnord/files/digest-fnord-1.5
new file mode 100644
index 000000000000..793e72a9cd95
--- /dev/null
+++ b/net-www/fnord/files/digest-fnord-1.5
@@ -0,0 +1 @@
+MD5 e391820c9894224a9f41de2beb61c1a0 fnord-1.5.tar.bz2 25110
diff --git a/net-www/fnord/files/fnord-1.5-gentoo.diff b/net-www/fnord/files/fnord-1.5-gentoo.diff
new file mode 100644
index 000000000000..d33d415217da
--- /dev/null
+++ b/net-www/fnord/files/fnord-1.5-gentoo.diff
@@ -0,0 +1,31 @@
+--- httpd.c.orig 2002-09-17 12:26:41.000000000 +0200
++++ httpd.c 2002-09-17 12:27:02.000000000 +0200
+@@ -23,7 +23,7 @@
+ #include "scan.h"
+
+ /* uncomment the following line to enable support for CGI */
+-// #define CGI
++#define CGI
+
+ #ifdef CGI
+ /* uncomment the following line to enable support for "index.cgi"
+@@ -37,7 +37,7 @@
+
+ /* uncomment the following line to enable support for autogenerated
+ * directory-listings for directories without index */
+-/* #define DIR_LIST */
++#define DIR_LIST
+
+ #ifdef DIR_LIST
+ /* uncomment the following line to enable support for system symlink
+--- fnord-conf.orig 2002-09-17 12:25:31.000000000 +0200
++++ fnord-conf 2002-09-17 12:25:46.000000000 +0200
+@@ -17,7 +17,7 @@
+ mkdir -p $dir
+ echo "#!/bin/sh" > $dir/run
+ echo "cd $webroot" >> $dir/run
+-echo "exec tcpserver -u $acct -RHl localhost ${myip:-0} 80 /command/fnord-httpd 2>&1" >> $dir/run
++echo "exec tcpserver -u $acct -RHl localhost ${myip:-0} 80 /usr/bin/fnord 2>&1" >> $dir/run
+ chmod 755 $dir/run
+
+ # tell old daemontools that it should spawn a log process, too
diff --git a/net-www/fnord/fnord-1.5.ebuild b/net-www/fnord/fnord-1.5.ebuild
new file mode 100644
index 000000000000..b123973edea4
--- /dev/null
+++ b/net-www/fnord/fnord-1.5.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/fnord/fnord-1.5.ebuild,v 1.1 2002/09/18 20:23:52 raker Exp $
+
+S=${WORKDIR}/${P}
+
+DESCRIPTION="Yet another small httpd."
+SRC_URI="http://www.fefe.de/fnord/${P}.tar.bz2"
+HOMEPAGE="http://www.fefe.de/fnord/"
+
+KEYWORDS="x86 sparc sparc64"
+SLOT="0"
+LICENSE="GPL-2"
+
+DEPEND="dev-libs/dietlibc"
+RDEPEND="sys-apps/daemontools"
+
+pkg_setup() {
+
+ if ! grep -q ^fnord: /etc/passwd ; then
+ useradd -g nofiles -s /bin/false -d /etc/fnord -c "fnord" fnord\
+ || die "problem adding user fnord"
+ fi
+ if ! grep -q ^fnordlog: /etc/passwd ; then
+ useradd -g nofiles -s /bin/false -d /etc/fnord -c "fnordlog" fnordlog\
+ || die "problem adding user fnordlog"
+ fi
+}
+
+src_unpack() {
+
+ unpack ${A} ; cd ${S}
+ mv Makefile Makefile.orig
+ sed -e "s:^CFLAGS=-O.*:CFLAGS=${CFLAGS}:" \
+ Makefile.orig > Makefile
+
+ patch -p0 < ${FILESDIR}/${PF}-gentoo.diff
+
+}
+
+src_compile() {
+
+ emake || die
+
+}
+
+src_install () {
+
+ exeinto /usr/bin
+ doexe fnord-conf fnord
+
+ dodoc TODO README SPEED COPYING CHANGES
+
+}