summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonny Davies <woodchip@gentoo.org>2002-11-02 08:18:52 +0000
committerDonny Davies <woodchip@gentoo.org>2002-11-02 08:18:52 +0000
commitcedcf61ed90b44cc39ab19fa45014b0b2cd08b34 (patch)
tree5ad55771ca0e8e3c2d8e123ab221fbed6da5308f /net-www/apache
parentVersion bump/enhancement #10081 (diff)
downloadgentoo-2-cedcf61ed90b44cc39ab19fa45014b0b2cd08b34.tar.gz
gentoo-2-cedcf61ed90b44cc39ab19fa45014b0b2cd08b34.tar.bz2
gentoo-2-cedcf61ed90b44cc39ab19fa45014b0b2cd08b34.zip
chase latest; #9967
Diffstat (limited to 'net-www/apache')
-rw-r--r--net-www/apache/ChangeLog8
-rw-r--r--net-www/apache/apache-2.0.43.ebuild83
-rw-r--r--net-www/apache/files/apache.rc64
-rw-r--r--net-www/apache/files/digest-apache-2.0.431
4 files changed, 92 insertions, 4 deletions
diff --git a/net-www/apache/ChangeLog b/net-www/apache/ChangeLog
index fe5a7cb17cff..3e787018e00f 100644
--- a/net-www/apache/ChangeLog
+++ b/net-www/apache/ChangeLog
@@ -1,13 +1,17 @@
# ChangeLog for net-www/apache
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-www/apache/ChangeLog,v 1.28 2002/10/12 21:16:25 woodchip Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/apache/ChangeLog,v 1.29 2002/11/02 08:18:52 woodchip Exp $
+
+*apache-2.0.43 (02 Nov 2002)
+
+ 02 Nov 2002; Donny Davies <woodchip@gentoo.org> : Chase latest; #9967.
*apache-1.3.27-r1 (12 Oct 2002)
12 Oct 2002; Donny Davies <woodchip@gentoo.org> :
Added redhat db-4 patch, tweaked sys-libs/db dependency to make things
more sane. Swept up patches into a single diff. Added (Gentoo/Linux)
- to the server_version string. Clean out old junk. Help out the #8759 people ;-)
+ to the server_version string. Clean out old junk. Help out with #8759.
*apache-1.3.27 (06 Oct 2002)
diff --git a/net-www/apache/apache-2.0.43.ebuild b/net-www/apache/apache-2.0.43.ebuild
new file mode 100644
index 000000000000..90838c5698a5
--- /dev/null
+++ b/net-www/apache/apache-2.0.43.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/apache/apache-2.0.43.ebuild,v 1.1 2002/11/02 08:18:52 woodchip Exp $
+
+IUSE="ssl"
+
+S="${WORKDIR}/httpd-${PV}"
+
+KEYWORDS="~x86 ~ppc"
+DESCRIPTION="Apache Web Server, Version 2.0.x"
+SRC_URI="http://www.apache.org/dist/httpd/httpd-${PV}.tar.gz"
+HOMEPAGE="http://www.apache.org"
+LICENSE="Apache-1.1"
+SLOT="2"
+
+DEPEND="virtual/glibc
+ >=dev-libs/mm-1.1.3
+ >=sys-libs/gdbm-1.8
+ >=dev-libs/expat-1.95.2
+ >=sys-devel/perl-5.6.1
+ ssl? >=dev-libs/openssl-0.9.6e"
+
+src_compile() {
+ PREFIX=/usr/lib/apache2
+
+ select_modules_config || die "determining modules"
+ ./configure \
+ --host=${CHOST} \
+ --prefix=${PREFIX} \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --sysconfdir=/etc/apache2 \
+ --datadir=/home/httpd \
+ --enable-suexec \
+ --with-suexec-uidmin=1000 \
+ --with-suexec-gidmin=100 \
+ ${MY_BUILTINS} \
+ || die "./configure failed"
+ emake || die "Make failed"
+}
+
+src_install () {
+ make DESTDIR=${D} install || die "make install failed"
+
+ # Install documentation.
+ dodoc CHANGES INSTALL LICENSE README
+
+ insinto /etc/conf.d; newins ${FILESDIR}/2.0.40/apache2.confd apache2
+ exeinto /etc/init.d; newexe ${FILESDIR}/2.0.40/apache2.initd apache2
+ insinto /etc/apache2; doins ${FILESDIR}/2.0.40/apache2-builtin-mods
+}
+
+parse_modules_config() {
+ local filename=$1
+ local name=""
+ local dso=""
+ local disable=""
+ [ -f ${filename} ] || return 1
+ einfo ">>> using ${filename} for builtins..."
+ for i in `cat $filename | sed "s/^#.*//"` ; do
+ if [ $i == "-" ] ; then
+ disable="true"
+ elif [ -z "$name" ] && [ ! -z "`echo $i | grep "mod_"`" ] ; then
+ name=`echo $i | sed "s/mod_//"`
+ elif [ "$disable" ] && ( [ $i == "static" ] || [ $i == "shared" ] ) ; then
+ MY_BUILTINS="${MY_BUILTINS} --disable-$name"
+ name="" ; disable=""
+ elif [ $i == "static" ] ; then
+ MY_BUILTINS="${MY_BUILTINS} --enable-$name=yes"
+ name="" ; disable=""
+ elif [ $i == "shared" ] ; then
+ MY_BUILTINS="${MY_BUILTINS} --enable-$name=shared"
+ name="" ; disable=""
+ fi
+ done
+ einfo ">>> Here is your custom config line:\n${MY_BUILTINS}"
+}
+
+select_modules_config() {
+ parse_modules_config /etc/apache/apache2-builtin-mods || \
+ parse_modules_config ${FILESDIR}/2.0.40/apache2-builtin-mods || \
+ return 1
+}
diff --git a/net-www/apache/files/apache.rc6 b/net-www/apache/files/apache.rc6
index 77f95cb7f435..a4a6c40adea0 100644
--- a/net-www/apache/files/apache.rc6
+++ b/net-www/apache/files/apache.rc6
@@ -1,7 +1,7 @@
#!/sbin/runscript
# Copyright 1999-2002 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# /space/gentoo/cvsroot/gentoo-x86/net-www/apache/files/apache.rc6,v 1.1 2002/04/09 23:51:39 woodchip Exp
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/apache/files/apache.rc6,v 1.8 2002/11/02 08:18:52 woodchip Exp $
depend() {
need net
diff --git a/net-www/apache/files/digest-apache-2.0.43 b/net-www/apache/files/digest-apache-2.0.43
new file mode 100644
index 000000000000..636e0853abdc
--- /dev/null
+++ b/net-www/apache/files/digest-apache-2.0.43
@@ -0,0 +1 @@
+MD5 8051de5d160c43d4ed2cc47dc9be6fd3 httpd-2.0.43.tar.gz 4835188