summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBjarke Istrup Pedersen <gurligebis@gentoo.org>2014-02-12 10:30:27 +0000
committerBjarke Istrup Pedersen <gurligebis@gentoo.org>2014-02-12 10:30:27 +0000
commitf7a23e51a6d89bf84aeff9c8ad3f33ce15a1baa2 (patch)
tree0e8145dd6ad9c313224f7f900305db455265b891 /net-wireless
parentnet-im/birdie: New package, #475950; ebuild written by Micheal Weber and me (diff)
downloadgentoo-2-f7a23e51a6d89bf84aeff9c8ad3f33ce15a1baa2.tar.gz
gentoo-2-f7a23e51a6d89bf84aeff9c8ad3f33ce15a1baa2.tar.bz2
gentoo-2-f7a23e51a6d89bf84aeff9c8ad3f33ce15a1baa2.zip
Bumping to 2.1
(Portage version: 2.2.8-r1/cvs/Linux i686, signed Manifest commit with key 15AE484C)
Diffstat (limited to 'net-wireless')
-rw-r--r--net-wireless/hostapd/ChangeLog10
-rw-r--r--net-wireless/hostapd/hostapd-2.1.ebuild (renamed from net-wireless/hostapd/hostapd-2.0.ebuild)15
2 files changed, 16 insertions, 9 deletions
diff --git a/net-wireless/hostapd/ChangeLog b/net-wireless/hostapd/ChangeLog
index 47d5bac7bf83..b04c2b422b7a 100644
--- a/net-wireless/hostapd/ChangeLog
+++ b/net-wireless/hostapd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-wireless/hostapd
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/hostapd/ChangeLog,v 1.143 2013/09/25 17:27:52 ago Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/hostapd/ChangeLog,v 1.144 2014/02/12 10:30:27 gurligebis Exp $
+
+*hostapd-2.1 (12 Feb 2014)
+
+ 12 Feb 2014; <gurligebis@gentoo.org> -hostapd-2.0.ebuild,
+ +hostapd-2.1.ebuild:
+ Bumping to 2.1
25 Sep 2013; Agostino Sarubbo <ago@gentoo.org> hostapd-2.0-r1.ebuild:
Stable for ppc, wrt bug #485340
diff --git a/net-wireless/hostapd/hostapd-2.0.ebuild b/net-wireless/hostapd/hostapd-2.1.ebuild
index 4d94030c02e0..b1868523c5e4 100644
--- a/net-wireless/hostapd/hostapd-2.0.ebuild
+++ b/net-wireless/hostapd/hostapd-2.1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/hostapd/hostapd-2.0.ebuild,v 1.3 2013/04/29 18:35:53 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/hostapd/hostapd-2.1.ebuild,v 1.1 2014/02/12 10:30:27 gurligebis Exp $
EAPI="4"
-inherit toolchain-funcs eutils
+inherit toolchain-funcs eutils systemd
DESCRIPTION="IEEE 802.11 wireless LAN Host AP daemon"
HOMEPAGE="http://hostap.epitest.fi"
@@ -12,7 +12,7 @@ SRC_URI="http://hostap.epitest.fi/releases/${P}.tar.gz"
LICENSE="|| ( GPL-2 BSD )"
SLOT="0"
-KEYWORDS="amd64 ~mips ppc x86"
+KEYWORDS="~amd64 ~mips ~ppc ~x86"
IUSE="ipv6 logwatch madwifi +ssl +wps +crda"
DEPEND="ssl? ( dev-libs/openssl )
@@ -28,9 +28,6 @@ RDEPEND="${DEPEND}"
S="${S}/${PN}"
src_prepare() {
- cd ..
- epatch "${FILESDIR}/${P}-tls_length_fix.patch"
-
sed -i -e "s:/etc/hostapd:/etc/hostapd/hostapd:g" \
"${S}/hostapd.conf" || die
}
@@ -64,6 +61,7 @@ src_configure() {
echo "CONFIG_EAP_GTC=y" >> ${CONFIG}
echo "CONFIG_EAP_SIM=y" >> ${CONFIG}
echo "CONFIG_EAP_AKA=y" >> ${CONFIG}
+ echo "CONFIG_EAP_EKE=y" >> ${CONFIG}
echo "CONFIG_EAP_PAX=y" >> ${CONFIG}
echo "CONFIG_EAP_PSK=y" >> ${CONFIG}
echo "CONFIG_EAP_SAKE=y" >> ${CONFIG}
@@ -105,6 +103,7 @@ src_configure() {
echo "CONFIG_PEERKEY=y" >> ${CONFIG}
echo "CONFIG_RSN_PREAUTH=y" >> ${CONFIG}
echo "CONFIG_INTERWORKING=y" >> ${CONFIG}
+ echo "CONFIG_ACS=y" >> ${CONFIG}
if use ipv6; then
# IPv6 support
@@ -145,6 +144,7 @@ src_install() {
newinitd "${FILESDIR}"/${PN}-init.d ${PN}
newconfd "${FILESDIR}"/${PN}-conf.d ${PN}
+ systemd_dounit "${FILESDIR}"/${PN}.service
doman ${PN}{.8,_cli.1}
@@ -165,6 +165,7 @@ src_install() {
pkg_postinst() {
einfo
+ einfo "If you are running openRC you need to follow this instructions:"
einfo "In order to use ${PN} you need to set up your wireless card"
einfo "for master mode in /etc/conf.d/net and then start"
einfo "/etc/init.d/${PN}."