summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Johanson <latexer@gentoo.org>2003-02-14 03:14:07 +0000
committerPeter Johanson <latexer@gentoo.org>2003-02-14 03:14:07 +0000
commit4fac1829c62ffa00056b81fd7382f9278d1f79a8 (patch)
tree0a47ac5b3d84a3d158a9276a2eca91e3271d816c /net-wireless
parentMarked stable (diff)
downloadgentoo-2-4fac1829c62ffa00056b81fd7382f9278d1f79a8.tar.gz
gentoo-2-4fac1829c62ffa00056b81fd7382f9278d1f79a8.tar.bz2
gentoo-2-4fac1829c62ffa00056b81fd7382f9278d1f79a8.zip
-r1 can now use HOSTAP_DRIVERS to select drivers to build.
Diffstat (limited to 'net-wireless')
-rw-r--r--net-wireless/hostap/ChangeLog11
-rw-r--r--net-wireless/hostap/files/digest-hostap-20021012-r12
-rw-r--r--net-wireless/hostap/hostap-20021012-r1.ebuild127
-rw-r--r--net-wireless/hostap/hostap-20021012.ebuild4
4 files changed, 141 insertions, 3 deletions
diff --git a/net-wireless/hostap/ChangeLog b/net-wireless/hostap/ChangeLog
index 85511cefd2b6..68e5dd690377 100644
--- a/net-wireless/hostap/ChangeLog
+++ b/net-wireless/hostap/ChangeLog
@@ -1,9 +1,18 @@
# ChangeLog for net-wireless/hostap
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/hostap/ChangeLog,v 1.1 2003/02/08 03:22:49 latexer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/hostap/ChangeLog,v 1.2 2003/02/14 03:14:07 latexer Exp $
+
+*hostap-20021012-r1 (13 Feb 2003)
+
+ 13 Feb 2003; Peter Johanson <latexer@gentoo.org> hostap-20021012-r1.ebuild
+ files/digest-hostap-20021012-r1 :
+ Ebuild now can use HOSTAP_DRIVERS to specify which drivers to build.
*hostap-20021012 (07 Feb 2003)
+ 13 Feb 2003; Peter Johanson <latexer@gentoo.org> hostap-20021012.ebuild :
+ Fixed IUSE
+
08 Feb 2003; Peter Johanson <latexer@gentoo.org> :
Moved from sys-apps to net-wireless.
diff --git a/net-wireless/hostap/files/digest-hostap-20021012-r1 b/net-wireless/hostap/files/digest-hostap-20021012-r1
new file mode 100644
index 000000000000..1c66f06d19b0
--- /dev/null
+++ b/net-wireless/hostap/files/digest-hostap-20021012-r1
@@ -0,0 +1,2 @@
+MD5 f5170147792a591120437dd33dbb106d hostap-2002-10-12.tar.gz 204390
+MD5 7e9f01a697d2e3e5164340d79474ea30 pcmcia-cs-3.2.1.tar.gz 1250413
diff --git a/net-wireless/hostap/hostap-20021012-r1.ebuild b/net-wireless/hostap/hostap-20021012-r1.ebuild
new file mode 100644
index 000000000000..f5b39c14cca7
--- /dev/null
+++ b/net-wireless/hostap/hostap-20021012-r1.ebuild
@@ -0,0 +1,127 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/hostap/hostap-20021012-r1.ebuild,v 1.1 2003/02/14 03:14:07 latexer Exp $
+
+inherit eutils
+
+DESCRIPTION="HostAP wireless drivers"
+HOMEPAGE="http://hostap.epitest.fi/"
+
+MY_PCMCIA="pcmcia-cs-3.2.1"
+SRC_URI="http://hostap.epitest.fi/releases/${PN}-2002-10-12.tar.gz
+ pcmcia? ( mirror://sourceforge/pcmcia-cs/${MY_PCMCIA}.tar.gz )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+IUSE="pcmcia"
+
+DEPEND="pcmcia? ( >=sys-apps/pcmcia-cs-3.2.1* )"
+
+S=${WORKDIR}/${PN}-2002-10-12
+LIB_PATH="/lib/modules/${KV}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # This is a patch that has already been applied to the hostap
+ # cvs tree. It fixes hostapd compilation for gcc-3.2
+
+ epatch ${FILESDIR}/${P}-gentoo-patch.diff
+
+ mv Makefile ${T}
+ sed -e "s:^PCMCIA_PATH=:PCMCIA_PATH=${WORKDIR}/${MY_PCMCIA}:" \
+ -e "s:gcc:${CC}:" \
+ -e "s:-O2:${CFLAGS}:" \
+ -e "s:\$(EXTRA_CFLAGS):\$(EXTRA_CFLAGS) -DPRISM2_HOSTAPD:" \
+ ${T}/Makefile > Makefile
+
+ cd ${S}/hostapd
+ mv Makefile ${T}
+ sed -e "s:gcc:${CC}:" \
+ -e "s:-O2:${CFLAGS}:" \
+ ${T}/Makefile > Makefile
+}
+
+src_compile() {
+
+ #
+ # This ebuild now uses a system similar to the alsa ebuild.
+ # By default, it will install the pci and plx drivers, and
+ # the pcmcia drivers if pcmcia is in your use variables. To
+ # specify exactly which drivers to build, do something like
+ #
+ # HOSTAP_DRIVERS="pci pccard" emerge hostap
+ #
+
+ if [ -z "${HOSTAP_DRIVERS}" ]; then
+ CUSTOM="no"
+ HOSTAP_DRIVERS="pci plx"
+ if [ -n "`use pcmcia`" ]; then
+ emake ${HOSTAP_DRIVERS} pccard hostap crypt || die
+ else
+ emake ${HOSTAP_DRIVERS} hostap crypt || die
+ fi
+ else
+ CUSTOM="yes"
+ einfo "Building the folowing drivers: ${HOSTAP_DRIVERS}"
+ emake ${HOSTAP_DRIVERS} hostap crypt || die
+ fi
+
+ cd ${S}/hostapd
+ emake || die
+}
+
+src_install() {
+ dodir ${LIB_PATH}/net
+ cp ${S}/driver/modules/{hostap.o,hostap_crypt.o,hostap_crypt_wep.o}\
+ ${D}${LIB_PATH}/net/
+
+ if [ "${CUSTOM}" == "no" ]; then
+
+ if [ -n "`use pcmcia`" ]; then
+ dodir ${LIB_PATH}/pcmcia
+ dodir /etc/pcmcia
+ cp ${S}/driver/modules/hostap_cs.o ${D}/${LIB_PATH}/pcmcia/
+ cp ${S}/driver/etc/hostap_cs.conf ${D}/etc/pcmcia/
+ if [ -r /etc/pcmcia/prism2.conf ]; then
+ einfo "You may need to edit or remove /etc/pcmcia/prism2.conf"
+ einfo "This is usually a result of conflicts with the"
+ einfo "linux-wlan-ng drivers."
+ fi
+ fi
+ for driver in ${HOSTAP_DRIVERS}; do
+ cp ${S}/driver/modules/hostap_${driver}.o\
+ ${D}${LIB_PATH}/net/;
+ done
+ elif [ "${CUSTOM}" == "yes" ]; then
+ if [[ "${HOSTAP_DRIVERS}" = *pccard* ]]; then
+ dodir ${LIB_PATH}/pcmcia
+ dodir /etc/pcmcia
+ cp ${S}/driver/modules/hostap_cs.o ${D}/${LIB_PATH}/pcmcia/
+ cp ${S}/driver/etc/hostap_cs.conf ${D}/etc/pcmcia/
+ if [ -r /etc/pcmcia/prism2.conf ]; then
+ einfo "You may need to edit or remove /etc/pcmcia/prism2.conf"
+ einfo "This is usually a result of conflicts with the"
+ einfo "linux-wlan-ng drivers."
+ fi
+ fi
+
+ if [[ "${HOSTAP_DRIVERS}" = *pci* ]]; then
+ cp ${S}/driver/modules/hostap_pci.o\
+ ${D}${LIB_PATH}/net/
+ fi
+
+ if [[ "${HOSTAP_DRIVERS}" = *plx* ]]; then
+ cp ${S}/driver/modules/hostap_plx.o\
+ ${D}${LIB_PATH}/net/
+ fi
+
+ fi
+
+ dodoc FAQ README README.prism2 ChangeLog
+
+ dosbin hostapd/hostapd
+}
diff --git a/net-wireless/hostap/hostap-20021012.ebuild b/net-wireless/hostap/hostap-20021012.ebuild
index a27f80463946..44dd41811678 100644
--- a/net-wireless/hostap/hostap-20021012.ebuild
+++ b/net-wireless/hostap/hostap-20021012.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/hostap/hostap-20021012.ebuild,v 1.1 2003/02/08 03:22:49 latexer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/hostap/hostap-20021012.ebuild,v 1.2 2003/02/14 03:14:07 latexer Exp $
inherit eutils
@@ -15,7 +15,7 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86"
-IUSE="pcmcia pci plx"
+IUSE="pcmcia"
DEPEND="pcmcia? ( >=sys-apps/pcmcia-cs-3.2.1* )"