summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2004-06-27 03:57:00 +0000
committerAlastair Tse <liquidx@gentoo.org>2004-06-27 03:57:00 +0000
commit63bb340b89a55a00c80c26fbfc0accadf25be4d6 (patch)
tree7e17191ad3c30c0b7e807ca3c03b552065fa320c /net-wireless/libbtctl/libbtctl-0.4.1.ebuild
parentstable on ppc64 (Manifest recommit) (diff)
downloadgentoo-2-63bb340b89a55a00c80c26fbfc0accadf25be4d6.tar.gz
gentoo-2-63bb340b89a55a00c80c26fbfc0accadf25be4d6.tar.bz2
gentoo-2-63bb340b89a55a00c80c26fbfc0accadf25be4d6.zip
adding new version. now has python and optional mono bindings. added unused disable/enable python patch. we don't use it right now because its not complete yet and the only thing that needs libbtctl right now requires the python bindings
Diffstat (limited to 'net-wireless/libbtctl/libbtctl-0.4.1.ebuild')
-rw-r--r--net-wireless/libbtctl/libbtctl-0.4.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/net-wireless/libbtctl/libbtctl-0.4.1.ebuild b/net-wireless/libbtctl/libbtctl-0.4.1.ebuild
new file mode 100644
index 000000000000..783c56deea7d
--- /dev/null
+++ b/net-wireless/libbtctl/libbtctl-0.4.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/libbtctl/libbtctl-0.4.1.ebuild,v 1.1 2004/06/27 03:57:00 liquidx Exp $
+
+inherit gnome2
+
+DESCRIPTION="A GObject wrapper for Bluetooth functionality"
+HOMEPAGE="http://usefulinc.com/software/gnome-bluetooth/"
+SRC_URI="http://downloads.usefulinc.com/libbtctl/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~sparc"
+IUSE="mono"
+
+RDEPEND=">=dev-libs/glib-2
+ >=net-wireless/bluez-utils-2.7
+ >=net-wireless/bluez-libs-2.7
+ >=dev-libs/openobex-1
+ >=dev-lang/python-2.3
+ >=dev-python/pygtk-2.0
+ !sparc? ( mono? ( >=dev-dotnet/mono-0.96 ) )"
+
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ dev-util/pkgconfig
+ doc? ( dev-util/gtk-doc )"
+
+MAKEOPTS="${MAKEOPTS} -j1"
+DOCS="README NEWS ChangeLog AUTHORS COPYING"
+
+src_compile() {
+ use sparc || G2CONF="`use_enable mono`"
+ gnome2_src_compile
+}