summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2008-08-12 14:09:37 +0000
committerTiziano Müller <dev-zero@gentoo.org>2008-08-12 14:09:37 +0000
commitcd477017620ae109f9628f881a2158bfa02a198c (patch)
tree4d3bdd57e5b0b79171d1a867687c0b7ceebef98f /net-wireless/bluez-utils
parentalpha/ia64 stable (diff)
downloadgentoo-2-cd477017620ae109f9628f881a2158bfa02a198c.tar.gz
gentoo-2-cd477017620ae109f9628f881a2158bfa02a198c.tar.bz2
gentoo-2-cd477017620ae109f9628f881a2158bfa02a198c.zip
Reworked the parameter list for configure (bug #234516), 'dobin' test-binaries conditionally (bug #162715).
(Portage version: 2.2_rc6/cvs/Linux 2.6.26-gentoo x86_64)
Diffstat (limited to 'net-wireless/bluez-utils')
-rw-r--r--net-wireless/bluez-utils/ChangeLog7
-rw-r--r--net-wireless/bluez-utils/bluez-utils-3.36.ebuild47
2 files changed, 25 insertions, 29 deletions
diff --git a/net-wireless/bluez-utils/ChangeLog b/net-wireless/bluez-utils/ChangeLog
index 37d1f65c609b..b6757cbf4c8a 100644
--- a/net-wireless/bluez-utils/ChangeLog
+++ b/net-wireless/bluez-utils/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-wireless/bluez-utils
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/bluez-utils/ChangeLog,v 1.128 2008/08/11 13:42:15 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/bluez-utils/ChangeLog,v 1.129 2008/08/12 14:09:37 dev-zero Exp $
+
+ 12 Aug 2008; Tiziano Müller <dev-zero@gentoo.org>
+ bluez-utils-3.36.ebuild:
+ Reworked the parameter list for configure (bug #234516), 'dobin'
+ test-binaries conditionally (bug #162715).
11 Aug 2008; Tiziano Müller <dev-zero@gentoo.org>
bluez-utils-3.36.ebuild:
diff --git a/net-wireless/bluez-utils/bluez-utils-3.36.ebuild b/net-wireless/bluez-utils/bluez-utils-3.36.ebuild
index 4fd9bf4ae15e..23f05f145776 100644
--- a/net-wireless/bluez-utils/bluez-utils-3.36.ebuild
+++ b/net-wireless/bluez-utils/bluez-utils-3.36.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/bluez-utils/bluez-utils-3.36.ebuild,v 1.2 2008/08/11 13:42:15 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/bluez-utils/bluez-utils-3.36.ebuild,v 1.3 2008/08/12 14:09:37 dev-zero Exp $
inherit autotools multilib eutils
@@ -47,41 +47,32 @@ src_compile() {
# we don't need the other daemons either with the new
# service architechture
- # hcid has in integrated sdpd now that we use
-
- # These are currently under work and don't work properly:
- # --enable-sync
- # --enable-obex
econf \
- $(use_enable debug) \
- --enable-inotify \
- $(use_enable usb) \
- $(use_enable alsa) \
- --enable-glib \
- $(use_enable gstreamer) \
- --disable-obex \
+ --enable-glib \
--enable-network \
--enable-serial \
--enable-input \
--enable-audio \
- --disable-sync \
- $(use_enable examples echo) \
- --enable-hcid \
- $(use_enable test-programs test) \
- $(use_enable old-daemons sdpd) \
+ $(use_enable gstreamer) \
+ $(use_enable alsa) \
+ $(use_enable usb) \
+ --enable-netlink \
+ --enable-tools \
+ --enable-bccmd \
+ --enable-hid2hci \
+ --enable-dfutool \
$(use_enable old-daemons hidd) \
$(use_enable old-daemons pand) \
+ $(use_enable old-daemons dund) \
$(use_enable cups) \
+ $(use_enable test-programs test) \
+ --enable-manpages \
--enable-configfiles \
--disable-initscripts \
--disable-pcmciarules \
- --enable-bccmd \
- --enable-avctrl \
- --enable-hid2hci \
- --enable-dfutool \
- --localstatedir=/var \
- || die "econf failed"
+ $(use_enable debug) \
+ --localstatedir=/var
emake || die "emake failed"
}
@@ -91,12 +82,12 @@ src_install() {
dodoc AUTHORS ChangeLog README || die
- # a very simple example daemon
- dobin test/passkey-agent || die
- dobin test/auth-agent || die
-
if use test-programs ; then
dobin input/test-input || die
+
+ # a very simple example daemon
+ dobin test/passkey-agent || die
+ dobin test/auth-agent || die
fi
newinitd "${FILESDIR}/3.11/bluetooth-init.d" bluetooth || die