summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2013-06-18 15:55:32 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2013-06-18 15:55:32 +0000
commite3b0048d16ba6450225d7c5420cb826a885e857f (patch)
tree078d7bbf25ec3284c6f513f3f133fb94961f3371 /net-voip
parentadd py3.3 support (diff)
downloadgentoo-2-e3b0048d16ba6450225d7c5420cb826a885e857f.tar.gz
gentoo-2-e3b0048d16ba6450225d7c5420cb826a885e857f.tar.bz2
gentoo-2-e3b0048d16ba6450225d7c5420cb826a885e857f.zip
Version bump, bug 291600.
(Portage version: 2.1.12.2/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'net-voip')
-rw-r--r--net-voip/yate/ChangeLog8
-rw-r--r--net-voip/yate/files/yate-4.3.0-ilbc-alsa-oss.patch96
-rw-r--r--net-voip/yate/metadata.xml1
-rw-r--r--net-voip/yate/yate-4.3.0.1.ebuild113
4 files changed, 217 insertions, 1 deletions
diff --git a/net-voip/yate/ChangeLog b/net-voip/yate/ChangeLog
index f869e4e2d029..3ca10c98e8d3 100644
--- a/net-voip/yate/ChangeLog
+++ b/net-voip/yate/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-voip/yate
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-voip/yate/ChangeLog,v 1.17 2013/03/02 23:11:40 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-voip/yate/ChangeLog,v 1.18 2013/06/18 15:55:32 chithanh Exp $
+
+*yate-4.3.0.1 (18 Jun 2013)
+
+ 18 Jun 2013; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ +files/yate-4.3.0-ilbc-alsa-oss.patch, +yate-4.3.0.1.ebuild, metadata.xml:
+ Version bump, bug 291600.
02 Mar 2013; Markos Chandras <hwoarang@gentoo.org> yate-2.0.0.ebuild:
Move Qt dependencies to the new category
diff --git a/net-voip/yate/files/yate-4.3.0-ilbc-alsa-oss.patch b/net-voip/yate/files/yate-4.3.0-ilbc-alsa-oss.patch
new file mode 100644
index 000000000000..8a90ee55df72
--- /dev/null
+++ b/net-voip/yate/files/yate-4.3.0-ilbc-alsa-oss.patch
@@ -0,0 +1,96 @@
+diff -ur a/configure.in b/configure.in
+--- a/configure.in 2012-12-21 15:26:49.000000000 +0100
++++ b/configure.in 2013-06-18 17:38:10.292436508 +0200
+@@ -779,6 +779,8 @@
+ AC_SUBST(WANPIPE_FLAGS)
+
+ HAVE_SOUNDCARD=no
++AC_ARG_ENABLE(oss,AC_HELP_STRING([--enable-oss],[Enable OSS (default: yes)]),enable_oss=$enableval,enable_oss=yes)
++if [[ "x$enable_oss" = "xyes" ]]; then
+ AC_MSG_CHECKING([for sound card headers])
+ AC_TRY_COMPILE([
+ #include <sys/stat.h>
+@@ -797,9 +799,12 @@
+ HAVE_SOUNDCARD="yes"
+ )
+ AC_MSG_RESULT([$HAVE_SOUNDCARD])
++fi
+ AC_SUBST(HAVE_SOUNDCARD)
+
+ HAVE_ALSA=no
++AC_ARG_ENABLE(alsa,AC_HELP_STRING([--enable-alsa],[Enable ALSA (default: yes)]),enable_alsa=$enableval,enable_alsa=yes)
++if [[ "x$enable_alsa" = "xyes" ]]; then
+ AC_MSG_CHECKING([for ALSA headers])
+ AC_TRY_COMPILE([
+ #if defined(__linux__)
+@@ -816,6 +821,7 @@
+ HAVE_ALSA="yes"
+ )
+ AC_MSG_RESULT([$HAVE_ALSA])
++fi
+ AC_SUBST(HAVE_ALSA)
+
+ # check for Mac OS X audio headers
+@@ -878,20 +884,36 @@
+
+ HAVE_ILBC=no
+ ILBC_INC=""
+-AC_ARG_ENABLE(ilbc,AC_HELP_STRING([--enable-ilbc],[Enable iLBC codec (default: yes)]),want_ilbc=$enableval,want_ilbc=yes)
+-if [[ "x$want_ilbc" = "xyes" ]]; then
+-AC_MSG_CHECKING([for iLBC reference in libs])
+- basedir=`cd "$srcdir" && pwd`
+- incilbc="libs/ilbc"
+- if [[ -f "$basedir/$incilbc/iLBC_encode.h" ]]; then
++SYSTEM_ILBC=no
++AC_ARG_ENABLE(ilbc,AC_HELP_STRING([--enable-ilbc],[Enable iLBC codec (default: yes)]),ac_cv_use_ilbc=$enableval,ac_cv_use_ilbc=yes)
++if [[ "x$ac_cv_use_ilbc" = "xyes" ]]; then
++ for i in /usr/include /usr/include/ilbc /usr/local/include /usr/local/include/ilbc; do
++ ac_cv_use_ilbc="$i"
++ test -f "$ac_cv_use_ilbc/iLBC_encode.h" && break
++ done
++fi
++if [[ "x$ac_cv_use_ilbc" != "xno" ]]; then
++ AC_MSG_CHECKING([for iLBC_encode.h in $ac_cv_use_ilbc])
++ if [[ -f "$ac_cv_use_ilbc/iLBC_encode.h" ]]; then
++ HAVE_ILBC=yes
++ ILBC_INC="-I$ac_cv_use_ilbc"
++ SYSTEM_ILBC=yes
++ else
++ AC_MSG_CHECKING([for iLBC in libs])
++ basedir=`cd "$srcdir" && pwd`
++ incilbc="libs/ilbc"
++ if [[ -f "$basedir/$incilbc/iLBC_encode.h" ]]; then
+ HAVE_ILBC=yes
+ basedir=`echo "$basedir" | sed 's/\([[^\]]\)\([[[:space:]\$\"'\'']]\)/\1\\\2/g'`
+ ILBC_INC="-I$basedir/$incilbc"
++ SYSTEM_ILBC=no
+ fi
++fi
+ AC_MSG_RESULT([$HAVE_ILBC])
+ fi
+ AC_SUBST(HAVE_ILBC)
+ AC_SUBST(ILBC_INC)
++AC_SUBST(SYSTEM_ILBC)
+
+ HAVE_ILBCWR=no
+ ILBCWR_INC=""
+Nur in b: configure.in.orig.
+diff -ur a/modules/Makefile.in b/modules/Makefile.in
+--- a/modules/Makefile.in 2012-12-21 15:26:49.000000000 +0100
++++ b/modules/Makefile.in 2013-06-18 17:38:10.292436508 +0200
+@@ -344,9 +344,13 @@
+ server/lksctp.yate: EXTERNFLAGS = @SCTP_FLAGS@
+ server/lksctp.yate: EXTERNLIBS = -lsctp
+
++ifeq (@SYSTEM_ILBC@,yes)
++ilbccodec.yate: LOCALLIBS = -lilbc
++else
+ ilbccodec.yate: ../libs/ilbc/libilbc.a
+-ilbccodec.yate: LOCALFLAGS = @ILBC_INC@
+ ilbccodec.yate: LOCALLIBS = -L../libs/ilbc -lilbc
++endif
++ilbccodec.yate: LOCALFLAGS = @ILBC_INC@
+
+ ilbcwebrtc.yate: ../libs/miniwebrtc/libminiwebrtc.a
+ ilbcwebrtc.yate: LOCALFLAGS = @ILBCWR_INC@ -I@top_srcdir@/libs/miniwebrtc/audio/common/processing -I@top_srcdir@/libs/miniwebrtc
+Nur in b/modules: Makefile.in.orig.
diff --git a/net-voip/yate/metadata.xml b/net-voip/yate/metadata.xml
index 82dbce6b1d4e..99f1ab1b9781 100644
--- a/net-voip/yate/metadata.xml
+++ b/net-voip/yate/metadata.xml
@@ -3,6 +3,7 @@
<pkgmetadata>
<herd>voip</herd>
<use>
+ <flag name='dahdi'>Enable the DAHDI driver for Digium compatible hardware</flag>
<flag name='h323'>Build H.323 Channel plugin</flag>
<flag name='ilbc'>Build ILBC codec plugin</flag>
<flag name='sctp'>
diff --git a/net-voip/yate/yate-4.3.0.1.ebuild b/net-voip/yate/yate-4.3.0.1.ebuild
new file mode 100644
index 000000000000..9f1c7668a984
--- /dev/null
+++ b/net-voip/yate/yate-4.3.0.1.ebuild
@@ -0,0 +1,113 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-voip/yate/yate-4.3.0.1.ebuild,v 1.1 2013/06/18 15:55:32 chithanh Exp $
+
+EAPI=5
+
+inherit autotools eutils multilib versionator
+
+DESCRIPTION="Yet Another Telephony Engine"
+HOMEPAGE="http://yate.null.ro/"
+SRC_URI="http://yate.null.ro/tarballs/yate$(get_major_version)/$(replace_version_separator 4 - ${P}).tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dahdi debug doc gsm h323 ilbc mysql oss postgres qt4 sctp spandsp speex sse2 ssl"
+
+RDEPEND="
+ dahdi? ( net-misc/dahdi )
+ h323? ( net-libs/h323plus )
+ gsm? ( media-sound/gsm )
+ ilbc? ( dev-libs/ilbc-rfc3951 )
+ mysql? ( virtual/mysql )
+ postgres? ( dev-db/postgresql-base )
+ qt4? ( dev-qt/qtcore:4
+ dev-qt/qtgui:4 )
+ spandsp? ( >=media-libs/spandsp-0.0.3 )
+ speex? ( media-libs/speex )
+ ssl? ( dev-libs/openssl )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${PN}
+
+# NOTES:
+# doc is already built
+
+# TODO:
+# coredumper can't be used because not in the tree, bug 118716
+# wanpipe can't be used because not in the tree (but voip overlay), bug 188939
+# spandsp >= 0.0.6 fails in configure and >=0.0.5 fails in build
+# fix bug 199222 for this version
+
+src_prepare() {
+ # add Icon in yate-qt4 desktop file
+ sed -i -e '/^Exec=yate-qt4$/a Icon=null_team-32.png' \
+ clients/yate-qt4.desktop || die "sed failed"
+
+ epatch "${FILESDIR}"/${PN}-4.3.0-ilbc-alsa-oss.patch
+
+ eautoreconf
+}
+
+src_configure() {
+ # fdsize, inline, rtti: keep default values
+ # internalregex: use system
+ # coredumper: not in the tree, bug 118716
+ # wanpipe, wphwec: not in the tree, bug 188939
+ # doxygen, kdoc: no need to rebuild already built doc
+ econf \
+ --disable-internalregex \
+ --without-coredumper \
+ --disable-wanpipe \
+ --without-wphwec \
+ --without-doxygen \
+ --without-kdoc \
+ --with-archlib=$(get_libdir) \
+ --without-amrnb \
+ $(use_enable dahdi) \
+ $(use_with gsm libgsm) \
+ $(use_with h323 openh323) \
+ $(use_with h323 pwlib) \
+ $(use_enable ilbc) \
+ $(use_with mysql mysql /usr) \
+ $(use_with postgres libpq /usr) \
+ $(use_with qt4 libqt4) \
+ $(use_enable sctp) \
+ $(use_with spandsp) \
+ $(use_with speex libspeex) \
+ $(use_with ssl openssl) \
+ --disable-zaptel
+}
+
+src_compile() {
+ if use debug; then
+ emake -j1 ddebug || die "emake ddebug failed"
+ else
+ emake -j1
+ fi
+}
+
+src_test() {
+ # there is no real test suite
+ # 'make test' tries to execute non-existing ./test
+ # do not add RESTRICT="test" because it's not a failing test suite
+ :
+}
+
+src_install() {
+ emake DESTDIR="${D}" install-noapi || die "emake install-noapi failed"
+
+ dodoc ChangeLog README || die "dodoc failed"
+
+ insinto /etc/logrotate.d
+ newins packing/${PN}.logrotate ${PN} || die "newins failed"
+
+ newinitd "${FILESDIR}"/${PN}.initd ${PN} || die "newinitd failed"
+ newconfd "${FILESDIR}"/${PN}.confd ${PN} || die "newconfd failed"
+
+ if use doc; then
+ emake DESTDIR="${D}" install-api || die "emake install-api failed"
+ fi
+}