summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2009-04-18 20:58:31 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2009-04-18 20:58:31 +0000
commit8bc9f0f44b56830054cf80c1ae4ff10d06d4ba91 (patch)
treee38243bc9dcbb88e921a2e9f27fe743b02c257bb /net-voip
parentInitial import. Ebuild by Richard Ash, fixes #266166 (diff)
downloadgentoo-2-8bc9f0f44b56830054cf80c1ae4ff10d06d4ba91.tar.gz
gentoo-2-8bc9f0f44b56830054cf80c1ae4ff10d06d4ba91.tar.bz2
gentoo-2-8bc9f0f44b56830054cf80c1ae4ff10d06d4ba91.zip
Initial ebuild.
(Portage version: 2.2_rc30/cvs/Linux x86_64)
Diffstat (limited to 'net-voip')
-rw-r--r--net-voip/telepathy-salut/ChangeLog10
-rw-r--r--net-voip/telepathy-salut/metadata.xml13
-rw-r--r--net-voip/telepathy-salut/telepathy-salut-0.3.8.ebuild53
3 files changed, 76 insertions, 0 deletions
diff --git a/net-voip/telepathy-salut/ChangeLog b/net-voip/telepathy-salut/ChangeLog
new file mode 100644
index 000000000000..3847c64f9c74
--- /dev/null
+++ b/net-voip/telepathy-salut/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-voip/telepathy-salut
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-voip/telepathy-salut/ChangeLog,v 1.1 2009/04/18 20:58:31 eva Exp $
+
+*telepathy-salut-0.3.8 (18 Apr 2009)
+
+ 18 Apr 2009; Gilles Dartiguelongue <eva@gentoo.org> +metadata.xml,
+ +telepathy-salut-0.3.8.ebuild:
+ Initial ebuild.
+
diff --git a/net-voip/telepathy-salut/metadata.xml b/net-voip/telepathy-salut/metadata.xml
new file mode 100644
index 000000000000..829be7fd6bf3
--- /dev/null
+++ b/net-voip/telepathy-salut/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>none</herd>
+ <maintainer>
+ <email>eva@gentoo.org</email>
+ <name>Gilles Dartiguelongue</name>
+ </maintainer>
+ <longdescription lang="en">
+ A link-local XMPP connection manager for Telepathy.
+ </longdescription>
+</pkgmetadata>
+
diff --git a/net-voip/telepathy-salut/telepathy-salut-0.3.8.ebuild b/net-voip/telepathy-salut/telepathy-salut-0.3.8.ebuild
new file mode 100644
index 000000000000..bb9c1d28ed16
--- /dev/null
+++ b/net-voip/telepathy-salut/telepathy-salut-0.3.8.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-voip/telepathy-salut/telepathy-salut-0.3.8.ebuild,v 1.1 2009/04/18 20:58:31 eva Exp $
+
+EAPI="2"
+
+inherit base
+
+DESCRIPTION="A link-local XMPP connection manager for Telepathy"
+HOMEPAGE="http://telepathy.freedesktop.org/wiki/Components"
+SRC_URI="http://telepathy.freedesktop.org/releases/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ssl test"
+
+# FIXME: Automagic useless libasyncns check ?
+RDEPEND="dev-libs/libxml2
+ >=dev-libs/glib-2.16
+ >=sys-apps/dbus-1.1.0
+ >=dev-libs/dbus-glib-0.61
+ >=net-libs/telepathy-glib-0.7.23
+ >=net-dns/avahi-0.6.22
+ net-libs/libsoup:2.4
+ ssl? ( dev-libs/openssl )"
+DEPEND="${RDEPEND}
+ test? (
+ net-libs/libgsasl
+ app-text/xmldiff
+ >=dev-libs/check-0.9.4
+ dev-python/twisted-words )
+ dev-libs/libxslt
+ >=dev-lang/python-2.4"
+
+src_prepare() {
+ base_src_prepare
+
+ # Disable a failing test, upstream bug #21272
+ sed 's#\(tcase_add_test (tc, test_tcp_listen);\)#/*\1*/#' \
+ -i lib/gibber/tests/check-gibber-listener.c || die "sed failed"
+}
+
+src_configure() {
+ econf $(use_enable ssl)
+ # too much changes required: $(use_enable test avahi-tests)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README || die "dodoc failed"
+}
+