summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-01-14 12:51:26 +0000
committerMike Frysinger <vapier@gentoo.org>2008-01-14 12:51:26 +0000
commit1fabf2d57134c85ef7cf78a7337d6ca6e10904f7 (patch)
tree1262c8d675fb74e1836bb12fc58b221172725023 /net-voip
parentAdd missing pkg-config dependency. Thanks to Patrick in bug #205700. (diff)
downloadgentoo-2-1fabf2d57134c85ef7cf78a7337d6ca6e10904f7.tar.gz
gentoo-2-1fabf2d57134c85ef7cf78a7337d6ca6e10904f7.tar.bz2
gentoo-2-1fabf2d57134c85ef7cf78a7337d6ca6e10904f7.zip
Version bump.
(Portage version: 2.1.4)
Diffstat (limited to 'net-voip')
-rw-r--r--net-voip/linphone/ChangeLog12
-rw-r--r--net-voip/linphone/files/digest-linphone-2.0.13
-rw-r--r--net-voip/linphone/files/linphone-1.99.0-core-amd64.patch11
-rw-r--r--net-voip/linphone/files/linphone-2.0.1-configure-gsm.patch11
-rw-r--r--net-voip/linphone/files/linphone-2.0.1-mediastreamer-deps.patch41
-rw-r--r--net-voip/linphone/linphone-2.0.1.ebuild87
6 files changed, 163 insertions, 2 deletions
diff --git a/net-voip/linphone/ChangeLog b/net-voip/linphone/ChangeLog
index 2b8476f2ef9e..b67dff357835 100644
--- a/net-voip/linphone/ChangeLog
+++ b/net-voip/linphone/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-voip/linphone
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-voip/linphone/ChangeLog,v 1.4 2007/08/20 20:22:42 vapier Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-voip/linphone/ChangeLog,v 1.5 2008/01/14 12:51:25 vapier Exp $
+
+*linphone-2.0.1 (14 Jan 2008)
+
+ 14 Jan 2008; Mike Frysinger <vapier@gentoo.org>
+ +files/linphone-1.99.0-core-amd64.patch,
+ +files/linphone-2.0.1-configure-gsm.patch,
+ +files/linphone-2.0.1-mediastreamer-deps.patch, +linphone-2.0.1.ebuild:
+ Version bump.
*linphone-1.7.1-r1 (20 Aug 2007)
diff --git a/net-voip/linphone/files/digest-linphone-2.0.1 b/net-voip/linphone/files/digest-linphone-2.0.1
new file mode 100644
index 000000000000..dc7dd3302cdc
--- /dev/null
+++ b/net-voip/linphone/files/digest-linphone-2.0.1
@@ -0,0 +1,3 @@
+MD5 30ef5d5cec0f0ff74d84f8191779fd6b linphone-2.0.1.tar.gz 7638627
+RMD160 89c120e5118c931daf9f58d1d988185a28bbcf05 linphone-2.0.1.tar.gz 7638627
+SHA256 33f9e17eba38c55c6b2260e02c98db642dd47d3c38677478a05caa0ae702d16f linphone-2.0.1.tar.gz 7638627
diff --git a/net-voip/linphone/files/linphone-1.99.0-core-amd64.patch b/net-voip/linphone/files/linphone-1.99.0-core-amd64.patch
new file mode 100644
index 000000000000..7aea35496d77
--- /dev/null
+++ b/net-voip/linphone/files/linphone-1.99.0-core-amd64.patch
@@ -0,0 +1,11 @@
+--- linphone-1.99.0/coreapi/linphonecore.c
++++ linphone-1.99.0/coreapi/linphonecore.c
+@@ -1621,7 +1621,7 @@
+ snprintf(dtmf_body, 999, "Signal=%c\r\nDuration=250\r\n", dtmf);
+ osip_message_set_body(msg,dtmf_body,strlen(dtmf_body));
+ osip_message_set_content_type(msg,"application/dtmf-relay");
+- snprintf(clen,sizeof(clen),"%i",strlen(dtmf_body));
++ snprintf(clen,sizeof(clen),"%zu",strlen(dtmf_body));
+ osip_message_set_content_length(msg,clen);
+
+ eXosip_lock();
diff --git a/net-voip/linphone/files/linphone-2.0.1-configure-gsm.patch b/net-voip/linphone/files/linphone-2.0.1-configure-gsm.patch
new file mode 100644
index 000000000000..fe343f2efd30
--- /dev/null
+++ b/net-voip/linphone/files/linphone-2.0.1-configure-gsm.patch
@@ -0,0 +1,11 @@
+--- a/mediastreamer2/configure
++++ b/mediastreamer2/configure
+@@ -22174,7 +22174,7 @@
+
+
+
+-if test "$GSM_found" = "yes" ; then
++if test "$GSM_found" = "yes" && test "$enable_gsm" != "no" ; then
+ build_gsm=yes
+ fi
+
diff --git a/net-voip/linphone/files/linphone-2.0.1-mediastreamer-deps.patch b/net-voip/linphone/files/linphone-2.0.1-mediastreamer-deps.patch
new file mode 100644
index 000000000000..c7aae1725570
--- /dev/null
+++ b/net-voip/linphone/files/linphone-2.0.1-mediastreamer-deps.patch
@@ -0,0 +1,41 @@
+liblinphone.la does not seem to properly add -L paths to libmediastreamer.la,
+so force the issue to work around the link failure caused by the -rpath added
+to /usr/lib/linphone/ and having an already installed older version of linphone
+
+--- console/Makefile.in
++++ console/Makefile.in
+@@ -287,12 +287,12 @@
+ @BUILD_CONSOLE_TRUE@ -I$(osip_prefix)/include
+
+ @BUILD_CONSOLE_TRUE@linphonec_SOURCES = linphonec.c linphonec.h commands.c
+-@BUILD_CONSOLE_TRUE@linphonec_LDADD = $(top_builddir)/coreapi/liblinphone.la $(READLINE_LIBS) $(OSIP_LIBS)
++@BUILD_CONSOLE_TRUE@linphonec_LDADD = $(top_builddir)/coreapi/liblinphone.la $(top_builddir)/mediastreamer2/src/libmediastreamer.la $(READLINE_LIBS) $(OSIP_LIBS)
+ @BUILD_CONSOLE_TRUE@sipomatic_SOURCES = \
+ @BUILD_CONSOLE_TRUE@ sipomatic.c sipomatic.h
+
+ @BUILD_CONSOLE_TRUE@sipomatic_LDADD = $(INTLLIBS) \
+-@BUILD_CONSOLE_TRUE@ $(top_builddir)/coreapi/liblinphone.la \
++@BUILD_CONSOLE_TRUE@ $(top_builddir)/coreapi/liblinphone.la $(top_builddir)/mediastreamer2/src/libmediastreamer.la \
+ @BUILD_CONSOLE_TRUE@ $(OSIP_LIBS)
+
+ AM_CFLAGS = $(STRICT_OPTIONS) -DENABLE_TRACE -D_ORTP_SOURCE $(VIDEO_CFLAGS) $(READLINE_CFLAGS) $(OSIP_CFLAGS)
+--- gtk/Makefile.in
++++ gtk/Makefile.in
+@@ -335,7 +335,7 @@
+ @BUILD_GTK_TRUE@ $(linphone_common_sources)
+
+ @BUILD_GTK_TRUE@linphone_LDADD = $(LIBGTK_LIBS) $(INTLLIBS) \
+-@BUILD_GTK_TRUE@ $(top_builddir)/coreapi/liblinphone.la
++@BUILD_GTK_TRUE@ $(top_builddir)/coreapi/liblinphone.la $(top_builddir)/mediastreamer2/src/libmediastreamer.la
+
+ AM_CFLAGS = $(STRICT_OPTIONS) $(LIBGTK_CFLAGS) $(IPV6_CFLAGS) \
+ $(ORTP_CFLAGS) $(OSIP_CFLAGS)
+@@ -348,7 +348,7 @@
+ @BUILD_GNOME_APPLET_TRUE@linphone_applet_CFLAGS = $(AM_CFLAGS) $(GNOME_APPLETS_CFLAGS) -DLINPHONE_APPLET
+ @BUILD_GNOME_APPLET_TRUE@linphone_applet_LDADD = \
+ @BUILD_GNOME_APPLET_TRUE@ $(GNOME_APPLETS_LIBS) \
+-@BUILD_GNOME_APPLET_TRUE@ $(top_builddir)/coreapi/liblinphone.la \
++@BUILD_GNOME_APPLET_TRUE@ $(top_builddir)/coreapi/liblinphone.la $(top_builddir)/mediastreamer2/src/libmediastreamer.la \
+ @BUILD_GNOME_APPLET_TRUE@ $(OSIP_LIBS)
+
+ @BUILD_GNOME_APPLET_TRUE@serverdir = $(libdir)/bonobo/servers
diff --git a/net-voip/linphone/linphone-2.0.1.ebuild b/net-voip/linphone/linphone-2.0.1.ebuild
new file mode 100644
index 000000000000..a76b28069a9e
--- /dev/null
+++ b/net-voip/linphone/linphone-2.0.1.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-voip/linphone/linphone-2.0.1.ebuild,v 1.1 2008/01/14 12:51:25 vapier Exp $
+
+# Note: video support in linphone relies on swscaler being disabled
+# in ffmpeg. this is because the video code in linphone is old
+# and uses the old interface. solution: fix linphone's video
+# code. workaround: build ffmpeg w/out --enable-swscaler.
+
+inherit eutils
+
+DESCRIPTION="Voice Over IP phone (internet phone which uses SIP)"
+HOMEPAGE="http://www.linphone.org/"
+SRC_URI="http://download.savannah.nongnu.org/releases/${PN}/stable/sources/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="1"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="alsa arts console gsm gtk ilbc ipv6 novideo xv"
+
+RDEPEND="dev-libs/glib
+ dev-perl/XML-Parser
+ net-dns/bind-tools
+ >=net-libs/libosip-3.0.3
+ >=net-libs/libeXosip-3.0.3
+ >=media-libs/speex-1.1.12
+ gsm? ( >=media-sound/gsm-1.0.12 )
+ x86? ( xv? ( dev-lang/nasm ) )
+ gtk? (
+ >=x11-libs/gtk+-2
+ gnome-base/libglade
+ )
+ alsa? ( media-libs/alsa-lib )
+ arts? ( kde-base/arts )
+ ilbc? ( dev-libs/ilbc-rfc3951 )
+ !novideo? (
+ >=media-libs/libsdl-1.2.9
+ media-video/ffmpeg
+ >=media-libs/libtheora-1.0_alpha7
+ )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+# use the bundled ortp until newer versions leave package.mask
+# >=net-libs/ortp-0.9.0
+# portaudio? ( >=media-libs/portaudio-19_pre )"
+# media-libs/gsm-1.0.12 fails on amd64 due to bug #192736
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/linphone-1.6.0-call.patch
+ epatch "${FILESDIR}"/linphone-1.99.0-core-amd64.patch
+ epatch "${FILESDIR}"/linphone-2.0.1-configure-gsm.patch
+ epatch "${FILESDIR}"/linphone-2.0.1-mediastreamer-deps.patch
+}
+
+src_compile() {
+ econf \
+ --disable-strict \
+ --libdir=/usr/$(get_libdir)/linphone \
+ $(use_enable console console_ui) \
+ $(use_enable gtk gtk_ui) \
+ $(use_with ilbc) \
+ $(use_enable ipv6) \
+ $(use_enable alsa) \
+ $(use_enable arts artsc) \
+ $(use_enable gsm) \
+ $(use_enable !novideo video) \
+ --disable-portaudio \
+ $(use_enable x86 truespeech) \
+ || die "Unable to configure"
+ #--enable-external-ortp \
+ #$(use_enable portaudio)
+ emake || die "Unable to make"
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "Failed to install"
+ dodoc AUTHORS BUGS ChangeLog INSTALL NEWS README README.arm TODO
+
+ # don't install ortp includes, docs and pkgconfig files
+ # to avoid conflicts with net-libs/ortp
+ rm -rf "${D}"/usr/include/ortp
+ rm -rf "${D}"/usr/share/gtk-doc/html/ortp
+ rm -rf "${D}"/usr/$(get_libdir)/linphone/pkgconfig
+ rm -rf "${D}"/ortp
+}