summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2013-09-17 12:30:09 +0000
committerTom Wijsman <tomwij@gentoo.org>2013-09-17 12:30:09 +0000
commit921a3fc9d6f1828c30d72abccb8480abf35e797b (patch)
tree1104a3039208a7ba09562f219fddb1e24f073de0 /net-proxy
parentAdd multilib_build_binaries function to multilib-build eclass (diff)
downloadgentoo-2-921a3fc9d6f1828c30d72abccb8480abf35e797b.tar.gz
gentoo-2-921a3fc9d6f1828c30d72abccb8480abf35e797b.tar.bz2
gentoo-2-921a3fc9d6f1828c30d72abccb8480abf35e797b.zip
Revision bump. Add systemd service unit. Add tools USE flag that install halog and iprange. EAPI 5. Part of the changes are contributed by Bertrand Jacquin (beber), fixes bug #466404.
(Portage version: HEAD/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'net-proxy')
-rw-r--r--net-proxy/haproxy/ChangeLog10
-rw-r--r--net-proxy/haproxy/haproxy-1.5_beta19-r1.ebuild126
-rw-r--r--net-proxy/haproxy/haproxy-9999.ebuild51
-rw-r--r--net-proxy/haproxy/metadata.xml3
4 files changed, 173 insertions, 17 deletions
diff --git a/net-proxy/haproxy/ChangeLog b/net-proxy/haproxy/ChangeLog
index e7b0f155e202..3b5fa5abff34 100644
--- a/net-proxy/haproxy/ChangeLog
+++ b/net-proxy/haproxy/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-proxy/haproxy
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/haproxy/ChangeLog,v 1.84 2013/06/30 21:14:11 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/haproxy/ChangeLog,v 1.85 2013/09/17 12:30:09 tomwij Exp $
+
+*haproxy-1.5_beta19-r1 (17 Sep 2013)
+
+ 17 Sep 2013; Tom Wijsman <TomWij@gentoo.org> +haproxy-1.5_beta19-r1.ebuild,
+ haproxy-9999.ebuild, metadata.xml:
+ Revision bump. Add systemd service unit. Add tools USE flag that install halog
+ and iprange. EAPI 5. Part of the changes are contributed by Bertrand Jacquin
+ (beber), fixes bug #466404.
30 Jun 2013; Agostino Sarubbo <ago@gentoo.org> haproxy-1.4.24.ebuild:
Stable for ppc, wrt bug #473674
diff --git a/net-proxy/haproxy/haproxy-1.5_beta19-r1.ebuild b/net-proxy/haproxy/haproxy-1.5_beta19-r1.ebuild
new file mode 100644
index 000000000000..3061a6bc0bd9
--- /dev/null
+++ b/net-proxy/haproxy/haproxy-1.5_beta19-r1.ebuild
@@ -0,0 +1,126 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/haproxy/haproxy-1.5_beta19-r1.ebuild,v 1.1 2013/09/17 12:30:09 tomwij Exp $
+
+EAPI="5"
+
+inherit user versionator toolchain-funcs flag-o-matic systemd
+
+MY_P="${PN}-${PV/_beta/-dev}"
+
+DESCRIPTION="A TCP/HTTP reverse proxy for high availability environments"
+HOMEPAGE="http://haproxy.1wt.eu"
+SRC_URI="http://haproxy.1wt.eu/download/$(get_version_component_range 1-2)/src/devel/${MY_P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="+crypt examples +pcre ssl tools vim-syntax +zlib"
+
+DEPEND="pcre? ( dev-libs/libpcre )
+ ssl? ( dev-libs/openssl[zlib?] )
+ zlib? ( sys-libs/zlib )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ enewgroup haproxy
+ enewuser haproxy -1 -1 -1 haproxy
+}
+
+src_prepare() {
+ sed -e 's:@SBINDIR@:'/usr/sbin':' contrib/systemd/haproxy.service.in \
+ > contrib/systemd/haproxy.service || die
+}
+
+src_compile() {
+ local args="TARGET=linux2628 USE_GETADDRINFO=1"
+
+ if use pcre ; then
+ args="${args} USE_PCRE=1 USE_PCRE_JIT=1"
+ else
+ args="${args} USE_PCRE= USE_PCRE_JIT="
+ fi
+
+# if use kernel_linux; then
+# args="${args} USE_LINUX_SPLICE=1 USE_LINUX_TPROXY=1"
+# else
+# args="${args} USE_LINUX_SPLICE= USE_LINUX_TPROXY="
+# fi
+
+ if use crypt ; then
+ args="${args} USE_LIBCRYPT=1"
+ else
+ args="${args} USE_LIBCRYPT="
+ fi
+
+ if use ssl ; then
+ args="${args} USE_OPENSSL=1"
+ else
+ args="${args} USE_OPENSSL="
+ fi
+
+ if use zlib ; then
+ args="${args} USE_ZLIB=1"
+ else
+ args="${args} USE_ZLIB="
+ fi
+
+ # For now, until the strict-aliasing breakage will be fixed
+# append-cflags -fno-strict-aliasing
+
+ emake CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" CC=$(tc-getCC) ${args}
+
+ if use tools ; then
+ for contrib in halog iprange ; do
+ emake -C contrib/${contrib} \
+ CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" CC=$(tc-getCC) ${args}
+ done
+ fi
+}
+
+src_install() {
+ dobin haproxy
+
+ newinitd "${FILESDIR}/haproxy.initd-r2" haproxy
+
+ # Don't install useless files
+# rm examples/build.cfg doc/*gpl.txt
+
+ dodoc CHANGELOG ROADMAP TODO doc/{configuration,haproxy-en}.txt
+ doman doc/haproxy.1
+
+ dosbin haproxy-systemd-wrapper
+ systemd_dounit contrib/systemd/haproxy.service
+
+ if use tools ; then
+ for contrib in halog iprange ; do
+ dobin contrib/${contrib}/${contrib}
+ done
+ fi
+
+ if use examples ; then
+ docinto examples
+ dodoc examples/*.cfg
+ fi
+
+ if use vim-syntax ; then
+ insinto /usr/share/vim/vimfiles/syntax
+ doins examples/haproxy.vim
+ fi
+}
+
+pkg_postinst() {
+ if [[ ! -f "${ROOT}/etc/haproxy.cfg" ]] ; then
+ ewarn "You need to create /etc/haproxy.cfg before you start the haproxy service."
+ ewarn "It's best practice to not run haproxy as root, user and group haproxy was therefore created."
+ ewarn "Make use of them with the \"user\" and \"group\" directives."
+
+ if [[ -d "${ROOT}/usr/share/doc/${PF}" ]]; then
+ einfo "Please consult the installed documentation for learning the configuration file's syntax."
+ einfo "The documentation and sample configuration files are installed here:"
+ einfo " ${ROOT}usr/share/doc/${PF}"
+ fi
+ fi
+}
diff --git a/net-proxy/haproxy/haproxy-9999.ebuild b/net-proxy/haproxy/haproxy-9999.ebuild
index 473963bc9521..97490eee19ba 100644
--- a/net-proxy/haproxy/haproxy-9999.ebuild
+++ b/net-proxy/haproxy/haproxy-9999.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/haproxy/haproxy-9999.ebuild,v 1.1 2013/05/13 20:11:16 idl0r Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/haproxy/haproxy-9999.ebuild,v 1.2 2013/09/17 12:30:09 tomwij Exp $
EAPI="5"
-inherit user versionator toolchain-funcs flag-o-matic git-2
+inherit user versionator toolchain-funcs flag-o-matic git-2 systemd
MY_P="${PN}-${PV/_beta/-dev}"
@@ -15,7 +15,7 @@ EGIT_REPO_URI="http://master.formilux.org/git/people/willy/haproxy.git"
LICENSE="GPL-2 LGPL-2.1"
SLOT="0"
KEYWORDS=""
-IUSE="+crypt examples +pcre ssl vim-syntax +zlib"
+IUSE="+crypt examples +pcre ssl tools vim-syntax +zlib"
DEPEND="pcre? ( dev-libs/libpcre )
ssl? ( dev-libs/openssl[zlib?] )
@@ -29,10 +29,15 @@ pkg_setup() {
enewuser haproxy -1 -1 -1 haproxy
}
+src_prepare() {
+ sed -e 's:@SBINDIR@:'/usr/sbin':' contrib/systemd/haproxy.service.in \
+ > contrib/systemd/haproxy.service || die
+}
+
src_compile() {
local args="TARGET=linux2628 USE_GETADDRINFO=1"
- if use pcre; then
+ if use pcre ; then
args="${args} USE_PCRE=1 USE_PCRE_JIT=1"
else
args="${args} USE_PCRE= USE_PCRE_JIT="
@@ -44,19 +49,19 @@ src_compile() {
# args="${args} USE_LINUX_SPLICE= USE_LINUX_TPROXY="
# fi
- if use crypt; then
+ if use crypt ; then
args="${args} USE_LIBCRYPT=1"
else
args="${args} USE_LIBCRYPT="
fi
- if use ssl; then
+ if use ssl ; then
args="${args} USE_OPENSSL=1"
else
args="${args} USE_OPENSSL="
fi
- if use zlib; then
+ if use zlib ; then
args="${args} USE_ZLIB=1"
else
args="${args} USE_ZLIB="
@@ -65,13 +70,20 @@ src_compile() {
# For now, until the strict-aliasing breakage will be fixed
# append-cflags -fno-strict-aliasing
- emake CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" CC=$(tc-getCC) ${args} || die
+ emake CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" CC=$(tc-getCC) ${args}
+
+ if use tools ; then
+ for contrib in halog iprange ; do
+ emake -C contrib/${contrib} \
+ CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" CC=$(tc-getCC) ${args}
+ done
+ fi
}
src_install() {
- dobin haproxy || die
+ dobin haproxy
- newinitd "${FILESDIR}/haproxy.initd-r2" haproxy || die
+ newinitd "${FILESDIR}/haproxy.initd-r2" haproxy
# Don't install useless files
# rm examples/build.cfg doc/*gpl.txt
@@ -79,16 +91,23 @@ src_install() {
dodoc CHANGELOG ROADMAP TODO doc/{configuration,haproxy-en}.txt
doman doc/haproxy.1
- if use examples;
- then
+ dosbin haproxy-systemd-wrapper
+ systemd_dounit contrib/systemd/haproxy.service
+
+ if use tools ; then
+ for contrib in halog iprange ; do
+ dobin contrib/${contrib}/${contrib}
+ done
+ fi
+
+ if use examples ; then
docinto examples
- dodoc examples/*.cfg || die
+ dodoc examples/*.cfg
fi
- if use vim-syntax;
- then
+ if use vim-syntax ; then
insinto /usr/share/vim/vimfiles/syntax
- doins examples/haproxy.vim || die
+ doins examples/haproxy.vim
fi
}
diff --git a/net-proxy/haproxy/metadata.xml b/net-proxy/haproxy/metadata.xml
index d9588385b79a..c88fcd83f296 100644
--- a/net-proxy/haproxy/metadata.xml
+++ b/net-proxy/haproxy/metadata.xml
@@ -19,4 +19,7 @@ It can:
- block requests matching a particular pattern
Its event-driven architecture allows it to easily handle thousands of simultaneous connections on hundreds of instances without risking the system's stability.
</longdescription>
+ <use>
+ <flag name='tools'>Install additional tools (halog, iprange).</flag>
+ </use>
</pkgmetadata>