summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2013-09-17 12:51:48 +0000
committerTom Wijsman <tomwij@gentoo.org>2013-09-17 12:51:48 +0000
commit4456a98bfd634bdd0becfa0476e1fecfb0850624 (patch)
tree7cbf4a18fafb60f77d54c791b4f971903fadc2cb /net-proxy
parentRevision bump. Add systemd service unit. Add tools USE flag that install halo... (diff)
downloadgentoo-2-4456a98bfd634bdd0becfa0476e1fecfb0850624.tar.gz
gentoo-2-4456a98bfd634bdd0becfa0476e1fecfb0850624.tar.bz2
gentoo-2-4456a98bfd634bdd0becfa0476e1fecfb0850624.zip
Version bump to 1.5_beta. EAPI 5. Dropped the patches that were applied upstream. Fixes bug #485148, reported by Manuel Rüger (mrueg).
(Portage version: HEAD/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'net-proxy')
-rw-r--r--net-proxy/squidguard/ChangeLog11
-rw-r--r--net-proxy/squidguard/files/squidguard-1.5_beta-gentoo.patch50
-rw-r--r--net-proxy/squidguard/squidguard-1.5_beta.ebuild74
3 files changed, 133 insertions, 2 deletions
diff --git a/net-proxy/squidguard/ChangeLog b/net-proxy/squidguard/ChangeLog
index a173809ffc57..efeeb8622b69 100644
--- a/net-proxy/squidguard/ChangeLog
+++ b/net-proxy/squidguard/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-proxy/squidguard
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/squidguard/ChangeLog,v 1.44 2012/09/03 21:26:47 blueness Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/squidguard/ChangeLog,v 1.45 2013/09/17 12:51:48 tomwij Exp $
+
+*squidguard-1.5_beta (17 Sep 2013)
+
+ 17 Sep 2013; Tom Wijsman <TomWij@gentoo.org>
+ +files/squidguard-1.5_beta-gentoo.patch, +squidguard-1.5_beta.ebuild:
+ Version bump to 1.5_beta. EAPI 5. Dropped the patches that were applied
+ upstream. Fixes bug #485148, reported by Manuel Rüger (mrueg).
03 Sep 2012; Anthony G. Basile <blueness@gentoo.org>
squidguard-1.4-r4.ebuild:
diff --git a/net-proxy/squidguard/files/squidguard-1.5_beta-gentoo.patch b/net-proxy/squidguard/files/squidguard-1.5_beta-gentoo.patch
new file mode 100644
index 000000000000..814079764a3f
--- /dev/null
+++ b/net-proxy/squidguard/files/squidguard-1.5_beta-gentoo.patch
@@ -0,0 +1,50 @@
+diff -Nru squidGuard-1.4.orig/Makefile.in squidGuard-1.4/Makefile.in
+--- squidGuard-1.4.orig/Makefile.in 2008-05-17 18:36:44.000000000 +0000
++++ squidGuard-1.4/Makefile.in 2009-01-10 13:02:14.000000000 +0000
+@@ -43,7 +43,7 @@
+ # Dependencies for installing
+ #
+
+-install: install-build install-conf
++install: install-build
+
+ install-conf:
+ @echo Installing configuration file ;
+@@ -85,10 +85,10 @@
+
+ install-build:
+ @echo Installing squidGuard
+- @if [ ! -d $(bindir) ]; then \
+- $(MKINSTALLDIRS) $(bindir) ; \
++ @if [ ! -d "$(INSTDIR)"/$(bindir) ]; then \
++ $(MKINSTALLDIRS) "$(INSTDIR)"/$(bindir) ; \
+ fi ; \
+- cp src/squidGuard $(bindir) || exit 1 ; \
++ cp src/squidGuard "$(INSTDIR)"/$(bindir) || exit 1 ; \
+ echo Done. ;
+
+ clean::
+diff -Nru squidGuard-1.4.orig/src/Makefile.in squidGuard-1.4/src/Makefile.in
+--- squidGuard-1.4.orig/src/Makefile.in 2009-01-03 20:05:39.000000000 +0000
++++ squidGuard-1.4/src/Makefile.in 2009-01-10 13:02:14.000000000 +0000
+@@ -110,6 +110,8 @@
+ mv -f y.tab.c y.tab.c.bison
+ mv -f y.tab.h y.tab.h.bison
+
++sg.y sg.l:
++
+ #
+ # Dependencies for installing
+ #
+@@ -122,8 +124,8 @@
+
+ install.bin:: squidGuard
+ @echo making $@ in `basename \`pwd\``
+- @$(MKDIR) $(bindir) $(logdir) $(cfgdir)
+- $(INSTALL_PROGRAM) squidGuard $(bindir)/squidGuard
++ @$(MKDIR) "$(INSTDIR)"/$(bindir) "$(INSTDIR)"/$(logdir) "$(INSTDIR)"/$(cfgdir)
++ $(INSTALL_PROGRAM) squidGuard "$(INSTDIR)"/$(bindir)/squidGuard
+
+ uninstall.bin::
+ @echo making $@ in `basename \`pwd\``
+diff -Nru squidGuard-1.4.orig/src/sgDb.c squidGuard-1.4/src/sgDb.c
diff --git a/net-proxy/squidguard/squidguard-1.5_beta.ebuild b/net-proxy/squidguard/squidguard-1.5_beta.ebuild
new file mode 100644
index 000000000000..d40e5aa1d0a6
--- /dev/null
+++ b/net-proxy/squidguard/squidguard-1.5_beta.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/squidguard/squidguard-1.5_beta.ebuild,v 1.1 2013/09/17 12:51:48 tomwij Exp $
+
+EAPI="5"
+
+WANT_AUTOMAKE=none
+
+inherit eutils autotools
+
+MY_P="squidGuard-${PV/_/-}"
+
+DESCRIPTION="Combined filter, redirector and access controller plugin for Squid."
+HOMEPAGE="http://www.squidguard.org"
+SRC_URI="http://www.squidguard.org/Downloads/Devel/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="ldap"
+
+RDEPEND=">=sys-libs/db-2
+ ldap? ( net-nds/openldap:0 )"
+
+DEPEND="${RDEPEND}
+ sys-devel/bison:0
+ sys-devel/flex:0"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ enewgroup squid 31
+ enewuser squid 31 -1 /var/cache/squid squid
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_with ldap) \
+ --with-sg-config=/etc/squidGuard/squidGuard.conf \
+ --with-sg-logdir=/var/log/squidGuard
+}
+
+src_install() {
+ emake prefix="/usr" INSTDIR="${D}" install
+
+ keepdir /var/log/squidGuard
+ fowners squid:squid /var/log/squidGuard
+
+ insinto /etc/squidGuard/sample
+ doins "${FILESDIR}"/squidGuard.conf.*
+ insinto /etc/squidGuard/sample/db
+ doins "${FILESDIR}"/blockedsites
+
+ dodoc ANNOUNCE CHANGELOG README
+ dohtml doc/*.html
+ docinto text
+ dodoc doc/*.txt
+}
+
+pkg_postinst() {
+ einfo "To enable squidGuard, add the following lines to /etc/squid/squid.conf:"
+ einfo " url_rewrite_program /usr/bin/squidGuard"
+ einfo " url_rewrite_children 10"
+ einfo ""
+ einfo "Remember to edit /etc/squidGuard/squidGuard.conf first!"
+ einfo "Examples can be found in /etc/squidGuard/sample/"
+}