summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2008-07-16 21:11:40 +0000
committerAlin Năstac <mrness@gentoo.org>2008-07-16 21:11:40 +0000
commit9beee0edcf7d4ca522c0bbf54e2292bc2cc2134e (patch)
tree38cc02480469fad19426c0d5ee2262db400126d8 /net-proxy/squidguard
parentAdd ~sparc keyword (diff)
downloadgentoo-2-9beee0edcf7d4ca522c0bbf54e2292bc2cc2134e.tar.gz
gentoo-2-9beee0edcf7d4ca522c0bbf54e2292bc2cc2134e.tar.bz2
gentoo-2-9beee0edcf7d4ca522c0bbf54e2292bc2cc2134e.zip
Add latest upstream bug fixes, thanks to Yar Odin <yarodin@gmail.com> (#231861).
(Portage version: 2.1.4.4, RepoMan options: --force)
Diffstat (limited to 'net-proxy/squidguard')
-rw-r--r--net-proxy/squidguard/ChangeLog8
-rw-r--r--net-proxy/squidguard/squidguard-1.3-r3.ebuild76
2 files changed, 83 insertions, 1 deletions
diff --git a/net-proxy/squidguard/ChangeLog b/net-proxy/squidguard/ChangeLog
index ce6f30704383..1c10197a55ab 100644
--- a/net-proxy/squidguard/ChangeLog
+++ b/net-proxy/squidguard/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-proxy/squidguard
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/squidguard/ChangeLog,v 1.25 2008/07/08 21:16:23 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/squidguard/ChangeLog,v 1.26 2008/07/16 21:11:40 mrness Exp $
+
+*squidguard-1.3-r3 (16 Jul 2008)
+
+ 16 Jul 2008; Alin Năstac <mrness@gentoo.org> +squidguard-1.3-r3.ebuild:
+ Add latest upstream bug fixes, thanks to Yar Odin <yarodin@gmail.com>
+ (#231861).
*squidguard-1.3-r2 (08 Jul 2008)
diff --git a/net-proxy/squidguard/squidguard-1.3-r3.ebuild b/net-proxy/squidguard/squidguard-1.3-r3.ebuild
new file mode 100644
index 000000000000..c25c3d623cd1
--- /dev/null
+++ b/net-proxy/squidguard/squidguard-1.3-r3.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/squidguard/squidguard-1.3-r3.ebuild,v 1.1 2008/07/16 21:11:40 mrness Exp $
+
+WANT_AUTOMAKE=none
+
+inherit eutils autotools
+
+DESCRIPTION="Combined filter, redirector and access controller plugin for Squid."
+HOMEPAGE="http://www.squidguard.org"
+SRC_URI="http://www.squidguard.org/Downloads/squidGuard-${PV}.tar.gz
+ http://www.squidguard.org/Downloads/Patches/${PV}/squidGuard-${PV}-patch-20080714.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86"
+IUSE="ldap"
+
+RDEPEND="net-proxy/squid
+ >=sys-libs/db-2
+ ldap? ( net-nds/openldap )"
+DEPEND="${RDEPEND}
+ sys-devel/bison
+ sys-devel/flex"
+
+S="${WORKDIR}/squidGuard-${PV}"
+
+RESTRICT="test" # tests are currently broken
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+ cp ../squidGuard-${PV}-patch-20080714/src/sgDb.c src/ || die "failed to replace sgDiv.c"
+ cp ../squidGuard-${PV}-patch-20080714/src/sgDiv.c.in src/ || die "failed to replace sgDiv.c.in"
+ epatch "${FILESDIR}/${P}-gentoo.patch"
+ epatch "${FILESDIR}/${P}-autoheader.patch"
+ epatch "${FILESDIR}/${P}-bison.patch"
+ eautoreconf
+}
+
+src_compile() {
+ econf \
+ $(use_with ldap) \
+ --with-sg-config=/etc/squidGuard/squidGuard.conf \
+ --with-sg-logdir=/var/log/squidGuard \
+ || die "configure has failed"
+
+ emake || die "make has failed"
+}
+
+src_install() {
+ emake prefix="/usr" INSTDIR="${D}" install || die "emake install has failed"
+
+ keepdir /var/log/squidGuard
+ fowners squid:squid /var/log/squidGuard
+
+ insinto /etc/squidGuard/sample
+ doins "${FILESDIR}"/squidGuard.conf.*
+ insinto /etc/squidGuard/sample/db
+ doins "${FILESDIR}"/blockedsites
+
+ dodoc ANNOUNCE CHANGELOG README
+ dohtml doc/*.html
+ docinto text
+ dodoc doc/*.txt
+}
+
+pkg_postinst() {
+ einfo "To enable squidGuard, add the following lines to /etc/squid/squid.conf:"
+ einfo " url_rewrite_program /usr/bin/squidGuard"
+ einfo " url_rewrite_children 10"
+ einfo ""
+ einfo "Remember to edit /etc/squidGuard/squidGuard.conf first!"
+ einfo "Examples can be found in /etc/squidGuard/sample/"
+}