summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Ruppert <idl0r@gentoo.org>2011-09-04 16:12:21 +0000
committerChristian Ruppert <idl0r@gentoo.org>2011-09-04 16:12:21 +0000
commit9baf26ccfd1c849c422aaa2548414d3f3aa463ca (patch)
tree353775a65b29cf7cd83d153d3264c10819983a70 /net-proxy/haproxy
parentTry to consolidate python test and doc useflags by REQUIRED_USE usage. Add pa... (diff)
downloadgentoo-2-9baf26ccfd1c849c422aaa2548414d3f3aa463ca.tar.gz
gentoo-2-9baf26ccfd1c849c422aaa2548414d3f3aa463ca.tar.bz2
gentoo-2-9baf26ccfd1c849c422aaa2548414d3f3aa463ca.zip
Version bump to 1.3.26 and 1.4.16.
(Portage version: 2.2.0_alpha53/cvs/Linux x86_64)
Diffstat (limited to 'net-proxy/haproxy')
-rw-r--r--net-proxy/haproxy/ChangeLog9
-rw-r--r--net-proxy/haproxy/haproxy-1.3.26.ebuild70
-rw-r--r--net-proxy/haproxy/haproxy-1.4.16.ebuild72
3 files changed, 150 insertions, 1 deletions
diff --git a/net-proxy/haproxy/ChangeLog b/net-proxy/haproxy/ChangeLog
index b2e5e7a7dcfe..bde6e4e5fe72 100644
--- a/net-proxy/haproxy/ChangeLog
+++ b/net-proxy/haproxy/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-proxy/haproxy
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/haproxy/ChangeLog,v 1.51 2011/07/23 11:26:44 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/haproxy/ChangeLog,v 1.52 2011/09/04 16:12:21 idl0r Exp $
+
+*haproxy-1.4.16 (04 Sep 2011)
+*haproxy-1.3.26 (04 Sep 2011)
+
+ 04 Sep 2011; Christian Ruppert <idl0r@gentoo.org> +haproxy-1.3.26.ebuild,
+ +haproxy-1.4.16.ebuild:
+ Version bump to 1.3.26 and 1.4.16.
23 Jul 2011; Markus Meier <maekke@gentoo.org> haproxy-1.4.15.ebuild:
x86 stable, bug #375111
diff --git a/net-proxy/haproxy/haproxy-1.3.26.ebuild b/net-proxy/haproxy/haproxy-1.3.26.ebuild
new file mode 100644
index 000000000000..e51466682129
--- /dev/null
+++ b/net-proxy/haproxy/haproxy-1.3.26.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/haproxy/haproxy-1.3.26.ebuild,v 1.1 2011/09/04 16:12:21 idl0r Exp $
+
+inherit eutils versionator toolchain-funcs
+
+DESCRIPTION="A TCP/HTTP reverse proxy for high availability environments"
+HOMEPAGE="http://haproxy.1wt.eu"
+SRC_URI="http://haproxy.1wt.eu/download/$(get_version_component_range 1-2)/src/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="examples pcre vim-syntax"
+
+DEPEND="pcre? ( dev-libs/libpcre )"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ enewgroup haproxy
+ enewuser haproxy -1 -1 -1 haproxy
+}
+
+src_compile() {
+ local args="TARGET=linux26"
+
+ use pcre && args="${args} USE_PCRE=1"
+
+ use kernel_linux && args="${args} USE_LINUX_SPLICE=1"
+ use kernel_linux && args="${args} USE_LINUX_TPROXY=1"
+
+ emake CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" CC=$(tc-getCC) ${args} || die
+}
+
+src_install() {
+ dobin haproxy || die
+ newinitd "${FILESDIR}/haproxy.initd" haproxy || die
+
+ # Don't install useless files
+ rm examples/build.cfg doc/*gpl.txt
+
+ dodoc CHANGELOG ROADMAP TODO doc/{configuration,haproxy-en}.txt
+ doman doc/haproxy.1
+
+ if use examples;
+ then
+ docinto examples
+ dodoc examples/*.cfg || die
+ fi
+
+ if use vim-syntax;
+ then
+ insinto /usr/share/vim/vimfiles/syntax
+ doins examples/haproxy.vim || die
+ fi
+}
+
+pkg_postinst() {
+ if [[ ! -f "${ROOT}/etc/haproxy.cfg" ]] ; then
+ ewarn "You need to create /etc/haproxy.cfg before you start the haproxy service."
+ ewarn "It's best practice to not run haproxy as root, user and group haproxy was therefore created."
+ ewarn "Make use of them with the \"user\" and \"group\" directives."
+
+ if [[ -d "${ROOT}/usr/share/doc/${PF}" ]]; then
+ einfo "Please consult the installed documentation for learning the configuration file's syntax."
+ einfo "The documentation and sample configuration files are installed here:"
+ einfo " ${ROOT}usr/share/doc/${PF}"
+ fi
+ fi
+}
diff --git a/net-proxy/haproxy/haproxy-1.4.16.ebuild b/net-proxy/haproxy/haproxy-1.4.16.ebuild
new file mode 100644
index 000000000000..53441b658dee
--- /dev/null
+++ b/net-proxy/haproxy/haproxy-1.4.16.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/haproxy/haproxy-1.4.16.ebuild,v 1.1 2011/09/04 16:12:21 idl0r Exp $
+
+EAPI="3"
+
+inherit eutils versionator toolchain-funcs
+
+DESCRIPTION="A TCP/HTTP reverse proxy for high availability environments"
+HOMEPAGE="http://haproxy.1wt.eu"
+SRC_URI="http://haproxy.1wt.eu/download/$(get_version_component_range 1-2)/src/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="examples pcre vim-syntax"
+
+DEPEND="pcre? ( dev-libs/libpcre )"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ enewgroup haproxy
+ enewuser haproxy -1 -1 -1 haproxy
+}
+
+src_compile() {
+ local args="TARGET=linux26"
+
+ use pcre && args="${args} USE_PCRE=1"
+
+ use kernel_linux && args="${args} USE_LINUX_SPLICE=1"
+ use kernel_linux && args="${args} USE_LINUX_TPROXY=1"
+
+ emake CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" CC=$(tc-getCC) ${args} || die
+}
+
+src_install() {
+ dobin haproxy || die
+ newinitd "${FILESDIR}/haproxy.initd" haproxy || die
+
+ # Don't install useless files
+ rm examples/build.cfg doc/*gpl.txt
+
+ dodoc CHANGELOG ROADMAP TODO doc/{configuration,haproxy-en}.txt
+ doman doc/haproxy.1
+
+ if use examples;
+ then
+ docinto examples
+ dodoc examples/*.cfg || die
+ fi
+
+ if use vim-syntax;
+ then
+ insinto /usr/share/vim/vimfiles/syntax
+ doins examples/haproxy.vim || die
+ fi
+}
+
+pkg_postinst() {
+ if [[ ! -f "${ROOT}/etc/haproxy.cfg" ]] ; then
+ ewarn "You need to create /etc/haproxy.cfg before you start the haproxy service."
+ ewarn "It's best practice to not run haproxy as root, user and group haproxy was therefore created."
+ ewarn "Make use of them with the \"user\" and \"group\" directives."
+
+ if [[ -d "${ROOT}/usr/share/doc/${PF}" ]]; then
+ einfo "Please consult the installed documentation for learning the configuration file's syntax."
+ einfo "The documentation and sample configuration files are installed here:"
+ einfo " ${ROOT}usr/share/doc/${PF}"
+ fi
+ fi
+}