summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-06-07 06:04:05 +0000
committerTim Harder <radhermit@gentoo.org>2011-06-07 06:04:05 +0000
commitf6328e729cecb2b8f2459ef5acd1c2c4f6e4e5e9 (patch)
tree6455ed040c8abaf62b6e26a5d24cf923481801f1 /net-proxy/dante
parentmigrate live ebuild to eapi 4. (diff)
downloadgentoo-2-f6328e729cecb2b8f2459ef5acd1c2c4f6e4e5e9.tar.gz
gentoo-2-f6328e729cecb2b8f2459ef5acd1c2c4f6e4e5e9.tar.bz2
gentoo-2-f6328e729cecb2b8f2459ef5acd1c2c4f6e4e5e9.zip
Version bump (bug #310255). Update to EAPI 4 and add kerberos and static-libs USE flags.
(Portage version: 2.2.0_alpha37/cvs/Linux x86_64)
Diffstat (limited to 'net-proxy/dante')
-rw-r--r--net-proxy/dante/ChangeLog11
-rw-r--r--net-proxy/dante/dante-1.2.3.ebuild74
-rw-r--r--net-proxy/dante/files/dante-1.2.3-socksify.patch25
3 files changed, 108 insertions, 2 deletions
diff --git a/net-proxy/dante/ChangeLog b/net-proxy/dante/ChangeLog
index 7a586c261271..3cb1872fd5d4 100644
--- a/net-proxy/dante/ChangeLog
+++ b/net-proxy/dante/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-proxy/dante
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/dante/ChangeLog,v 1.54 2009/09/23 19:48:30 patrick Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/dante/ChangeLog,v 1.55 2011/06/07 06:04:05 radhermit Exp $
+
+*dante-1.2.3 (07 Jun 2011)
+
+ 07 Jun 2011; Tim Harder <radhermit@gentoo.org> +dante-1.2.3.ebuild,
+ +files/dante-1.2.3-socksify.patch:
+ Version bump (bug #310255). Update to EAPI 4 and add kerberos and static-libs
+ USE flags.
23 Sep 2009; Patrick Lauer <patrick@gentoo.org> dante-1.1.19-r4.ebuild:
Remove virtual/libc
diff --git a/net-proxy/dante/dante-1.2.3.ebuild b/net-proxy/dante/dante-1.2.3.ebuild
new file mode 100644
index 000000000000..1fd8486a8c81
--- /dev/null
+++ b/net-proxy/dante/dante-1.2.3.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/dante/dante-1.2.3.ebuild,v 1.1 2011/06/07 06:04:05 radhermit Exp $
+
+EAPI=4
+
+inherit eutils
+
+DESCRIPTION="A free socks4,5 and msproxy implementation"
+HOMEPAGE="http://www.inet.no/dante/"
+SRC_URI="ftp://ftp.inet.no/pub/socks/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="debug kerberos pam selinux static-libs tcpd"
+
+RDEPEND="pam? ( virtual/pam )
+ kerberos? ( virtual/krb5 )
+ selinux? ( sec-policy/selinux-dante )
+ tcpd? ( sys-apps/tcp-wrappers )
+ userland_GNU? ( sys-apps/shadow )"
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ sys-devel/bison"
+
+DOCS="BUGS CREDITS NEWS README SUPPORT TODO doc/README* doc/*.txt doc/SOCKS4.protocol"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-socksify.patch"
+
+ sed -i \
+ -e 's:/etc/socks\.conf:/etc/socks/socks.conf:' \
+ -e 's:/etc/sockd\.conf:/etc/socks/sockd.conf:' \
+ doc/{socksify.1,socks.conf.5,sockd.conf.5,sockd.8}
+}
+
+src_configure() {
+ econf \
+ --with-socks-conf=/etc/socks/socks.conf \
+ --with-sockd-conf=/etc/socks/sockd.conf \
+ --without-upnp \
+ $(use_enable debug) \
+ $(use_with kerberos gssapi) \
+ $(use_with pam) \
+ $(use_enable static-libs static) \
+ $(use_enable tcpd libwrap)
+}
+
+src_install() {
+ default
+
+ # default configuration files
+ insinto /etc/socks
+ doins "${FILESDIR}"/sock?.conf
+ pushd "${D}/etc/socks" > /dev/null
+ use pam && epatch "${FILESDIR}/sockd.conf-with-pam.patch"
+ use tcpd && epatch "${FILESDIR}/sockd.conf-with-libwrap.patch"
+ popd > /dev/null
+
+ # init script
+ newinitd "${FILESDIR}/dante-sockd-init" dante-sockd
+ newconfd "${FILESDIR}/dante-sockd-conf" dante-sockd
+
+ # example configuration files
+ docinto examples
+ dodoc example/*.conf
+
+ use static-libs || find "${ED}" -name '*.la' -exec rm '{}' +
+}
+
+pkg_postinst() {
+ enewuser sockd -1 -1 /etc/socks daemon
+}
diff --git a/net-proxy/dante/files/dante-1.2.3-socksify.patch b/net-proxy/dante/files/dante-1.2.3-socksify.patch
new file mode 100644
index 000000000000..9b8f97b32289
--- /dev/null
+++ b/net-proxy/dante/files/dante-1.2.3-socksify.patch
@@ -0,0 +1,25 @@
+--- dante-1.2.3/bin/socksify.in.orig
++++ dante-1.2.3/bin/socksify.in
+@@ -47,8 +47,6 @@
+ #been relinked or recompiled. This will not work on statically linked
+ #binaries.
+
+-SOCKSIFY_PRELOAD_LIBS="@SOCKSIFY_PRELOAD_LIBS@"
+-
+ LIBDIR="${LIBDIR:-@LIBRARY_PREFIX@}"
+
+ #dlib/Makefile.am libtool flags should produce a predictable library name
+@@ -65,7 +63,11 @@
+ @PRELOAD_VARIABLE@="${LIBRARY}${SOCKSIFY_PRELOAD_LIBS:+${PRELOAD_SEPERATOR}}${SOCKSIFY_PRELOAD_LIBS}${PRELOAD_POSTFIX:+${PRELOAD_SEPERATOR}}${PRELOAD_POSTFIX}"
+ export @PRELOAD_VARIABLE@
+
+-LD_LIBRARY_PATH="${LD_LIBRARY_PATH}${LD_LIBRARY_PATH:+:}${LIBDIR}"
+-export LD_LIBRARY_PATH
++# There is no reason to set LD_LIBRARY_PATH, at least on Linux, where
++# LD_PRELOAD can contain a full path to the library. Setting the
++# following breaks socksify on Linux/Alpha at least with
++# binutils-2.14.90.0.7-r3 (08 Dec 2003 agriffis)
++#LD_LIBRARY_PATH="${LD_LIBRARY_PATH}${LD_LIBRARY_PATH:+:}${LIBDIR}"
++#export LD_LIBRARY_PATH
+
+ exec "$@"