summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimo Gurr <tgurr@gentoo.org>2008-06-01 20:36:40 +0000
committerTimo Gurr <tgurr@gentoo.org>2008-06-01 20:36:40 +0000
commitd98d144519c64e42647fc7eecc624e7c461c7c61 (patch)
treea13a2c32daefab712b814ddf3d6c866707cce467 /net-print
parent... and ~x86 as well (bug #224479) (diff)
downloadgentoo-2-d98d144519c64e42647fc7eecc624e7c461c7c61.tar.gz
gentoo-2-d98d144519c64e42647fc7eecc624e7c461c7c61.tar.bz2
gentoo-2-d98d144519c64e42647fc7eecc624e7c461c7c61.zip
Version bump, fixing bug #224331. Thanks Chris Mayo for the diff.
(Portage version: 2.1.5.3)
Diffstat (limited to 'net-print')
-rw-r--r--net-print/cups-pdf/ChangeLog9
-rw-r--r--net-print/cups-pdf/cups-pdf-2.4.7.ebuild44
2 files changed, 51 insertions, 2 deletions
diff --git a/net-print/cups-pdf/ChangeLog b/net-print/cups-pdf/ChangeLog
index b0fca43962a7..6c445426f3bc 100644
--- a/net-print/cups-pdf/ChangeLog
+++ b/net-print/cups-pdf/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-print/cups-pdf
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/cups-pdf/ChangeLog,v 1.35 2007/06/09 00:09:44 genstef Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-print/cups-pdf/ChangeLog,v 1.36 2008/06/01 20:36:40 tgurr Exp $
+
+*cups-pdf-2.4.7 (01 Jun 2008)
+
+ 01 Jun 2008; Timo Gurr <tgurr@gentoo.org> +cups-pdf-2.4.7.ebuild:
+ Version bump, fixing bug #224331. Thanks Chris Mayo for the diff.
*cups-pdf-2.4.6 (09 Jun 2007)
diff --git a/net-print/cups-pdf/cups-pdf-2.4.7.ebuild b/net-print/cups-pdf/cups-pdf-2.4.7.ebuild
new file mode 100644
index 000000000000..8f16d128b594
--- /dev/null
+++ b/net-print/cups-pdf/cups-pdf-2.4.7.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-print/cups-pdf/cups-pdf-2.4.7.ebuild,v 1.1 2008/06/01 20:36:40 tgurr Exp $
+
+inherit toolchain-funcs multilib
+
+DESCRIPTION="Provides a virtual printer for CUPS to produce PDF files."
+HOMEPAGE="http://www.cups-pdf.de/"
+SRC_URI="http://www.cups-pdf.de/src/${PN}_${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="net-print/cups
+ virtual/ghostscript"
+
+src_compile() {
+ cd src
+ $(tc-getCC) ${CFLAGS} -o cups-pdf cups-pdf.c || die "Compilation failed."
+}
+
+src_install () {
+ exeinto $(cups-config --serverbin)/backend
+ has_version '>=net-print/cups-1.2' && exeopts -m0700
+ doexe src/cups-pdf
+
+ insinto /usr/share/cups/model
+ doins extra/CUPS-PDF.ppd
+
+ insinto /etc/cups
+ doins extra/cups-pdf.conf
+
+ dodoc ChangeLog README
+ newdoc contrib/Contents contrib_Contents
+}
+
+pkg_postinst () {
+ einfo "Please view both the README and contrib_Contents files"
+ einfo "as you may want to adjust some settings and/or use"
+ einfo "contributed software. In the latter case you may need"
+ einfo "to extract some files from the ${P} distfile."
+}