summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2009-09-14 19:11:21 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2009-09-14 19:11:21 +0000
commita0ec497091fa5f6b77af1cb1de3e45355519b018 (patch)
treebfbe35402519c4a26609c26f94e6c4d2e285acef /net-print
parentFix dependencies (bug #284670). (diff)
downloadgentoo-2-a0ec497091fa5f6b77af1cb1de3e45355519b018.tar.gz
gentoo-2-a0ec497091fa5f6b77af1cb1de3e45355519b018.tar.bz2
gentoo-2-a0ec497091fa5f6b77af1cb1de3e45355519b018.zip
[net-print/gutenprint] Version bump bug #276421
(Portage version: 2.2_rc40/cvs/Linux x86_64)
Diffstat (limited to 'net-print')
-rw-r--r--net-print/gutenprint/ChangeLog10
-rw-r--r--net-print/gutenprint/files/gutenprint-5.2.4-CFLAGS.patch24
-rw-r--r--net-print/gutenprint/gutenprint-5.2.4.ebuild96
3 files changed, 128 insertions, 2 deletions
diff --git a/net-print/gutenprint/ChangeLog b/net-print/gutenprint/ChangeLog
index 9e91fb809c52..2869871ff37c 100644
--- a/net-print/gutenprint/ChangeLog
+++ b/net-print/gutenprint/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-print/gutenprint
-# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/gutenprint/ChangeLog,v 1.5 2009/03/04 22:54:09 dirtyepic Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-print/gutenprint/ChangeLog,v 1.6 2009/09/14 19:11:21 alexxy Exp $
+
+*gutenprint-5.2.4 (14 Sep 2009)
+
+ 14 Sep 2009; Alexey Shvetsov <alexxy@gentoo.org> +gutenprint-5.2.4.ebuild,
+ +files/gutenprint-5.2.4-CFLAGS.patch:
+ Version bump bug #276421
*gutenprint-5.2.3 (04 Mar 2009)
diff --git a/net-print/gutenprint/files/gutenprint-5.2.4-CFLAGS.patch b/net-print/gutenprint/files/gutenprint-5.2.4-CFLAGS.patch
new file mode 100644
index 000000000000..e5d64e6042e0
--- /dev/null
+++ b/net-print/gutenprint/files/gutenprint-5.2.4-CFLAGS.patch
@@ -0,0 +1,24 @@
+diff -Naur gutenprint-5.2.3-orig/configure.ac gutenprint-5.2.3/configure.ac
+--- gutenprint-5.2.3-orig/configure.ac 2008-12-20 18:04:24.000000000 -0600
++++ gutenprint-5.2.3/configure.ac 2009-02-13 18:52:19.000000000 -0600
+@@ -631,20 +631,6 @@
+ if test x${USE_MAINTAINER_MODE} = xyes ; then
+ STP_ADD_COMPILER_ARGS([-pedantic -Waggregate-return -Wcast-qual -Wshadow -Wredundant-decls],, [GNUCFLAGS])
+ fi
+- if test x$ENABLE_DEBUG = xyes ; then
+- STP_ADD_COMPILER_ARG([-g])
+- else
+- STP_ADD_FIRST_COMPILER_ARG([-O6 -O3 -O2 -O1 -O])
+- fi
+-else
+- if test x$ENABLE_DEBUG = xyes ; then
+- STP_ADD_COMPILER_ARG([-g])
+- else
+- STP_ADD_FIRST_COMPILER_ARG([-O])
+- fi
+-fi
+-if test x$ENABLE_PROFILE = xyes ; then
+- STP_ADD_COMPILER_ARG([-pg])
+ fi
+ AC_SUBST(GNUCFLAGS)
+
diff --git a/net-print/gutenprint/gutenprint-5.2.4.ebuild b/net-print/gutenprint/gutenprint-5.2.4.ebuild
new file mode 100644
index 000000000000..8fc3eece7c65
--- /dev/null
+++ b/net-print/gutenprint/gutenprint-5.2.4.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-print/gutenprint/gutenprint-5.2.4.ebuild,v 1.1 2009/09/14 19:11:21 alexxy Exp $
+
+inherit autotools flag-o-matic eutils multilib
+
+IUSE="cups foomaticdb gimp gtk readline ppds"
+
+DESCRIPTION="Ghostscript and cups printer drivers"
+HOMEPAGE="http://gutenprint.sourceforge.net"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+SRC_URI="mirror://sourceforge/gimp-print/${P}.tar.bz2"
+RESTRICT="test"
+
+RDEPEND="cups? ( >=net-print/cups-1.1.14 )
+ virtual/ghostscript
+ sys-libs/readline
+ gtk? ( >=x11-libs/gtk+-2.0 )
+ gimp? ( >=media-gfx/gimp-2.2 >=x11-libs/gtk+-2.0 )
+ dev-lang/perl
+ foomaticdb? ( net-print/foomatic-db-engine )"
+DEPEND="${RDEPEND}
+ gtk? ( dev-util/pkgconfig )"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-CFLAGS.patch
+
+ # IJS Patch
+ sed -i -e "s:<ijs\([^/]\):<ijs/ijs\1:g" src/ghost/ijsgutenprint.c || die "sed failed"
+
+ mkdir m4local
+ AT_M4DIR="m4extra" eautoreconf
+}
+
+src_compile() {
+ if use cups && use ppds; then
+ myconf="${myconf} --enable-cups-ppds --enable-cups-level3-ppds"
+ else
+ myconf="${myconf} --disable-cups-ppds"
+ fi
+
+ if use gtk || use gimp; then
+ myconf="${myconf} --enable-libgutenprintui2"
+ else
+ myconf="${myconf} --disable-libgutenprintui2"
+ fi
+
+ use foomaticdb \
+ && myconf="${myconf} --with-foomatic3" \
+ || myconf="${myconf} --without-foomatic"
+
+ econf \
+ --enable-test \
+ --enable-epson \
+ --with-ghostscript \
+ --with-user-guide \
+ --with-samples \
+ --with-escputil \
+ --disable-translated-cups-ppds \
+ --enable-nls \
+ $(use_with readline) \
+ $(use_with gimp gimp2) \
+ $(use_with gimp gimp2-as-gutenprint) \
+ $(use_with cups) \
+ ${myconf} || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc AUTHORS ChangeLog NEWS README doc/gutenprint-users-manual.{pdf,odt}
+ dohtml doc/FAQ.html
+ dohtml -r doc/users_guide/html doc/developer/developer-html
+ rm -fR "${D}"/usr/share/gutenprint/doc
+ if ! use gtk && ! use gimp; then
+ rm -f "${D}"/usr/$(get_libdir)/pkgconfig/gutenprintui2.pc
+ rm -rf "${D}"/usr/include/gutenprintui2
+ fi
+}
+
+pkg_postinst() {
+ if [ "${ROOT}" == "/" ] && [ -x /usr/sbin/cups-genppdupdate ]; then
+ elog "Updating installed printer ppd files"
+ elog $(/usr/sbin/cups-genppdupdate)
+ else
+ elog "You need to update installed ppds manually using cups-genppdupdate"
+ fi
+}