summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimo Gurr <tgurr@gentoo.org>2008-02-22 18:13:58 +0000
committerTimo Gurr <tgurr@gentoo.org>2008-02-22 18:13:58 +0000
commit5aa4a278b96e51d2e1ca9ed39a6752194164b3c4 (patch)
treed8c1a6d595db3934098cc5bdc8257a17efff4784 /net-print
parentremove unuse net-im/ejabberd:sname use flag (diff)
downloadgentoo-2-5aa4a278b96e51d2e1ca9ed39a6752194164b3c4.tar.gz
gentoo-2-5aa4a278b96e51d2e1ca9ed39a6752194164b3c4.tar.bz2
gentoo-2-5aa4a278b96e51d2e1ca9ed39a6752194164b3c4.zip
Add cups-1.3.6.ebuild, version bump. Also remove bindnow to solve the portage QA warning. Clean up old ebuilds and fix some quoting.
(Portage version: 2.1.4.4)
Diffstat (limited to 'net-print')
-rw-r--r--net-print/cups/ChangeLog11
-rw-r--r--net-print/cups/cups-1.2.10-r1.ebuild36
-rw-r--r--net-print/cups/cups-1.2.12-r2.ebuild229
-rw-r--r--net-print/cups/cups-1.3.6.ebuild (renamed from net-print/cups/cups-1.2.12-r3.ebuild)197
4 files changed, 148 insertions, 325 deletions
diff --git a/net-print/cups/ChangeLog b/net-print/cups/ChangeLog
index 02db9cf052aa..0f1d73b7720c 100644
--- a/net-print/cups/ChangeLog
+++ b/net-print/cups/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-print/cups
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/cups/ChangeLog,v 1.280 2007/12/26 16:55:59 cardoe Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-print/cups/ChangeLog,v 1.281 2008/02/22 18:13:58 tgurr Exp $
+
+*cups-1.3.6 (22 Feb 2008)
+
+ 22 Feb 2008; Timo Gurr <tgurr@gentoo.org> cups-1.2.10-r1.ebuild,
+ -cups-1.2.12-r2.ebuild, -cups-1.2.12-r3.ebuild, +cups-1.3.6.ebuild:
+ Add cups-1.3.6.ebuild, version bump. Also remove bindnow to solve the
+ portage QA warning. Clean up old ebuilds and fix some quoting.
26 Dec 2007; Doug Klima <cardoe@gentoo.org> cups-1.2.12-r2.ebuild,
cups-1.2.12-r3.ebuild, cups-1.2.12-r4.ebuild, cups-1.3.5.ebuild:
diff --git a/net-print/cups/cups-1.2.10-r1.ebuild b/net-print/cups/cups-1.2.10-r1.ebuild
index a49b8c1e7565..1a26e80e402f 100644
--- a/net-print/cups/cups-1.2.10-r1.ebuild
+++ b/net-print/cups/cups-1.2.10-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/cups/cups-1.2.10-r1.ebuild,v 1.12 2007/08/07 11:59:35 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/cups/cups-1.2.10-r1.ebuild,v 1.13 2008/02/22 18:13:58 tgurr Exp $
WANT_AUTOMAKE=latest
@@ -60,7 +60,7 @@ PROVIDE="virtual/lpr"
# we just leave it out, even if FEATURES=test
RESTRICT="test"
-S=${WORKDIR}/${MY_P}
+S="${WORKDIR}/${MY_P}"
pkg_setup() {
enewgroup lp
@@ -71,10 +71,10 @@ pkg_setup() {
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
# upstream does not acknowledge bindnow as a solution
- epatch ${FILESDIR}/cups-1.2.0-bindnow.patch
+ epatch "${FILESDIR}"/cups-1.2.0-bindnow.patch
# cups does not use autotools "the usual way" and ship a static config.h.in
eaclocal
@@ -117,29 +117,29 @@ src_compile() {
}
src_install() {
- emake BUILDROOT=${D} install || die "emake install failed"
+ emake BUILDROOT="${D}" install || die "emake install failed"
dodoc {CHANGES{,-1.{0,1}},CREDITS,LICENSE,README}.txt
# clean out cups init scripts
- rm -rf ${D}/etc/{init.d/cups,rc*,pam.d/cups}
+ rm -rf "${D}"/etc/{init.d/cups,rc*,pam.d/cups}
# install our init scripts
- newinitd ${FILESDIR}/cupsd.init cupsd
+ newinitd "${FILESDIR}"/cupsd.init cupsd
# install our pam script
pamd_mimic_system cups auth account
# correct path
- sed -i -e "s:server = .*:server = /usr/libexec/cups/daemon/cups-lpd:" ${D}/etc/xinetd.d/cups-lpd
+ sed -i -e "s:server = .*:server = /usr/libexec/cups/daemon/cups-lpd:" "${D}"/etc/xinetd.d/cups-lpd
# it is safer to disable this by default, bug 137130
- grep -w 'disable' ${D}/etc/xinetd.d/cups-lpd || \
- sed -i -e "s:}:\tdisable = yes\n}:" ${D}/etc/xinetd.d/cups-lpd
+ grep -w 'disable' "${D}"/etc/xinetd.d/cups-lpd || \
+ sed -i -e "s:}:\tdisable = yes\n}:" "${D}"/etc/xinetd.d/cups-lpd
# install pdftops filter
exeinto /usr/libexec/cups/filter/
- newexe ${FILESDIR}/pdftops.pl pdftops
+ newexe "${FILESDIR}"/pdftops.pl pdftops
# only for gs-esp this is correct, see bug 163897
if has_version app-text/ghostscript-gpl || has_version app-text/ghostscript-gnu; then
- sed -i -e "s:#application/vnd.cups-postscript:application/vnd.cups-postscript:" ${D}/etc/cups/mime.convs
+ sed -i -e "s:#application/vnd.cups-postscript:application/vnd.cups-postscript:" "${D}"/etc/cups/mime.convs
fi
keepdir /usr/share/cups/profiles /usr/libexec/cups/driver /var/log/cups \
@@ -147,9 +147,9 @@ src_install() {
# .desktop handling. X useflag. xdg-open from freedesktop is preferred
if use X; then
- sed -i -e "s:htmlview:xdg-open:" ${D}/usr/share/applications/cups.desktop
+ sed -i -e "s:htmlview:xdg-open:" "${D}"/usr/share/applications/cups.desktop
else
- rm -r ${D}/usr/share/applications
+ rm -r "${D}"/usr/share/applications
fi
# Fix a symlink collision, see bug #172341
@@ -159,7 +159,7 @@ src_install() {
pkg_preinst() {
# cleanups
- [ -n "${PN}" ] && rm -fR ${ROOT}/usr/share/doc/${PN}-*
+ [ -n "${PN}" ] && rm -fR "${ROOT}"/usr/share/doc/"${PN}"-*
}
pkg_postinst() {
@@ -191,7 +191,7 @@ pkg_postinst() {
ewarn
ewarn "You need to rebuild kdelibs for kdeprinter to work with cups-1.2"
fi
- if [ -e ${ROOT}/usr/lib/cups ]; then
+ if [ -e "${ROOT}"/usr/lib/cups ]; then
ewarn
ewarn "/usr/lib/cups exists - You need to remerge every ebuild that"
ewarn "installed into /usr/lib/cups and /etc/cups, qfile is in portage-utils:"
@@ -202,7 +202,7 @@ pkg_postinst() {
ewarn "You should also run revdep-rebuild"
# place symlinks to make the update smoothless
- for i in ${ROOT}/usr/lib/cups/{backend,filter}/*; do
+ for i in "${ROOT}"/usr/lib/cups/{backend,filter}/*; do
if [ "${i/\*}" == "${i}" ] && ! [ -e ${i/lib/libexec} ]; then
ln -s ${i} ${i/lib/libexec}
fi
diff --git a/net-print/cups/cups-1.2.12-r2.ebuild b/net-print/cups/cups-1.2.12-r2.ebuild
deleted file mode 100644
index 496c70828150..000000000000
--- a/net-print/cups/cups-1.2.12-r2.ebuild
+++ /dev/null
@@ -1,229 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/cups/cups-1.2.12-r2.ebuild,v 1.11 2008/01/10 09:04:24 vapier Exp $
-
-WANT_AUTOMAKE=latest
-
-inherit autotools eutils flag-o-matic multilib pam
-
-MY_P=${P/_}
-
-DESCRIPTION="The Common Unix Printing System"
-HOMEPAGE="http://www.cups.org/"
-SRC_URI="mirror://sourceforge/cups/${MY_P}-source.tar.bz2"
-#http://ftp.funet.fi/pub/mirrors/ftp.easysw.com/pub/cups/${PV}/${MY_P}-source.tar.bz2"
-#ESVN_REPO_URI="http://svn.easysw.com/public/cups/trunk"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh sparc ~sparc-fbsd x86 ~x86-fbsd"
-IUSE="ldap ssl slp pam php samba nls dbus tiff png ppds jpeg X"
-
-DEP="pam? ( virtual/pam )
- ssl? ( net-libs/gnutls )
- slp? ( >=net-libs/openslp-1.0.4 )
- ldap? ( net-nds/openldap )
- dbus? ( sys-apps/dbus )
- png? ( >=media-libs/libpng-1.2.1 )
- tiff? ( >=media-libs/tiff-3.5.5 )
- jpeg? ( >=media-libs/jpeg-6b )
- php? ( dev-lang/php )
- app-text/libpaper"
-DEPEND="${DEP}
- !<net-print/foomatic-filters-ppds-20070501
- !<net-print/hplip-1.7.4a-r1
- nls? ( sys-devel/gettext )"
-RDEPEND="${DEP}
- nls? ( virtual/libintl )
- !virtual/lpr
- >=app-text/poppler-0.4.3-r1
- X? ( x11-misc/xdg-utils )"
-
-PDEPEND="
- ppds? ( || (
- (
- net-print/foomatic-filters-ppds
- net-print/foomatic-db-ppds
- )
- net-print/foomatic-filters-ppds
- net-print/foomatic-db-ppds
- net-print/hplip
- media-gfx/gimp-print
- net-print/foo2zjs
- net-print/cups-pdf
- ) )
- samba? ( >=net-fs/samba-3.0.8 )
- virtual/ghostscript"
-PROVIDE="virtual/lpr"
-
-# upstream includes an interactive test which is a nono for gentoo.
-# therefore, since the printing herd has bigger fish to fry, for now,
-# we just leave it out, even if FEATURES=test
-RESTRICT="test"
-
-S=${WORKDIR}/${MY_P}
-
-pkg_setup() {
- if use x86 && [ -d "/usr/lib64" ]
- then
- eerror "You are running an x86 system, but /usr/lib64 exists, cups will install all library objects into this directory!"
- eerror "You should remove /usr/lib64, but before you do, you should check for existing objects, and re-compile all affected packages."
- eerror "You can use qfile (emerge portage-utils to install qfile) to get a list of the affected ebuilds:"
- eerror "# qfile -qC /usr/lib64"
- die "lib64 on x86 detected"
- fi
-
- enewgroup lp
- enewuser lp -1 -1 -1 lp
-
- enewgroup lpadmin 106
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- # upstream does not acknowledge bindnow as a solution
- epatch "${FILESDIR}"/cups-1.2.0-bindnow.patch
-
- # CVE-2007-4351 security patch, bug #196736
- epatch "${FILESDIR}"/${PN}-1.2-str2561-v2.patch
-
- # cups does not use autotools "the usual way" and ship a static config.h.in
- eaclocal
- eautoconf
-}
-
-src_compile() {
- export DSOFLAGS="${LDFLAGS}"
-
- if use ldap; then
- append-flags -DLDAP_DEPRECATED
- fi
-
- econf \
- --with-cups-user=lp \
- --with-cups-group=lp \
- --with-system-groups=lpadmin \
- --localstatedir=/var \
- --with-docdir=/usr/share/cups/html \
- --with-bindnow=$(bindnow-flags) \
- $(use_enable pam) \
- $(use_enable ssl) \
- --enable-gnutls \
- $(use_enable slp) \
- $(use_enable nls) \
- $(use_enable dbus) \
- $(use_enable png) \
- $(use_enable jpeg) \
- $(use_enable tiff) \
- $(use_with php) \
- $(use_enable ldap) \
- --enable-libpaper \
- --enable-threads \
- --enable-static \
- --disable-pdftops \
- || die "econf failed"
-
- # Install in /usr/libexec always, instead of using /usr/lib/cups, as that
- # makes more sense when facing multilib support.
- sed -i -e 's:SERVERBIN.*:SERVERBIN = $(BUILDROOT)/usr/libexec/cups:' Makedefs
- sed -i -e 's:#define CUPS_SERVERBIN.*:#define CUPS_SERVERBIN "/usr/libexec/cups":' config.h
- sed -i -e 's:cups_serverbin=.*:cups_serverbin=/usr/libexec/cups:' cups-config
-
- emake || die "emake failed"
-}
-
-src_install() {
- emake BUILDROOT="${D}" install || die "emake install failed"
- dodoc {CHANGES{,-1.{0,1}},CREDITS,LICENSE,README}.txt
-
- # clean out cups init scripts
- rm -rf "${D}"/etc/{init.d/cups,rc*,pam.d/cups}
- # install our init scripts
- newinitd "${FILESDIR}"/cupsd.init cupsd
- # install our pam script
- pamd_mimic_system cups auth account
-
- # correct path
- sed -i -e "s:server = .*:server = /usr/libexec/cups/daemon/cups-lpd:" "${D}"/etc/xinetd.d/cups-lpd
- # it is safer to disable this by default, bug 137130
- grep -w 'disable' "${D}"/etc/xinetd.d/cups-lpd || \
- sed -i -e "s:}:\tdisable = yes\n}:" "${D}"/etc/xinetd.d/cups-lpd
-
- # install pdftops filter
- exeinto /usr/libexec/cups/filter/
- newexe "${FILESDIR}"/pdftops.pl pdftops
-
- # only for gs-esp this is correct, see bug 163897
- if has_version app-text/ghostscript-gpl || has_version app-text/ghostscript-gnu; then
- sed -i -e "s:#application/vnd.cups-postscript:application/vnd.cups-postscript:" "${D}"/etc/cups/mime.convs
- fi
-
- keepdir /usr/share/cups/profiles /usr/libexec/cups/driver /var/log/cups \
- /var/run/cups/certs /var/cache/cups /var/spool/cups/tmp /etc/cups/ssl
-
- # .desktop handling. X useflag. xdg-open from freedesktop is preferred
- if use X; then
- sed -i -e "s:htmlview:xdg-open:" "${D}"/usr/share/applications/cups.desktop
- else
- rm -r "${D}"/usr/share/applications
- fi
-
- # Fix a symlink collision, see bug #172341
- dodir /usr/share/ppd
- dosym /usr/share/ppd /usr/share/cups/model/foomatic-ppds
-}
-
-pkg_preinst() {
- # cleanups
- [ -n "${PN}" ] && rm -fR "${ROOT}"/usr/share/doc/${PN}-*
-}
-
-pkg_postinst() {
- einfo "Remote printing: change "
- einfo "Listen localhost:631"
- einfo "to"
- einfo "Listen *:631"
- einfo "in /etc/cups/cupsd.conf"
- einfo
- einfo "For more information about installing a printer take a look at:"
- einfo "http://www.gentoo.org/doc/en/printing-howto.xml."
-
- local good_gs=false
- for x in app-text/ghostscript-gpl app-text/ghostscript-gnu app-text/ghostscript-esp; do
- if has_version ${x} && built_with_use ${x} cups; then
- good_gs=true
- break
- fi
- done;
- if ! ${good_gs}; then
- ewarn
- ewarn "You need to emerge ghostscript with the \"cups\" USE flag turned on"
- fi
- if has_version =net-print/cups-1.1*; then
- ewarn
- ewarn "The configuration changed with cups-1.2, you may want to save the old"
- ewarn "one and start from scratch:"
- ewarn "# mv /etc/cups /etc/cups.orig; emerge -va1 cups"
- ewarn
- ewarn "You need to rebuild kdelibs for kdeprinter to work with cups-1.2"
- fi
- if [ -e "${ROOT}"/usr/lib/cups ]; then
- ewarn
- ewarn "/usr/lib/cups exists - You need to remerge every ebuild that"
- ewarn "installed into /usr/lib/cups and /etc/cups, qfile is in portage-utils:"
- ewarn "# FEATURES=-collision-protect emerge -va1 \$(qfile -qC /usr/lib/cups /etc/cups | sed \"s:net-print/cups$::\")"
- ewarn
- ewarn "FEATURES=-collision-protect is needed to overwrite the compatibility"
- ewarn "symlinks installed by this package, it wont be needed on later merges."
- ewarn "You should also run revdep-rebuild"
-
- # place symlinks to make the update smoothless
- for i in "${ROOT}"/usr/lib/cups/{backend,filter}/*; do
- if [ "${i/\*}" == "${i}" ] && ! [ -e ${i/lib/libexec} ]; then
- ln -s ${i} ${i/lib/libexec}
- fi
- done
- fi
-}
diff --git a/net-print/cups/cups-1.2.12-r3.ebuild b/net-print/cups/cups-1.3.6.ebuild
index f9a69ced16ff..ce8da7d51c5d 100644
--- a/net-print/cups/cups-1.2.12-r3.ebuild
+++ b/net-print/cups/cups-1.3.6.ebuild
@@ -1,8 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/cups/cups-1.2.12-r3.ebuild,v 1.10 2008/01/10 09:04:24 vapier Exp $
-
-WANT_AUTOMAKE=latest
+# $Header: /var/cvsroot/gentoo-x86/net-print/cups/cups-1.3.6.ebuild,v 1.1 2008/02/22 18:13:58 tgurr Exp $
inherit autotools eutils flag-o-matic multilib pam
@@ -11,33 +9,41 @@ MY_P=${P/_}
DESCRIPTION="The Common Unix Printing System"
HOMEPAGE="http://www.cups.org/"
SRC_URI="mirror://sourceforge/cups/${MY_P}-source.tar.bz2"
-#http://ftp.funet.fi/pub/mirrors/ftp.easysw.com/pub/cups/${PV}/${MY_P}-source.tar.bz2"
-#ESVN_REPO_URI="http://svn.easysw.com/public/cups/trunk"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc ~sparc-fbsd x86 ~x86-fbsd"
-IUSE="ldap ssl slp pam php samba nls dbus tiff png ppds jpeg X"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="acl avahi dbus java jpeg kerberos ldap nls pam perl php png ppds python samba slp ssl static tiff X zeroconf"
-DEP="pam? ( virtual/pam )
- ssl? ( net-libs/gnutls )
- slp? ( >=net-libs/openslp-1.0.4 )
- ldap? ( net-nds/openldap )
+COMMON_DEPEND="acl? ( kernel_linux? ( sys-apps/acl sys-apps/attr ) )
+ avahi? ( net-dns/avahi )
dbus? ( sys-apps/dbus )
- png? ( >=media-libs/libpng-1.2.1 )
- tiff? ( >=media-libs/tiff-3.5.5 )
+ java? ( >=virtual/jre-1.4 )
jpeg? ( >=media-libs/jpeg-6b )
+ kerberos? ( virtual/krb5 )
+ ldap? ( net-nds/openldap )
+ pam? ( virtual/pam )
+ perl? ( dev-lang/perl )
php? ( dev-lang/php )
- app-text/libpaper"
-DEPEND="${DEP}
+ png? ( >=media-libs/libpng-1.2.1 )
+ python? ( dev-lang/python )
+ slp? ( >=net-libs/openslp-1.0.4 )
+ ssl? ( net-libs/gnutls )
+ tiff? ( >=media-libs/tiff-3.5.5 )
+ zeroconf? ( !avahi? ( net-misc/mDNSResponder ) )
+ app-text/libpaper
+ dev-libs/libgcrypt"
+
+DEPEND="${COMMON_DEPEND}
!<net-print/foomatic-filters-ppds-20070501
!<net-print/hplip-1.7.4a-r1
nls? ( sys-devel/gettext )"
-RDEPEND="${DEP}
- nls? ( virtual/libintl )
+
+RDEPEND="${COMMON_DEPEND}
!virtual/lpr
- >=app-text/poppler-0.4.3-r1
- X? ( x11-misc/xdg-utils )"
+ nls? ( virtual/libintl )
+ X? ( x11-misc/xdg-utils )
+ >=app-text/poppler-0.4.3-r1"
PDEPEND="
ppds? ( || (
@@ -54,6 +60,7 @@ PDEPEND="
) )
samba? ( >=net-fs/samba-3.0.8 )
virtual/ghostscript"
+
PROVIDE="virtual/lpr"
# upstream includes an interactive test which is a nono for gentoo.
@@ -61,16 +68,20 @@ PROVIDE="virtual/lpr"
# we just leave it out, even if FEATURES=test
RESTRICT="test"
-S=${WORKDIR}/${MY_P}
+S="${WORKDIR}/${MY_P}"
+
+LANGS="de en es et fr he it ja pl sv zh_TW"
+for X in ${LANGS} ; do
+ IUSE="${IUSE} linguas_${X}"
+done
pkg_setup() {
- if use x86 && [ -d "/usr/lib64" ]
- then
- eerror "You are running an x86 system, but /usr/lib64 exists, cups will install all library objects into this directory!"
- eerror "You should remove /usr/lib64, but before you do, you should check for existing objects, and re-compile all affected packages."
- eerror "You can use qfile (emerge portage-utils to install qfile) to get a list of the affected ebuilds:"
- eerror "# qfile -qC /usr/lib64"
- die "lib64 on x86 detected"
+ if use avahi && ! built_with_use net-dns/avahi mdnsresponder-compat ; then
+ echo
+ eerror "In order to have cups working with avahi zeroconf support, you need"
+ eerror "to have net-dns/avahi emerged with 'mdnsresponder-compat' in your USE"
+ eerror "flag. Please add that flag, re-emerge avahi, and then emerge cups again."
+ die "net-dns/avahi is missing the mdnsresponder-compat feature."
fi
enewgroup lp
@@ -83,13 +94,11 @@ src_unpack() {
unpack ${A}
cd "${S}"
- # upstream does not acknowledge bindnow as a solution
- epatch "${FILESDIR}"/cups-1.2.0-bindnow.patch
+ # disable configure automagic for acl/attr
+ epatch "${FILESDIR}/${PN}-1.3.0-configure.patch"
- # CVE-2007-4351 security patch, bug #196736
- epatch "${FILESDIR}"/${PN}-1.2-str2561-v2.patch
# CVE-2007-4045 security patch, bug #199195
- epatch "${FILESDIR}"/${PN}-1.2.4-CVE-2007-4045.patch
+ epatch "${FILESDIR}/${PN}-1.3.4-CVE-2007-4045.patch"
# cups does not use autotools "the usual way" and ship a static config.h.in
eaclocal
@@ -97,39 +106,62 @@ src_unpack() {
}
src_compile() {
+
+ # locale support
+ strip-linguas ${LANGS}
+
+ if [ -z "${LINGUAS}" ] ; then
+ export LINGUAS=all
+ fi
+
export DSOFLAGS="${LDFLAGS}"
- if use ldap; then
+ if use ldap ; then
append-flags -DLDAP_DEPRECATED
fi
+ local myconf
+
+ if use avahi || use zeroconf ; then
+ myconf="${myconf} --enable-dnssd"
+ else
+ myconf="${myconf} --disable-dnssd"
+ fi
+
econf \
+ --libdir=/usr/$(get_libdir) \
+ --localstatedir=/var \
--with-cups-user=lp \
--with-cups-group=lp \
- --with-system-groups=lpadmin \
- --localstatedir=/var \
--with-docdir=/usr/share/cups/html \
- --with-bindnow=$(bindnow-flags) \
- $(use_enable pam) \
- $(use_enable ssl) \
- --enable-gnutls \
- $(use_enable slp) \
- $(use_enable nls) \
+ --with-languages=${LINGUAS} \
+ --with-system-groups=lpadmin \
+ $(use_enable acl) \
$(use_enable dbus) \
- $(use_enable png) \
$(use_enable jpeg) \
+ $(use_enable kerberos gssapi) \
+ $(use_enable ldap) \
+ $(use_enable nls) \
+ $(use_enable pam) \
+ $(use_enable png) \
+ $(use_enable slp) \
+ $(use_enable ssl) \
+ $(use_enable static) \
$(use_enable tiff) \
+ $(use_with java) \
+ $(use_with perl) \
$(use_with php) \
- $(use_enable ldap) \
+ $(use_with python) \
+ --enable-gnutls \
--enable-libpaper \
--enable-threads \
- --enable-static \
--disable-pdftops \
+ ${myconf} \
|| die "econf failed"
- # Install in /usr/libexec always, instead of using /usr/lib/cups, as that
+ # install in /usr/libexec always, instead of using /usr/lib/cups, as that
# makes more sense when facing multilib support.
- sed -i -e 's:SERVERBIN.*:SERVERBIN = $(BUILDROOT)/usr/libexec/cups:' Makedefs
+ sed -i -e 's:SERVERBIN.*:SERVERBIN = "$(BUILDROOT)"/usr/libexec/cups:' Makedefs
sed -i -e 's:#define CUPS_SERVERBIN.*:#define CUPS_SERVERBIN "/usr/libexec/cups":' config.h
sed -i -e 's:cups_serverbin=.*:cups_serverbin=/usr/libexec/cups:' cups-config
@@ -138,12 +170,20 @@ src_compile() {
src_install() {
emake BUILDROOT="${D}" install || die "emake install failed"
- dodoc {CHANGES{,-1.{0,1}},CREDITS,LICENSE,README}.txt
+ dodoc {CHANGES{,-1.{0,1}},CREDITS,README}.txt || die "dodoc install failed"
# clean out cups init scripts
rm -rf "${D}"/etc/{init.d/cups,rc*,pam.d/cups}
- # install our init scripts
- newinitd "${FILESDIR}"/cupsd.init cupsd
+
+ # install our init script
+ local neededservices
+ use avahi && neededservices="$neededservices avahi-daemon"
+ use dbus && neededservices="$neededservices dbus"
+ use zeroconf && ! use avahi && neededservices="$neededservices mDNSResponderPosix"
+ [[ -n ${neededservices} ]] && neededservices="need${neededservices}"
+ sed -e "s/@neededservices@/$neededservices/" "${FILESDIR}"/cupsd.init.d > "${T}"/cupsd
+ doinitd "${T}"/cupsd
+
# install our pam script
pamd_mimic_system cups auth account
@@ -155,10 +195,10 @@ src_install() {
# install pdftops filter
exeinto /usr/libexec/cups/filter/
- newexe "${FILESDIR}"/pdftops.pl pdftops
+ newexe "${FILESDIR}"/pdftops-1.20.gentoo pdftops
# only for gs-esp this is correct, see bug 163897
- if has_version app-text/ghostscript-gpl || has_version app-text/ghostscript-gnu; then
+ if has_version app-text/ghostscript-gpl || has_version app-text/ghostscript-gnu ; then
sed -i -e "s:#application/vnd.cups-postscript:application/vnd.cups-postscript:" "${D}"/etc/cups/mime.convs
fi
@@ -166,64 +206,69 @@ src_install() {
/var/run/cups/certs /var/cache/cups /var/spool/cups/tmp /etc/cups/ssl
# .desktop handling. X useflag. xdg-open from freedesktop is preferred
- if use X; then
+ if use X ; then
sed -i -e "s:htmlview:xdg-open:" "${D}"/usr/share/applications/cups.desktop
else
rm -r "${D}"/usr/share/applications
fi
- # Fix a symlink collision, see bug #172341
+ # fix a symlink collision, see bug #172341
dodir /usr/share/ppd
dosym /usr/share/ppd /usr/share/cups/model/foomatic-ppds
+
+ # create RSS feed directory
+ diropts -m 0740 -o lp -g lp
+ dodir /var/cache/cups/rss
}
pkg_preinst() {
# cleanups
- [ -n "${PN}" ] && rm -fR "${ROOT}"/usr/share/doc/${PN}-*
+ [ -n "${PN}" ] && rm -fR "${ROOT}"/usr/share/doc/"${PN}"-*
}
pkg_postinst() {
- einfo "Remote printing: change "
- einfo "Listen localhost:631"
- einfo "to"
- einfo "Listen *:631"
- einfo "in /etc/cups/cupsd.conf"
- einfo
- einfo "For more information about installing a printer take a look at:"
- einfo "http://www.gentoo.org/doc/en/printing-howto.xml."
+ echo
+ elog "For information about installing a printer and general cups setup"
+ elog "take a look at: http://www.gentoo.org/doc/en/printing-howto.xml"
+ echo
local good_gs=false
- for x in app-text/ghostscript-gpl app-text/ghostscript-gnu app-text/ghostscript-esp; do
- if has_version ${x} && built_with_use ${x} cups; then
+ for x in app-text/ghostscript-gpl app-text/ghostscript-gnu app-text/ghostscript-esp ; do
+ if has_version ${x} && built_with_use ${x} cups ; then
good_gs=true
break
fi
done;
if ! ${good_gs}; then
- ewarn
+ echo
ewarn "You need to emerge ghostscript with the \"cups\" USE flag turned on"
+ echo
fi
- if has_version =net-print/cups-1.1*; then
- ewarn
- ewarn "The configuration changed with cups-1.2, you may want to save the old"
+
+ if has_version =net-print/cups-1.1* ; then
+ echo
+ ewarn "The configuration changed with cups-1.3, you may want to save the old"
ewarn "one and start from scratch:"
ewarn "# mv /etc/cups /etc/cups.orig; emerge -va1 cups"
- ewarn
- ewarn "You need to rebuild kdelibs for kdeprinter to work with cups-1.2"
+ echo
+ ewarn "You need to rebuild kdelibs for kdeprinter to work with cups-1.3"
+ echo
fi
- if [ -e "${ROOT}"/usr/lib/cups ]; then
- ewarn
+
+ if [ -e "${ROOT}"/usr/lib/cups ] ; then
+ echo
ewarn "/usr/lib/cups exists - You need to remerge every ebuild that"
ewarn "installed into /usr/lib/cups and /etc/cups, qfile is in portage-utils:"
ewarn "# FEATURES=-collision-protect emerge -va1 \$(qfile -qC /usr/lib/cups /etc/cups | sed \"s:net-print/cups$::\")"
- ewarn
+ echo
ewarn "FEATURES=-collision-protect is needed to overwrite the compatibility"
- ewarn "symlinks installed by this package, it wont be needed on later merges."
+ ewarn "symlinks installed by this package, it won't be needed on later merges."
ewarn "You should also run revdep-rebuild"
+ echo
# place symlinks to make the update smoothless
- for i in "${ROOT}"/usr/lib/cups/{backend,filter}/*; do
- if [ "${i/\*}" == "${i}" ] && ! [ -e ${i/lib/libexec} ]; then
+ for i in "${ROOT}"/usr/lib/cups/{backend,filter}/* ; do
+ if [ "${i/\*}" == "${i}" ] && ! [ -e ${i/lib/libexec} ] ; then
ln -s ${i} ${i/lib/libexec}
fi
done