summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Gryniewicz <dang@gentoo.org>2009-04-25 15:02:07 +0000
committerDaniel Gryniewicz <dang@gentoo.org>2009-04-25 15:02:07 +0000
commit83171748e60ab05a4fd6978f03d8b59dbacbf0a5 (patch)
tree4e68e09fad68d81b2b427296da93121bc2e09fe9 /net-print/gnome-cups-manager
parentFix bug #267349 by Daniel Gryniewicz, NetworkManager-0.7 links against (diff)
downloadgentoo-2-83171748e60ab05a4fd6978f03d8b59dbacbf0a5.tar.gz
gentoo-2-83171748e60ab05a4fd6978f03d8b59dbacbf0a5.tar.bz2
gentoo-2-83171748e60ab05a4fd6978f03d8b59dbacbf0a5.zip
Bump to gnome-cups-manager-0.33-r1
- Fix overflow introduced in one of the patches. Bug #259045 (Portage version: 2.2_rc31/cvs/Linux x86_64)
Diffstat (limited to 'net-print/gnome-cups-manager')
-rw-r--r--net-print/gnome-cups-manager/ChangeLog10
-rw-r--r--net-print/gnome-cups-manager/gnome-cups-manager-0.33-r1.ebuild51
2 files changed, 60 insertions, 1 deletions
diff --git a/net-print/gnome-cups-manager/ChangeLog b/net-print/gnome-cups-manager/ChangeLog
index a844be6f3089..fb6aeb332149 100644
--- a/net-print/gnome-cups-manager/ChangeLog
+++ b/net-print/gnome-cups-manager/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-print/gnome-cups-manager
# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/gnome-cups-manager/ChangeLog,v 1.84 2009/04/14 11:54:15 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/gnome-cups-manager/ChangeLog,v 1.85 2009/04/25 15:02:07 dang Exp $
+
+*gnome-cups-manager-0.33-r1 (25 Apr 2009)
+
+ 25 Apr 2009; Daniel Gryniewicz <dang@gentoo.org>
+ +gnome-cups-manager-0.33-r1.ebuild:
+ Bump to gnome-cups-manager-0.33-r1
+
+ - Fix overflow introduced in one of the patches. Bug #259045
14 Apr 2009; Raúl Porcel <armin76@gentoo.org>
gnome-cups-manager-0.33.ebuild:
diff --git a/net-print/gnome-cups-manager/gnome-cups-manager-0.33-r1.ebuild b/net-print/gnome-cups-manager/gnome-cups-manager-0.33-r1.ebuild
new file mode 100644
index 000000000000..73b99850dca7
--- /dev/null
+++ b/net-print/gnome-cups-manager/gnome-cups-manager-0.33-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-print/gnome-cups-manager/gnome-cups-manager-0.33-r1.ebuild,v 1.1 2009/04/25 15:02:07 dang Exp $
+
+inherit eutils gnome2 flag-o-matic
+
+DESCRIPTION="GNOME CUPS Printer Management Interface"
+HOMEPAGE="http://www.gnome.org/"
+
+SRC_URI="${SRC_URI}
+ mirror://gentoo/${PN}-patches-${PVR}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+COMMON=">=x11-libs/gtk+-2.3.1
+ >=dev-libs/glib-2.3.1
+ >=gnome-base/libgnome-2
+ >=gnome-base/libgnomeui-2.2
+ >=gnome-base/libglade-2
+ >=gnome-base/libbonobo-2
+ >=net-print/libgnomecups-0.2.3
+ gnome-base/gnome-keyring"
+
+RDEPEND="${COMMON}
+ x11-libs/gksu"
+
+DEPEND="${COMMON}
+ >=dev-util/pkgconfig-0.9
+ >=dev-util/intltool-0.28"
+
+DOCS="ChangeLog NEWS README"
+
+src_unpack() {
+ gnome2_src_unpack
+
+ rm "${WORKDIR}"/patches/140_all_ui_tooltip.patch || \
+ die "removing patch failed"
+
+ export EPATCH_SOURCE="${WORKDIR}/patches" \
+ EPATCH_SUFFIX="patch" \
+ EPATCH_MULTI_MSG="Applying Ubuntu patches (enhancements) ..."
+ epatch
+}
+
+src_install() {
+ gnome2_src_install
+ #Debian-specific.
+ rm "${D}"/usr/sbin/gnome-cups-switch
+}