summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Stakenvicius <axs@gentoo.org>2013-12-18 16:12:07 +0000
committerIan Stakenvicius <axs@gentoo.org>2013-12-18 16:12:07 +0000
commitc7cda4646028efa4d24943ae039eda8b279a2878 (patch)
treed56100ea8e9fee2881925734c61250e6f5705d1b /net-print/foo2zjs
parentInstall GeoIP.dat in data/ for src_test() (bug #494650 by eroen). (diff)
downloadgentoo-2-c7cda4646028efa4d24943ae039eda8b279a2878.tar.gz
gentoo-2-c7cda4646028efa4d24943ae039eda8b279a2878.tar.bz2
gentoo-2-c7cda4646028efa4d24943ae039eda8b279a2878.zip
fix access violations, bug 420623
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 2B6559ED)
Diffstat (limited to 'net-print/foo2zjs')
-rw-r--r--net-print/foo2zjs/ChangeLog6
-rw-r--r--net-print/foo2zjs/foo2zjs-99999999.ebuild7
2 files changed, 10 insertions, 3 deletions
diff --git a/net-print/foo2zjs/ChangeLog b/net-print/foo2zjs/ChangeLog
index f2fb759d7d98..49260a30e749 100644
--- a/net-print/foo2zjs/ChangeLog
+++ b/net-print/foo2zjs/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-print/foo2zjs
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/foo2zjs/ChangeLog,v 1.50 2013/03/24 19:50:36 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/foo2zjs/ChangeLog,v 1.51 2013/12/18 16:12:07 axs Exp $
+
+ 18 Dec 2013; Ian Stakenvicius <axs@gentoo.org> foo2zjs-99999999.ebuild:
+ fix access violations, bug 420623
24 Mar 2013; Andreas K. Huettel <dilfridge@gentoo.org>
+files/foo2zjs-usbbackend.patch, foo2zjs-99999999.ebuild:
@@ -279,4 +282,3 @@
+foo2zjs-20041030.ebuild:
Adding foo2zjs, thanks to Robert Führicht <the_master_of_disaster@gmx.at> in
bug 65156
-
diff --git a/net-print/foo2zjs/foo2zjs-99999999.ebuild b/net-print/foo2zjs/foo2zjs-99999999.ebuild
index 7b021eba6209..90d6b63fa8d1 100644
--- a/net-print/foo2zjs/foo2zjs-99999999.ebuild
+++ b/net-print/foo2zjs/foo2zjs-99999999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/foo2zjs/foo2zjs-99999999.ebuild,v 1.10 2013/03/24 19:50:36 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/foo2zjs/foo2zjs-99999999.ebuild,v 1.11 2013/12/18 16:12:07 axs Exp $
EAPI="4"
@@ -57,6 +57,11 @@ src_prepare() {
# Prevent an access violation, do not create symlinks on live file system
# during installation.
sed -e 's/ install-filter / /g' -i Makefile
+
+ # Prevent an access violation, do not remove files from live filesystem
+ # during make install
+ sed -e '/rm .*LIBUDEVDIR)\//d' -i Makefile
+ sed -e '/rm .*lib\/udev\/rules.d\//d' -i hplj1000
}
src_compile() {