summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-06-17 09:45:51 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-06-17 09:45:51 +0000
commitf06d713ff483fc49615eb4675fd93f27f11970c6 (patch)
tree6f48b7803f4aab6250a85519e0b0e0cb617bc0a0 /net-p2p
parentFix build problem due to missed m4 directory, bug #324425, thank Nikolay S. R... (diff)
downloadgentoo-2-f06d713ff483fc49615eb4675fd93f27f11970c6.tar.gz
gentoo-2-f06d713ff483fc49615eb4675fd93f27f11970c6.tar.bz2
gentoo-2-f06d713ff483fc49615eb4675fd93f27f11970c6.zip
Version bump
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/qbittorrent/ChangeLog8
-rw-r--r--net-p2p/qbittorrent/files/moc_bug_workaround.patch24
-rw-r--r--net-p2p/qbittorrent/qbittorrent-2.2.9.ebuild62
3 files changed, 93 insertions, 1 deletions
diff --git a/net-p2p/qbittorrent/ChangeLog b/net-p2p/qbittorrent/ChangeLog
index 5b912c624cfa..16d8da095767 100644
--- a/net-p2p/qbittorrent/ChangeLog
+++ b/net-p2p/qbittorrent/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-p2p/qbittorrent
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/ChangeLog,v 1.87 2010/06/12 10:12:06 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/ChangeLog,v 1.88 2010/06/17 09:45:51 hwoarang Exp $
+
+*qbittorrent-2.2.9 (17 Jun 2010)
+
+ 17 Jun 2010; Markos Chandras <hwoarang@gentoo.org>
+ +qbittorrent-2.2.9.ebuild, +files/moc_bug_workaround.patch:
+ Version bump
12 Jun 2010; Markos Chandras <hwoarang@gentoo.org> metadata.xml:
Taking over maintainership
diff --git a/net-p2p/qbittorrent/files/moc_bug_workaround.patch b/net-p2p/qbittorrent/files/moc_bug_workaround.patch
new file mode 100644
index 000000000000..f01eadb5eaac
--- /dev/null
+++ b/net-p2p/qbittorrent/files/moc_bug_workaround.patch
@@ -0,0 +1,24 @@
+Index: src/bittorrent.h
+===================================================================
+--- src/bittorrent.h (revision 4095)
++++ src/bittorrent.h (working copy)
+@@ -118,6 +118,9 @@
+ bool useTemporaryFolder() const;
+ QString getDefaultSavePath() const;
+ ScanFoldersModel* getScanFoldersModel() const;
++#if LIBTORRENT_VERSION_MINOR < 15
++ void saveDHTEntry();
++#endif
+
+ public slots:
+ QTorrentHandle addTorrent(QString path, bool fromScanDir = false, QString from_url = QString(), bool resumed = false);
+@@ -136,9 +139,6 @@
+ void resumeTorrent(QString hash);
+ void resumeAllTorrents();
+ /* End Web UI */
+-#if LIBTORRENT_VERSION_MINOR < 15
+- void saveDHTEntry();
+-#endif
+ void preAllocateAllFiles(bool b);
+ void saveFastResumeData();
+ void enableIPFilter(QString filter);
diff --git a/net-p2p/qbittorrent/qbittorrent-2.2.9.ebuild b/net-p2p/qbittorrent/qbittorrent-2.2.9.ebuild
new file mode 100644
index 000000000000..a96f298bc96e
--- /dev/null
+++ b/net-p2p/qbittorrent/qbittorrent-2.2.9.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-2.2.9.ebuild,v 1.1 2010/06/17 09:45:51 hwoarang Exp $
+
+EAPI="2"
+PYTHON_DEPEND="2"
+inherit python confutils qt4-r2 versionator
+
+DESCRIPTION="BitTorrent client in C++ and Qt"
+HOMEPAGE="http://www.qbittorrent.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+X geoip libnotify"
+
+# boost version so that we always have thread support
+CDEPEND="net-libs/rb_libtorrent
+ x11-libs/qt-core:4
+ X? ( x11-libs/qt-gui:4
+ libnotify? ( x11-libs/qt-gui:4[glib] ) )
+ dev-libs/boost"
+DEPEND="${CDEPEND}
+ dev-util/pkgconfig"
+RDEPEND="${CDEPEND}
+ geoip? ( dev-libs/geoip )
+ libnotify? ( x11-libs/libnotify )"
+
+DOCS="AUTHORS Changelog NEWS README TODO"
+
+pkg_setup() {
+ confutils_use_depend_all libnotify X
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ # Move saveDHTEntry definition away from slots so the moc
+ # doens't get confused and breaks compilation
+ epatch "${FILESDIR}"/moc_bug_workaround.patch
+ # Respect LDFLAGS
+ sed -i -e 's/-Wl,--as-needed/$(LDFLAGS)/g' src/src.pro
+ qt4-r2_src_prepare
+}
+
+src_configure() {
+ local myconf
+ use X || myconf+=" --disable-gui"
+ use geoip || myconf+=" --disable-geoip-database"
+ use libnotify || myconf+=" --disable-libnotify"
+
+ # slotted boost detection, bug #309415
+ BOOST_PKG="$(best_version ">=dev-libs/boost-1.34.1")"
+ BOOST_VER="$(get_version_component_range 1-2 "${BOOST_PKG/*boost-/}")"
+ BOOST_VER="$(replace_all_version_separators _ "${BOOST_VER}")"
+ myconf+=" --with-libboost-inc=/usr/include/boost-${BOOST_VER}"
+
+ # econf fails, since this uses qconf
+ ./configure --prefix=/usr --qtdir=/usr ${myconf} || die "configure failed"
+ eqmake4
+}