summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStanislav Ochotnicky <sochotnicky@gentoo.org>2010-06-18 21:51:21 +0000
committerStanislav Ochotnicky <sochotnicky@gentoo.org>2010-06-18 21:51:21 +0000
commite425079ab0b19b2b5309fd19c93e7994364c834d (patch)
tree5afab6c36e082b3c1fca2f2f752e1e01e9fa327d /net-p2p
parentamd64 stable (diff)
downloadgentoo-2-e425079ab0b19b2b5309fd19c93e7994364c834d.tar.gz
gentoo-2-e425079ab0b19b2b5309fd19c93e7994364c834d.tar.bz2
gentoo-2-e425079ab0b19b2b5309fd19c93e7994364c834d.zip
Fixed installation of executable to /usr/share (#295769)
Removed old patches + move to EAPI2 (Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/linuxdcpp/ChangeLog10
-rw-r--r--net-p2p/linuxdcpp/files/1.0.1-gcc-4.3.patch16
-rw-r--r--net-p2p/linuxdcpp/files/linuxdcpp-1.0.1-fix-remote-vulnerability.patch33
-rw-r--r--net-p2p/linuxdcpp/linuxdcpp-1.0.3-r1.ebuild53
4 files changed, 62 insertions, 50 deletions
diff --git a/net-p2p/linuxdcpp/ChangeLog b/net-p2p/linuxdcpp/ChangeLog
index 61478de9e09f..982189708b60 100644
--- a/net-p2p/linuxdcpp/ChangeLog
+++ b/net-p2p/linuxdcpp/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-p2p/linuxdcpp
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/linuxdcpp/ChangeLog,v 1.40 2010/06/18 19:28:36 sochotnicky Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/linuxdcpp/ChangeLog,v 1.41 2010/06/18 21:51:21 sochotnicky Exp $
+
+*linuxdcpp-1.0.3-r1 (18 Jun 2010)
+
+ 18 Jun 2010; Stanislav Ochotnicky <sochotnicky@gentoo.org>
+ -files/linuxdcpp-1.0.1-fix-remote-vulnerability.patch,
+ +linuxdcpp-1.0.3-r1.ebuild, -files/1.0.1-gcc-4.3.patch:
+ Fixed installation of executable to /usr/share (#295769)
+ Removed old patches
18 Jun 2010; Stanislav Ochotnicky <sochotnicky@gentoo.org>
linuxdcpp-9999.ebuild:
diff --git a/net-p2p/linuxdcpp/files/1.0.1-gcc-4.3.patch b/net-p2p/linuxdcpp/files/1.0.1-gcc-4.3.patch
deleted file mode 100644
index 279663eddefb..000000000000
--- a/net-p2p/linuxdcpp/files/1.0.1-gcc-4.3.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-diff -NrU5 linuxdcpp-1.0.1.orig/client/ShareManager.h linuxdcpp-1.0.1/client/ShareManager.h
---- linuxdcpp-1.0.1.orig/client/ShareManager.h 2007-07-07 22:02:08.000000000 +0200
-+++ linuxdcpp-1.0.1/client/ShareManager.h 2008-06-22 14:14:30.000000000 +0200
-@@ -35,10 +35,12 @@
- #include "Singleton.h"
- #include "BloomFilter.h"
- #include "FastAlloc.h"
- #include "MerkleTree.h"
-
-+#include <memory> // GCC 4.3 fix
-+
- STANDARD_EXCEPTION(ShareException);
-
- class SimpleXML;
- class Client;
- class File;
diff --git a/net-p2p/linuxdcpp/files/linuxdcpp-1.0.1-fix-remote-vulnerability.patch b/net-p2p/linuxdcpp/files/linuxdcpp-1.0.1-fix-remote-vulnerability.patch
deleted file mode 100644
index ab2346678a38..000000000000
--- a/net-p2p/linuxdcpp/files/linuxdcpp-1.0.1-fix-remote-vulnerability.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-http://bugs.gentoo.org/show_bug.cgi?id=230075
-Security bug, fixed upstream.
---- client/ShareManager.cpp 13 Oct 2007 21:56:55 -0000 1.14
-+++ client/ShareManager.cpp 29 Jun 2008 15:34:36 -0000 1.15
-@@ -926,6 +926,10 @@
- }
- j = i + 1;
- }
-+
-+ if(it == directories.end())
-+ return NULL;
-+
- for(ShareManager::Directory::MapIter it2 = it->second->directories.begin(); it2 != it->second->directories.end(); ++it2) {
- it2->second->toXml(sos, indent, tmp, recurse);
- }
---- client/NmdcHub.cpp 4 Aug 2007 21:17:21 -0000 1.14
-+++ client/NmdcHub.cpp 29 Jun 2008 15:42:27 -0000 1.15
-@@ -693,10 +693,14 @@
- if(fromNick.empty())
- return;
-
-+ if(param.size() < j + 2) {
-+ return;
-+ }
-+ string msg = param.substr(j + 2);
-+
- OnlineUser* replyTo = findUser(rtNick);
- OnlineUser* from = findUser(fromNick);
-
-- string msg = param.substr(j + 2);
- if(replyTo == NULL || from == NULL) {
- if(replyTo == 0) {
- // Assume it's from the hub
diff --git a/net-p2p/linuxdcpp/linuxdcpp-1.0.3-r1.ebuild b/net-p2p/linuxdcpp/linuxdcpp-1.0.3-r1.ebuild
new file mode 100644
index 000000000000..549d503cfb5c
--- /dev/null
+++ b/net-p2p/linuxdcpp/linuxdcpp-1.0.3-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/linuxdcpp/linuxdcpp-1.0.3-r1.ebuild,v 1.1 2010/06/18 21:51:21 sochotnicky Exp $
+
+EAPI=2
+
+inherit eutils
+
+DESCRIPTION="Direct connect client, looks and works like famous DC++"
+HOMEPAGE="https://launchpad.net/linuxdcpp"
+SRC_URI="http://launchpad.net/linuxdcpp/1.0/${PV}/+download/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE="debug"
+
+RDEPEND=">=gnome-base/libglade-2.4
+ >=x11-libs/gtk+-2.6
+ app-arch/bzip2
+ dev-libs/openssl"
+DEPEND="${RDEPEND}
+ media-libs/fontconfig
+ >=dev-util/scons-0.96
+ dev-util/pkgconfig"
+
+src_prepare() {
+ # prevent scons installation of *txt files to wrong directory
+ sed -i 's/.*source = text_files.*//' SConstruct
+}
+
+src_compile() {
+ local myconf=""
+ use debug && myconf="${myconf} debug=1"
+
+ scons ${myconf} ${MAKEOPTS} CXXFLAGS="${CXXFLAGS}" PREFIX=/usr || die "scons failed"
+}
+
+src_install() {
+ # linuxdcpp does not install docs according to gentoos naming scheme, so do it by hand
+ dodoc Readme.txt Changelog.txt Credits.txt
+ rm "${S}"/*.txt
+
+ scons install PREFIX="/usr" FAKE_ROOT="${D}" || die "scons install failed"
+
+ doicon pixmaps/${PN}.png
+ make_desktop_entry "${PN}" "${PN}" "${PN}"
+}
+
+pkg_postinst() {
+ elog
+ elog "After adding first directory to shares you might need to restart linuxdcpp."
+ elog
+}