summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2013-10-16 20:07:02 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2013-10-16 20:07:02 +0000
commitbdd783e3e5af9ead7dcc530404ee0c83be580b9b (patch)
tree2f6f5d5aa1a4be141deb838f8fed4a874cbbfae2 /net-p2p
parentsystemd USE flag is not needed (#487674#c9 by Enrico Tagliavini) (diff)
downloadgentoo-2-bdd783e3e5af9ead7dcc530404ee0c83be580b9b.tar.gz
gentoo-2-bdd783e3e5af9ead7dcc530404ee0c83be580b9b.tar.bz2
gentoo-2-bdd783e3e5af9ead7dcc530404ee0c83be580b9b.zip
Version bump
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key C2BA7F3C!)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/qbittorrent/ChangeLog8
-rw-r--r--net-p2p/qbittorrent/qbittorrent-3.1.0.ebuild54
2 files changed, 61 insertions, 1 deletions
diff --git a/net-p2p/qbittorrent/ChangeLog b/net-p2p/qbittorrent/ChangeLog
index 94c3a7a208df..d7c3336df216 100644
--- a/net-p2p/qbittorrent/ChangeLog
+++ b/net-p2p/qbittorrent/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-p2p/qbittorrent
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/ChangeLog,v 1.216 2013/10/13 10:35:28 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/ChangeLog,v 1.217 2013/10/16 20:07:02 hwoarang Exp $
+
+*qbittorrent-3.1.0 (16 Oct 2013)
+
+ 16 Oct 2013; Markos Chandras <hwoarang@gentoo.org> +qbittorrent-3.1.0.ebuild,
+ metadata.xml:
+ Version bump
*qbittorrent-3.0.11-r1 (13 Oct 2013)
diff --git a/net-p2p/qbittorrent/qbittorrent-3.1.0.ebuild b/net-p2p/qbittorrent/qbittorrent-3.1.0.ebuild
new file mode 100644
index 000000000000..ca10f487cb73
--- /dev/null
+++ b/net-p2p/qbittorrent/qbittorrent-3.1.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-3.1.0.ebuild,v 1.1 2013/10/16 20:07:02 hwoarang Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit python-r1 qt4-r2
+
+MY_P="${P/_/}"
+DESCRIPTION="BitTorrent client in C++ and Qt"
+HOMEPAGE="http://www.qbittorrent.org/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="dbus +X geoip"
+
+# python-2 is a runtime dep only, for the search engine (see INSTALL file)
+CDEPEND="dev-libs/boost
+ dev-qt/qtcore:4
+ dev-qt/qtsingleapplication
+ >=net-libs/rb_libtorrent-0.16.3
+ X? ( dev-qt/qtgui:4 )
+ dbus? ( dev-qt/qtdbus:4 )"
+DEPEND="${CDEPEND}
+ virtual/pkgconfig"
+RDEPEND="${CDEPEND}
+ ${PYTHON_DEPS}
+ geoip? ( dev-libs/geoip )"
+
+DOCS="AUTHORS Changelog NEWS README TODO"
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ # Respect LDFLAGS
+ sed -i -e 's/-Wl,--as-needed/$(LDFLAGS)/g' src/src.pro
+ qt4-r2_src_prepare
+}
+
+src_configure() {
+ local myconf
+ use X || myconf+=" --disable-gui"
+ use geoip || myconf+=" --disable-geoip-database"
+ use dbus || myconf+=" --disable-qt-dbus"
+
+ # econf fails, since this uses qconf
+ ./configure --prefix=/usr --qtdir=/usr \
+ --with-libboost-inc=/usr/include/boost \
+ --with-qtsingleapplication=system \
+ ${myconf} || die "configure failed"
+ eqmake4
+}