summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2015-07-11 13:25:23 +0000
committerAnthony G. Basile <blueness@gentoo.org>2015-07-11 13:25:23 +0000
commit6e963c5b2e1b58e7a932b6555ff1bf6c3a8f4b9c (patch)
tree1e03ecff28389626a0453ac4c8e0ead7162f79dd /net-p2p
parentRemove additionalparam flags from javadoc target for the javadoc to compile s... (diff)
downloadgentoo-2-6e963c5b2e1b58e7a932b6555ff1bf6c3a8f4b9c.tar.gz
gentoo-2-6e963c5b2e1b58e7a932b6555ff1bf6c3a8f4b9c.tar.bz2
gentoo-2-6e963c5b2e1b58e7a932b6555ff1bf6c3a8f4b9c.zip
Version bump. Bug #554176.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/litecoind/ChangeLog9
-rw-r--r--net-p2p/litecoind/files/0.9.0-sys_leveldb.patch34
-rw-r--r--net-p2p/litecoind/litecoind-0.10.2.2.ebuild (renamed from net-p2p/litecoind/litecoind-0.8.7.1.ebuild)74
-rw-r--r--net-p2p/litecoind/litecoind-0.8.7.2.ebuild123
4 files changed, 66 insertions, 174 deletions
diff --git a/net-p2p/litecoind/ChangeLog b/net-p2p/litecoind/ChangeLog
index de81f42385b8..e08f2e2fc272 100644
--- a/net-p2p/litecoind/ChangeLog
+++ b/net-p2p/litecoind/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-p2p/litecoind
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/litecoind/ChangeLog,v 1.10 2015/01/07 17:54:39 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/litecoind/ChangeLog,v 1.11 2015/07/11 13:25:23 blueness Exp $
+
+*litecoind-0.10.2.2 (11 Jul 2015)
+
+ 11 Jul 2015; Anthony G. Basile <blueness@gentoo.org>
+ +files/0.9.0-sys_leveldb.patch, +litecoind-0.10.2.2.ebuild,
+ -litecoind-0.8.7.1.ebuild, -litecoind-0.8.7.2.ebuild:
+ Version bump. Bug #554176.
*litecoind-0.8.7.4 (07 Jan 2015)
diff --git a/net-p2p/litecoind/files/0.9.0-sys_leveldb.patch b/net-p2p/litecoind/files/0.9.0-sys_leveldb.patch
new file mode 100644
index 000000000000..60e9f2b20941
--- /dev/null
+++ b/net-p2p/litecoind/files/0.9.0-sys_leveldb.patch
@@ -0,0 +1,34 @@
+commit c38e0af3e021eb0b2aba846c77b06ca71de06b11 (personal-github/sys_leveldb, sys_leveldb)
+Author: Luke Dashjr <luke-jr+git@utopios.org>
+Date: Mon Sep 9 03:06:17 2013 +0000
+
+ configure: Add unsupported --with-system-leveldb configure flag
+
+diff --git a/configure.ac b/configure.ac
+index 3ed4549..5a5852d 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -332,10 +332,22 @@ AC_TRY_COMPILE([#include <sys/socket.h>],
+ [ AC_MSG_RESULT(no)]
+ )
+
++dnl Check for leveldb, only if explicitly requested
+ LEVELDB_CPPFLAGS=
+ LIBLEVELDB=
+ LIBMEMENV=
+-AM_CONDITIONAL([EMBEDDED_LEVELDB],[true])
++AC_ARG_WITH([system-leveldb],
++ [AS_HELP_STRING([--with-system-leveldb],
++ [Build with system LevelDB (default is no; DANGEROUS; NOT SUPPORTED)])],
++ [system_leveldb=$withval],
++ [system_leveldb=no]
++)
++if test x$system_leveldb != xno; then
++ LEVELDB_CPPFLAGS=
++ LIBLEVELDB=-lleveldb
++ LIBMEMENV=-lmemenv
++fi
++AM_CONDITIONAL([EMBEDDED_LEVELDB],[test x$system_leveldb = xno])
+ AC_SUBST(LEVELDB_CPPFLAGS)
+ AC_SUBST(LIBLEVELDB)
+ AC_SUBST(LIBMEMENV)
diff --git a/net-p2p/litecoind/litecoind-0.8.7.1.ebuild b/net-p2p/litecoind/litecoind-0.10.2.2.ebuild
index 806cbceffe8a..ac562ec7df26 100644
--- a/net-p2p/litecoind/litecoind-0.8.7.1.ebuild
+++ b/net-p2p/litecoind/litecoind-0.10.2.2.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/litecoind/litecoind-0.8.7.1.ebuild,v 1.3 2014/08/28 22:34:06 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/litecoind/litecoind-0.10.2.2.ebuild,v 1.1 2015/07/11 13:25:23 blueness Exp $
EAPI=5
DB_VER="4.8"
-inherit bash-completion-r1 db-use eutils systemd user
+inherit autotools db-use eutils systemd user
MyPV="${PV/_/-}"
MyPN="litecoin"
@@ -19,19 +19,15 @@ SRC_URI="https://github.com/${MyPN}-project/${MyPN}/archive/v${MyPV}.tar.gz -> $
LICENSE="MIT ISC GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="examples ipv6 logrotate upnp"
+IUSE="logrotate upnp"
RDEPEND="
dev-libs/boost[threads(+)]
dev-libs/openssl:0[-bindist]
- logrotate? (
- app-admin/logrotate
- )
- upnp? (
- net-libs/miniupnpc
- )
+ logrotate? ( app-admin/logrotate )
+ upnp? ( net-libs/miniupnpc )
sys-libs/db:$(db_ver_to_slot "${DB_VER}")[cxx]
- <=dev-libs/leveldb-1.12.0[-snappy]
+ virtual/bitcoin-leveldb
"
DEPEND="${RDEPEND}
>=app-shells/bash-4.1
@@ -47,47 +43,33 @@ pkg_setup() {
}
src_prepare() {
- epatch "${FILESDIR}"/${MyPN}-sys_leveldb.patch
+ epatch "${FILESDIR}/0.9.0-sys_leveldb.patch"
+ eautoreconf
rm -r src/leveldb
-
- if has_version '>=dev-libs/boost-1.52'; then
- sed -i 's/\(-l db_cxx\)/-l boost_chrono$(BOOST_LIB_SUFFIX) \1/' src/makefile.unix
- fi
}
src_configure() {
- OPTS=()
-
- OPTS+=("DEBUGFLAGS=")
- OPTS+=("CXXFLAGS=${CXXFLAGS}")
- OPTS+=("LDFLAGS=${LDFLAGS}")
-
+ local my_econf=
if use upnp; then
- OPTS+=("USE_UPNP=1")
+ my_econf="${my_econf} --with-miniupnpc --enable-upnp-default"
else
- OPTS+=("USE_UPNP=-")
+ my_econf="${my_econf} --without-miniupnpc --disable-upnp-default"
fi
-
- use ipv6 || OPTS+=("USE_IPV6=-")
-
- OPTS+=("USE_SYSTEM_LEVELDB=1")
- OPTS+=("BDB_INCLUDE_PATH=$(db_includedir "${DB_VER}")")
- OPTS+=("BDB_LIB_SUFFIX=-${DB_VER}")
-
- cd src || die
- emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" -f makefile.unix "${OPTS[@]}" ${PN}
+ econf \
+ --disable-ccache \
+ --disable-static \
+ --disable-tests \
+ --with-system-leveldb \
+ --with-system-libsecp256k1 \
+ --without-libs \
+ --without-daemon \
+ --without-gui \
+ ${my_econf} \
+ "$@"
}
-#Tests are broken with and without our litecoin-sys_leveldb.patch.
-#When tests work, make sure to inherit toolchain-funcs
-#src_test() {
-# cd src || die
-# emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" -f makefile.unix "${OPTS[@]}" test_litecoin
-# ./test_litecoin || die 'Tests failed'
-#}
-
src_install() {
- dobin src/${PN}
+ default
insinto /etc/litecoin
doins "${FILESDIR}/litecoin.conf"
@@ -108,14 +90,6 @@ src_install() {
newman contrib/debian/manpages/bitcoind.1 litecoind.1
newman contrib/debian/manpages/bitcoin.conf.5 litecoin.conf.5
- sed -i -e 's/bitcoin/litecoin/g' contrib/bitcoind.bash-completion
- newbashcomp contrib/bitcoind.bash-completion ${PN}.bash-completion
-
- if use examples; then
- docinto examples
- dodoc -r contrib/{bitrpc,pyminer,spendfrom,tidy_datadir.sh,wallettools}
- fi
-
if use logrotate; then
insinto /etc/logrotate.d
newins "${FILESDIR}/litecoind.logrotate" litecoind
diff --git a/net-p2p/litecoind/litecoind-0.8.7.2.ebuild b/net-p2p/litecoind/litecoind-0.8.7.2.ebuild
deleted file mode 100644
index 249237c9e624..000000000000
--- a/net-p2p/litecoind/litecoind-0.8.7.2.ebuild
+++ /dev/null
@@ -1,123 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/litecoind/litecoind-0.8.7.2.ebuild,v 1.1 2014/08/28 23:05:03 blueness Exp $
-
-EAPI=5
-
-DB_VER="4.8"
-
-inherit bash-completion-r1 db-use eutils systemd user
-
-MyPV="${PV/_/-}"
-MyPN="litecoin"
-MyP="${MyPN}-${MyPV}"
-
-DESCRIPTION="P2P Internet currency based on Bitcoin but easier to mine"
-HOMEPAGE="https://litecoin.org/"
-SRC_URI="https://github.com/${MyPN}-project/${MyPN}/archive/v${MyPV}.tar.gz -> ${MyP}.tar.gz"
-
-LICENSE="MIT ISC GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="examples ipv6 logrotate upnp"
-
-RDEPEND="
- dev-libs/boost[threads(+)]
- dev-libs/openssl:0[-bindist]
- logrotate? (
- app-admin/logrotate
- )
- upnp? (
- net-libs/miniupnpc
- )
- sys-libs/db:$(db_ver_to_slot "${DB_VER}")[cxx]
- <=dev-libs/leveldb-1.12.0[-snappy]
-"
-DEPEND="${RDEPEND}
- >=app-shells/bash-4.1
- sys-apps/sed
-"
-
-S="${WORKDIR}/${MyP}"
-
-pkg_setup() {
- local UG='litecoin'
- enewgroup "${UG}"
- enewuser "${UG}" -1 -1 /var/lib/litecoin "${UG}"
-}
-
-src_prepare() {
- epatch "${FILESDIR}"/${MyPN}-sys_leveldb.patch
- rm -r src/leveldb
-
- if has_version '>=dev-libs/boost-1.52'; then
- sed -i 's/\(-l db_cxx\)/-l boost_chrono$(BOOST_LIB_SUFFIX) \1/' src/makefile.unix
- fi
-}
-
-src_configure() {
- OPTS=()
-
- OPTS+=("DEBUGFLAGS=")
- OPTS+=("CXXFLAGS=${CXXFLAGS}")
- OPTS+=("LDFLAGS=${LDFLAGS}")
-
- if use upnp; then
- OPTS+=("USE_UPNP=1")
- else
- OPTS+=("USE_UPNP=-")
- fi
-
- use ipv6 || OPTS+=("USE_IPV6=-")
-
- OPTS+=("USE_SYSTEM_LEVELDB=1")
- OPTS+=("BDB_INCLUDE_PATH=$(db_includedir "${DB_VER}")")
- OPTS+=("BDB_LIB_SUFFIX=-${DB_VER}")
-
- cd src || die
- emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" -f makefile.unix "${OPTS[@]}" ${PN}
-}
-
-#Tests are broken with and without our litecoin-sys_leveldb.patch.
-#When tests work, make sure to inherit toolchain-funcs
-#src_test() {
-# cd src || die
-# emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" -f makefile.unix "${OPTS[@]}" test_litecoin
-# ./test_litecoin || die 'Tests failed'
-#}
-
-src_install() {
- dobin src/${PN}
-
- insinto /etc/litecoin
- doins "${FILESDIR}/litecoin.conf"
- fowners litecoin:litecoin /etc/litecoin/litecoin.conf
- fperms 600 /etc/litecoin/litecoin.conf
-
- newconfd "${FILESDIR}/litecoin.confd" ${PN}
- newinitd "${FILESDIR}/litecoin.initd-r1" ${PN}
- systemd_dounit "${FILESDIR}/litecoin.service"
-
- keepdir /var/lib/litecoin/.litecoin
- fperms 700 /var/lib/litecoin
- fowners litecoin:litecoin /var/lib/litecoin/
- fowners litecoin:litecoin /var/lib/litecoin/.litecoin
- dosym /etc/litecoin/litecoin.conf /var/lib/litecoin/.litecoin/litecoin.conf
-
- dodoc doc/README.md doc/release-notes.md
- newman contrib/debian/manpages/bitcoind.1 litecoind.1
- newman contrib/debian/manpages/bitcoin.conf.5 litecoin.conf.5
-
- sed -i -e 's/bitcoin/litecoin/g' contrib/bitcoind.bash-completion
- newbashcomp contrib/bitcoind.bash-completion ${PN}.bash-completion
-
- if use examples; then
- docinto examples
- dodoc -r contrib/{bitrpc,pyminer,spendfrom,tidy_datadir.sh,wallettools}
- fi
-
- if use logrotate; then
- insinto /etc/logrotate.d
- newins "${FILESDIR}/litecoind.logrotate" litecoind
- fi
-}