summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2015-05-02 15:38:04 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2015-05-02 15:38:04 +0000
commit2730efb3dc281ca9647d5f7d270643b0d0c1cf0d (patch)
treebbeefff67a02872f7ff4497dedd9317c332b4a80 /net-p2p
parentPort to EAPI=5 (diff)
downloadgentoo-2-2730efb3dc281ca9647d5f7d270643b0d0c1cf0d.tar.gz
gentoo-2-2730efb3dc281ca9647d5f7d270643b0d0c1cf0d.tar.bz2
gentoo-2-2730efb3dc281ca9647d5f7d270643b0d0c1cf0d.zip
Port to EAPI=5
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 84AD142F)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/mktorrent/ChangeLog10
-rw-r--r--net-p2p/mktorrent/mktorrent-1.0-r1.ebuild34
2 files changed, 42 insertions, 2 deletions
diff --git a/net-p2p/mktorrent/ChangeLog b/net-p2p/mktorrent/ChangeLog
index 1ee4368b15dd..5e69313f9c2a 100644
--- a/net-p2p/mktorrent/ChangeLog
+++ b/net-p2p/mktorrent/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-p2p/mktorrent
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/mktorrent/ChangeLog,v 1.11 2011/05/20 12:11:37 jlec Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/mktorrent/ChangeLog,v 1.12 2015/05/02 15:38:04 dilfridge Exp $
+
+*mktorrent-1.0-r1 (02 May 2015)
+
+ 02 May 2015; Andreas K. Huettel <dilfridge@gentoo.org>
+ +mktorrent-1.0-r1.ebuild:
+ Port to EAPI=5
20 May 2011; Justin Lecher <jlec@gentoo.org> mktorrent-1.0.ebuild,
metadata.xml:
diff --git a/net-p2p/mktorrent/mktorrent-1.0-r1.ebuild b/net-p2p/mktorrent/mktorrent-1.0-r1.ebuild
new file mode 100644
index 000000000000..d4b101a0fce6
--- /dev/null
+++ b/net-p2p/mktorrent/mktorrent-1.0-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/mktorrent/mktorrent-1.0-r1.ebuild,v 1.1 2015/05/02 15:38:04 dilfridge Exp $
+
+EAPI=5
+inherit toolchain-funcs
+
+DESCRIPTION="Simple command line utility to create BitTorrent metainfo files"
+HOMEPAGE="http://mktorrent.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="threads +ssl debug"
+
+RDEPEND="ssl? ( dev-libs/openssl )"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ tc-export CC
+ MAKEPARAM="USE_LONG_OPTIONS=1"
+ MAKEPARAM="${MAKEPARAM} USE_LARGE_FILES=1"
+ use debug && MAKEPARAM="${MAKEPARAM} DEBUG=1"
+ use ssl && MAKEPARAM="${MAKEPARAM} USE_OPENSSL=1"
+ use threads && MAKEPARAM="${MAKEPARAM} USE_PTHREADS=1"
+
+ emake ${MAKEPARAM}
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc README
+}