summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-11-20 12:50:41 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-11-20 12:50:41 +0000
commit17a515269315bb7edfde71a7a89ab736f8452ec6 (patch)
tree1133c1f38635d30d58b841d20b0dec6d103ff88e /net-p2p
parentadding compatibility patches for make-3.82 and camlp5-6.02.0, fixes bug #346061 (diff)
downloadgentoo-2-17a515269315bb7edfde71a7a89ab736f8452ec6.tar.gz
gentoo-2-17a515269315bb7edfde71a7a89ab736f8452ec6.tar.bz2
gentoo-2-17a515269315bb7edfde71a7a89ab736f8452ec6.zip
Version bump. Introduce live ebuild. Thanks to Ishan Arora <ishanarora@gmail.com>
(Portage version: 2.1.9.24/cvs/Linux x86_64)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/qbittorrent/ChangeLog11
-rw-r--r--net-p2p/qbittorrent/qbittorrent-2.5.0_beta4.ebuild (renamed from net-p2p/qbittorrent/qbittorrent-2.5.0_beta1.ebuild)2
-rw-r--r--net-p2p/qbittorrent/qbittorrent-9999.ebuild62
3 files changed, 73 insertions, 2 deletions
diff --git a/net-p2p/qbittorrent/ChangeLog b/net-p2p/qbittorrent/ChangeLog
index 14c8899fb036..e9670f2a6f8f 100644
--- a/net-p2p/qbittorrent/ChangeLog
+++ b/net-p2p/qbittorrent/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for net-p2p/qbittorrent
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/ChangeLog,v 1.121 2010/11/11 17:48:17 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/ChangeLog,v 1.122 2010/11/20 12:50:41 hwoarang Exp $
+
+*qbittorrent-9999 (20 Nov 2010)
+*qbittorrent-2.5.0_beta4 (20 Nov 2010)
+
+ 20 Nov 2010; Markos Chandras <hwoarang@gentoo.org>
+ -qbittorrent-2.5.0_beta1.ebuild, +qbittorrent-2.5.0_beta4.ebuild,
+ +qbittorrent-9999.ebuild:
+ Version bump. Introduce live ebuild. Thanks to Ishan Arora
+ <ishanarora@gmail.com>
*qbittorrent-2.4.10 (11 Nov 2010)
diff --git a/net-p2p/qbittorrent/qbittorrent-2.5.0_beta1.ebuild b/net-p2p/qbittorrent/qbittorrent-2.5.0_beta4.ebuild
index 71fba307efda..8cfcbf57f0af 100644
--- a/net-p2p/qbittorrent/qbittorrent-2.5.0_beta1.ebuild
+++ b/net-p2p/qbittorrent/qbittorrent-2.5.0_beta4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-2.5.0_beta1.ebuild,v 1.1 2010/10/17 22:54:36 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-2.5.0_beta4.ebuild,v 1.1 2010/11/20 12:50:41 hwoarang Exp $
EAPI="2"
PYTHON_DEPEND="2"
diff --git a/net-p2p/qbittorrent/qbittorrent-9999.ebuild b/net-p2p/qbittorrent/qbittorrent-9999.ebuild
new file mode 100644
index 000000000000..aae508d9c004
--- /dev/null
+++ b/net-p2p/qbittorrent/qbittorrent-9999.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-9999.ebuild,v 1.1 2010/11/20 12:50:41 hwoarang Exp $
+
+EAPI="2"
+PYTHON_DEPEND="2"
+
+inherit python confutils qt4-r2 versionator subversion
+
+DESCRIPTION="BitTorrent client in C++ and Qt"
+HOMEPAGE="http://www.qbittorrent.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+ESVN_REPO_URI="https://qbittorrent.svn.sourceforge.net/svnroot/qbittorrent/trunk"
+KEYWORDS=""
+
+IUSE="+X geoip libnotify"
+
+# boost version so that we always have thread support
+CDEPEND="net-libs/rb_libtorrent
+ x11-libs/qt-core:4
+ x11-libs/qt-dbus:4
+ X? ( x11-libs/qt-gui:4
+ libnotify? ( x11-libs/qt-gui:4[glib] ) )
+ dev-libs/boost"
+DEPEND="${CDEPEND}
+ dev-util/pkgconfig"
+RDEPEND="${CDEPEND}
+ geoip? ( dev-libs/geoip )
+ libnotify? ( x11-libs/libnotify )"
+
+DOCS="AUTHORS Changelog NEWS README TODO"
+
+pkg_setup() {
+ confutils_use_depend_all libnotify X
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ # Respect LDFLAGS
+ sed -i -e 's/-Wl,--as-needed/$(LDFLAGS)/g' src/src.pro
+ qt4-r2_src_prepare
+}
+
+src_configure() {
+ local myconf
+ use X || myconf+=" --disable-gui"
+ use geoip || myconf+=" --disable-geoip-database"
+ use libnotify || myconf+=" --disable-libnotify"
+
+ # slotted boost detection, bug #309415
+ BOOST_PKG="$(best_version ">=dev-libs/boost-1.34.1")"
+ BOOST_VER="$(get_version_component_range 1-2 "${BOOST_PKG/*boost-/}")"
+ BOOST_VER="$(replace_all_version_separators _ "${BOOST_VER}")"
+ myconf+=" --with-libboost-inc=/usr/include/boost-${BOOST_VER}"
+
+ # econf fails, since this uses qconf
+ ./configure --prefix=/usr --qtdir=/usr ${myconf} || die "configure failed"
+ eqmake4
+}