summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2009-09-27 05:31:59 +0000
committerRyan Hill <dirtyepic@gentoo.org>2009-09-27 05:31:59 +0000
commit16ecc6d285708a40298820b84f0a116c46c8d06d (patch)
treede55538b642ee5b80aee60319ce9aa8fd8947452 /net-p2p
parentRemove old. (diff)
downloadgentoo-2-16ecc6d285708a40298820b84f0a116c46c8d06d.tar.gz
gentoo-2-16ecc6d285708a40298820b84f0a116c46c8d06d.tar.bz2
gentoo-2-16ecc6d285708a40298820b84f0a116c46c8d06d.zip
Version bump.
- This version contains a backwards-incompatible change in the way the download queue is stored. If you downgrade to an earlier version you will lose access to any queued downloads. (Portage version: 2.2_rc42/cvs/Linux x86_64)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/nicotine+/ChangeLog10
-rw-r--r--net-p2p/nicotine+/nicotine+-1.2.13.ebuild32
2 files changed, 41 insertions, 1 deletions
diff --git a/net-p2p/nicotine+/ChangeLog b/net-p2p/nicotine+/ChangeLog
index c4abcb27545d..e43afea9a6ce 100644
--- a/net-p2p/nicotine+/ChangeLog
+++ b/net-p2p/nicotine+/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-p2p/nicotine+
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/nicotine+/ChangeLog,v 1.35 2009/07/19 16:02:17 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/nicotine+/ChangeLog,v 1.36 2009/09/27 05:31:59 dirtyepic Exp $
+
+*nicotine+-1.2.13 (27 Sep 2009)
+
+ 27 Sep 2009; Ryan Hill <dirtyepic@gentoo.org> +nicotine+-1.2.13.ebuild:
+ Version bump.
+ - This version contains a backwards-incompatible change in the way the
+ download queue is stored. If you downgrade to an earlier version you
+ will lose access to any queued downloads.
19 Jul 2009; Jeremy Olexa <darkside@gentoo.org> nicotine+-1.2.10.ebuild:
amd64 stable, bug 276113
diff --git a/net-p2p/nicotine+/nicotine+-1.2.13.ebuild b/net-p2p/nicotine+/nicotine+-1.2.13.ebuild
new file mode 100644
index 000000000000..5331109b60de
--- /dev/null
+++ b/net-p2p/nicotine+/nicotine+-1.2.13.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/nicotine+/nicotine+-1.2.13.ebuild,v 1.1 2009/09/27 05:31:59 dirtyepic Exp $
+
+inherit distutils multilib toolchain-funcs
+
+DESCRIPTION="A fork of nicotine, a Soulseek client in Python"
+HOMEPAGE="http://nicotine-plus.sourceforge.net"
+#SRC_URI="http://www.nicotine-plus.org/files/${P}.tar.bz2"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-3 LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE="geoip spell"
+
+RDEPEND="virtual/python
+ >=dev-python/pygtk-2.10
+ media-libs/mutagen
+ geoip? ( >=dev-python/geoip-python-0.2.0
+ >=dev-libs/geoip-1.2.1 )
+ spell? ( dev-python/sexy-python )
+ !net-p2p/nicotine"
+
+DEPEND="${RDEPEND}"
+
+src_install() {
+ distutils_python_version
+ distutils_src_install \
+ --install-lib /usr/$(get_libdir)/python${PYVER}/site-packages
+ dosym nicotine.py /usr/bin/nicotine
+}