summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2011-08-26 18:46:43 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2011-08-26 18:46:43 +0000
commit032525b6c72252df55803cd00b0c7831054335f3 (patch)
tree168b70967075423b7950691fcfd5da75b82adc6a /net-p2p
parentQA: do not call econf in src_compile for EAPI=2 and later. Closes bug #376449. (diff)
downloadgentoo-2-032525b6c72252df55803cd00b0c7831054335f3.tar.gz
gentoo-2-032525b6c72252df55803cd00b0c7831054335f3.tar.bz2
gentoo-2-032525b6c72252df55803cd00b0c7831054335f3.zip
Rewrite ebuild with EAPI=4 to actually follow proper QA guidelines. Closes bug #331875.
(Portage version: 2.2.0_alpha51/cvs/Linux x86_64)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/cccp/ChangeLog8
-rw-r--r--net-p2p/cccp/cccp-0.9.ebuild27
2 files changed, 23 insertions, 12 deletions
diff --git a/net-p2p/cccp/ChangeLog b/net-p2p/cccp/ChangeLog
index 29adf9c6094f..20329751f593 100644
--- a/net-p2p/cccp/ChangeLog
+++ b/net-p2p/cccp/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-p2p/cccp
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/cccp/ChangeLog,v 1.10 2007/01/23 15:50:17 armin76 Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/cccp/ChangeLog,v 1.11 2011/08/26 18:46:43 flameeyes Exp $
+
+ 26 Aug 2011; Diego E. Pettenò <flameeyes@gentoo.org> cccp-0.9.ebuild:
+ Rewrite ebuild with EAPI=4 to actually follow proper QA guidelines. Closes
+ bug #331875.
23 Jan 2007; Raúl Porcel <armin76@gentoo.org> -cccp-0.8.ebuild:
Drop old
diff --git a/net-p2p/cccp/cccp-0.9.ebuild b/net-p2p/cccp/cccp-0.9.ebuild
index eb58a7c037d3..09230967e8d3 100644
--- a/net-p2p/cccp/cccp-0.9.ebuild
+++ b/net-p2p/cccp/cccp-0.9.ebuild
@@ -1,6 +1,10 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/cccp/cccp-0.9.ebuild,v 1.4 2005/03/25 23:20:24 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/cccp/cccp-0.9.ebuild,v 1.5 2011/08/26 18:46:43 flameeyes Exp $
+
+EAPI=4
+
+inherit toolchain-funcs
IUSE=""
@@ -12,23 +16,26 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 ~ppc ~amd64"
-DEPEND=">=net-p2p/dctc-0.83"
+RDEPEND=">=net-p2p/dctc-0.83"
+DEPEND=""
S="${WORKDIR}/${PN}.${PV}"
-src_compile() {
- gcc ${CFLAGS} -o cccp cccp.c
+doecho() {
+ echo "$@"
+ "$@"
+}
+src_compile() {
+ doecho $(tc-getCC) ${LDFLAGS} ${CFLAGS} cccp.c -o cccp \
+ || die "unable to build unpaper"
}
src_install () {
-
dobin cccp
doman cccp.1
dodoc README TODO GETTING_STARTED scripts/SCRIPTS
- insinto /usr/share/cccp/scripts
- doins scripts/*
- chmod 755 ${D}/usr/share/cccp/scripts/[a-z]*
-
+ exeinto /usr/share/cccp/scripts
+ doexe scripts/[a-z]*
}