summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSaleem Abdulrasool <compnerd@gentoo.org>2008-01-22 04:25:47 +0000
committerSaleem Abdulrasool <compnerd@gentoo.org>2008-01-22 04:25:47 +0000
commit8f830d22e461ec015efabf32ffe5a9e4a741efc6 (patch)
treee5ce1cc2fd4f3dcff8b9c4903cc17170516879c9 /net-p2p/transmission
parentPull in icons as post-dependency. (diff)
downloadgentoo-2-8f830d22e461ec015efabf32ffe5a9e4a741efc6.tar.gz
gentoo-2-8f830d22e461ec015efabf32ffe5a9e4a741efc6.tar.bz2
gentoo-2-8f830d22e461ec015efabf32ffe5a9e4a741efc6.zip
version bump from upstream
(Portage version: 2.1.4)
Diffstat (limited to 'net-p2p/transmission')
-rw-r--r--net-p2p/transmission/ChangeLog8
-rw-r--r--net-p2p/transmission/files/digest-transmission-1.0.13
-rw-r--r--net-p2p/transmission/transmission-1.0.1.ebuild34
3 files changed, 44 insertions, 1 deletions
diff --git a/net-p2p/transmission/ChangeLog b/net-p2p/transmission/ChangeLog
index 6e7ffa7cd1cb..079908e83224 100644
--- a/net-p2p/transmission/ChangeLog
+++ b/net-p2p/transmission/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-p2p/transmission
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/transmission/ChangeLog,v 1.47 2008/01/06 00:08:42 compnerd Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/transmission/ChangeLog,v 1.48 2008/01/22 04:25:46 compnerd Exp $
+
+*transmission-1.0.1 (22 Jan 2008)
+
+ 22 Jan 2008; Saleem Abdulrasool <compnerd@gentoo.org>
+ +transmission-1.0.1.ebuild:
+ Version bump from upstream
06 Jan 2008; Saleem Abdulrasool <compnerd@gentoo.org>
-transmission-0.72.ebuild, -transmission-0.96.ebuild:
diff --git a/net-p2p/transmission/files/digest-transmission-1.0.1 b/net-p2p/transmission/files/digest-transmission-1.0.1
new file mode 100644
index 000000000000..95e76512bb95
--- /dev/null
+++ b/net-p2p/transmission/files/digest-transmission-1.0.1
@@ -0,0 +1,3 @@
+MD5 7e54fc9904b252206630e8b9180eeb59 transmission-1.01.tar.bz2 4078689
+RMD160 11d58809a408e49bd8e580df1c5b3eb795da76e1 transmission-1.01.tar.bz2 4078689
+SHA256 8a4e0ce51b4502a4174f600c6596f099dbe3744014c8be51c0a3dd8fdd09d541 transmission-1.01.tar.bz2 4078689
diff --git a/net-p2p/transmission/transmission-1.0.1.ebuild b/net-p2p/transmission/transmission-1.0.1.ebuild
new file mode 100644
index 000000000000..8d2a1aa86eb0
--- /dev/null
+++ b/net-p2p/transmission/transmission-1.0.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/transmission/transmission-1.0.1.ebuild,v 1.1 2008/01/22 04:25:46 compnerd Exp $
+
+MY_PV="1.01"
+
+DESCRIPTION="Simple BitTorrent client"
+HOMEPAGE="http://www.transmissionbt.com/"
+SRC_URI="http://download.transmissionbt.com/transmission/files/${PN}-${MY_PV}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE="gtk"
+
+RDEPEND=">=dev-libs/glib-2.6
+ >=dev-libs/openssl-0.9.8
+ gtk? ( >=x11-libs/gtk+-2.6 )"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ >=dev-util/pkgconfig-0.19
+ gtk? ( >=dev-util/intltool-0.35 )"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_compile() {
+ econf $(use_with gtk) || die "configure failed"
+ emake || die "build failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "install failed"
+ dodoc AUTHORS NEWS
+}