summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Hood <squinky86@gentoo.org>2006-06-16 05:12:32 +0000
committerJon Hood <squinky86@gentoo.org>2006-06-16 05:12:32 +0000
commit1926eb22b24c8dd2f74bbc5e0d020744da7be729 (patch)
treedbffe44db7da1b545bda6a6596a75521aa1baeda /net-p2p/transmission/transmission-0.5-r1.ebuild
parentold (diff)
downloadgentoo-2-1926eb22b24c8dd2f74bbc5e0d020744da7be729.tar.gz
gentoo-2-1926eb22b24c8dd2f74bbc5e0d020744da7be729.tar.bz2
gentoo-2-1926eb22b24c8dd2f74bbc5e0d020744da7be729.zip
add desktop and png files
(Portage version: 2.1)
Diffstat (limited to 'net-p2p/transmission/transmission-0.5-r1.ebuild')
-rw-r--r--net-p2p/transmission/transmission-0.5-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/net-p2p/transmission/transmission-0.5-r1.ebuild b/net-p2p/transmission/transmission-0.5-r1.ebuild
new file mode 100644
index 000000000000..9c87d3a1ce9a
--- /dev/null
+++ b/net-p2p/transmission/transmission-0.5-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/transmission/transmission-0.5-r1.ebuild,v 1.1 2006/06/16 05:12:32 squinky86 Exp $
+
+inherit eutils
+
+MY_P=${PN/t/T}-${PV}
+
+DESCRIPTION="Transmission is a free, lightweight BitTorrent client."
+HOMEPAGE="http://transmission.m0k.org"
+SRC_URI="http://download.m0k.org/transmission/files/${MY_P}.tar.gz"
+LICENSE="MIT"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gtk ssl"
+
+DEPEND=">=dev-util/jam-2.5
+ sys-devel/gettext
+ gtk? ( >=x11-libs/gtk+-2.6 )
+ ssl? ( dev-libs/openssl )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ econf $(use_enable ssl openssl) \
+ $(use_enable gtk) || die "configure failed"
+ jam
+}
+
+src_install() {
+ dobin transmissioncli
+
+ if use gtk ; then
+ dobin gtk/transmission-gtk
+ insinto /usr/share/applications/
+ doins "${FILESDIR}"/transmission.desktop
+ insinto /usr/share/pixmaps/
+ doins "${FILESDIR}"/transmission.png
+ fi
+}