summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2013-04-24 20:00:04 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2013-04-24 20:00:04 +0000
commit6e7429e3435bf3db9974e88b46cb40651da40a48 (patch)
tree42c9c45c0fbd013fd75c67c2b43a79bb4a785b40 /net-p2p/torrentinfo
parentVersion bump to 3.1.0, thanks to Matt for reporting this on IRC. (diff)
downloadgentoo-2-6e7429e3435bf3db9974e88b46cb40651da40a48.tar.gz
gentoo-2-6e7429e3435bf3db9974e88b46cb40651da40a48.tar.bz2
gentoo-2-6e7429e3435bf3db9974e88b46cb40651da40a48.zip
Version bump
(Portage version: 2.1.11.62/cvs/Linux x86_64, signed Manifest commit with key C2BA7F3C!)
Diffstat (limited to 'net-p2p/torrentinfo')
-rw-r--r--net-p2p/torrentinfo/ChangeLog7
-rw-r--r--net-p2p/torrentinfo/torrentinfo-1.8.6.ebuild26
2 files changed, 32 insertions, 1 deletions
diff --git a/net-p2p/torrentinfo/ChangeLog b/net-p2p/torrentinfo/ChangeLog
index a64d4c8e7bb5..435e9361a88f 100644
--- a/net-p2p/torrentinfo/ChangeLog
+++ b/net-p2p/torrentinfo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-p2p/torrentinfo
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/torrentinfo/ChangeLog,v 1.7 2013/04/23 20:12:29 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/torrentinfo/ChangeLog,v 1.8 2013/04/24 20:00:04 hwoarang Exp $
+
+*torrentinfo-1.8.6 (24 Apr 2013)
+
+ 24 Apr 2013; Markos Chandras <hwoarang@gentoo.org> +torrentinfo-1.8.6.ebuild:
+ Version bump
*torrentinfo-1.8.4 (23 Apr 2013)
diff --git a/net-p2p/torrentinfo/torrentinfo-1.8.6.ebuild b/net-p2p/torrentinfo/torrentinfo-1.8.6.ebuild
new file mode 100644
index 000000000000..eb184a85ab93
--- /dev/null
+++ b/net-p2p/torrentinfo/torrentinfo-1.8.6.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/torrentinfo/torrentinfo-1.8.6.ebuild,v 1.1 2013/04/24 20:00:04 hwoarang Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_6,2_7,3_2} )
+
+inherit distutils-r1
+
+DESCRIPTION="A torrent file parser"
+HOMEPAGE="https://github.com/ShanaTsunTsunLove/torrentinfo"
+SRC_URI="https://github.com/ShanaTsunTsunLove/torrentinfo/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="virtual/python-argparse[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"
+
+python_test() {
+ nosetests -v test/tests.py || die "Tests fail with ${EPYTHON}"
+}