summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-06-09 16:00:55 +0000
committerJustin Lecher <jlec@gentoo.org>2012-06-09 16:00:55 +0000
commitf9372bf3073066a639c332f12b9232ea67a890a9 (patch)
tree5e1d95f1ff6386fb5e8d08f07994e1e4723d2776 /net-p2p/rtorrent
parentVersion BUmp, move to EAPI=4 (diff)
downloadgentoo-2-f9372bf3073066a639c332f12b9232ea67a890a9.tar.gz
gentoo-2-f9372bf3073066a639c332f12b9232ea67a890a9.tar.bz2
gentoo-2-f9372bf3073066a639c332f12b9232ea67a890a9.zip
Version BUmp, move to EAPI=4
(Portage version: 2.2.0_alpha110/cvs/Linux x86_64)
Diffstat (limited to 'net-p2p/rtorrent')
-rw-r--r--net-p2p/rtorrent/ChangeLog7
-rw-r--r--net-p2p/rtorrent/rtorrent-0.9.2.ebuild51
2 files changed, 57 insertions, 1 deletions
diff --git a/net-p2p/rtorrent/ChangeLog b/net-p2p/rtorrent/ChangeLog
index b61febf89c01..fe93e2d7ac4f 100644
--- a/net-p2p/rtorrent/ChangeLog
+++ b/net-p2p/rtorrent/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-p2p/rtorrent
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/ChangeLog,v 1.176 2012/05/04 06:33:35 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/ChangeLog,v 1.177 2012/06/09 16:00:55 jlec Exp $
+
+*rtorrent-0.9.2 (09 Jun 2012)
+
+ 09 Jun 2012; Justin Lecher <jlec@gentoo.org> +rtorrent-0.9.2.ebuild:
+ Version BUmp, move to EAPI=4
04 May 2012; Jeff Horelick <jdhore@gentoo.org> rtorrent-0.8.6-r1.ebuild,
rtorrent-0.8.6-r4.ebuild, rtorrent-0.8.7-r4.ebuild, rtorrent-0.8.9.ebuild,
diff --git a/net-p2p/rtorrent/rtorrent-0.9.2.ebuild b/net-p2p/rtorrent/rtorrent-0.9.2.ebuild
new file mode 100644
index 000000000000..0aad391459bd
--- /dev/null
+++ b/net-p2p/rtorrent/rtorrent-0.9.2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/rtorrent-0.9.2.ebuild,v 1.1 2012/06/09 16:00:55 jlec Exp $
+
+EAPI=4
+
+inherit eutils
+
+DESCRIPTION="BitTorrent Client using libtorrent"
+HOMEPAGE="http://libtorrent.rakshasa.no/"
+SRC_URI="http://libtorrent.rakshasa.no/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="daemon debug ipv6 test xmlrpc"
+
+COMMON_DEPEND="~net-libs/libtorrent-0.13.${PV##*.}
+ >=dev-libs/libsigc++-2.2.2:2
+ >=net-misc/curl-7.19.1
+ sys-libs/ncurses
+ xmlrpc? ( dev-libs/xmlrpc-c )"
+RDEPEND="${COMMON_DEPEND}
+ daemon? ( app-misc/screen )"
+DEPEND="${COMMON_DEPEND}
+ test? ( dev-util/cppunit )
+ virtual/pkgconfig"
+
+DOCS=( doc/rtorrent.rc )
+
+src_prepare() {
+ # bug #358271
+ epatch "${FILESDIR}"/${PN}-0.9.1-ncurses.patch
+}
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ $(use_enable debug) \
+ $(use_enable ipv6) \
+ $(use_with xmlrpc xmlrpc-c)
+}
+
+src_install() {
+ default
+
+ if use daemon; then
+ newinitd "${FILESDIR}/rtorrentd.init" rtorrentd
+ newconfd "${FILESDIR}/rtorrentd.conf" rtorrentd
+ fi
+}