summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2008-11-10 10:09:05 +0000
committerRaúl Porcel <armin76@gentoo.org>2008-11-10 10:09:05 +0000
commit1d05d6c9674e26573e444430bdcb17c179e2e98a (patch)
tree04ec9bf3be97feb31c6258637866e78100f49a82 /net-p2p/qbittorrent
parentRemove useless entry (diff)
downloadgentoo-2-1d05d6c9674e26573e444430bdcb17c179e2e98a.tar.gz
gentoo-2-1d05d6c9674e26573e444430bdcb17c179e2e98a.tar.bz2
gentoo-2-1d05d6c9674e26573e444430bdcb17c179e2e98a.zip
Version bump
(Portage version: 2.1.4.5)
Diffstat (limited to 'net-p2p/qbittorrent')
-rw-r--r--net-p2p/qbittorrent/ChangeLog7
-rw-r--r--net-p2p/qbittorrent/qbittorrent-1.2.1.ebuild57
2 files changed, 63 insertions, 1 deletions
diff --git a/net-p2p/qbittorrent/ChangeLog b/net-p2p/qbittorrent/ChangeLog
index 833858244b6f..71438c587c54 100644
--- a/net-p2p/qbittorrent/ChangeLog
+++ b/net-p2p/qbittorrent/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-p2p/qbittorrent
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/ChangeLog,v 1.47 2008/10/30 19:32:22 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/ChangeLog,v 1.48 2008/11/10 10:09:05 armin76 Exp $
+
+*qbittorrent-1.2.1 (10 Nov 2008)
+
+ 10 Nov 2008; Raúl Porcel <armin76@gentoo.org> +qbittorrent-1.2.1.ebuild:
+ Version bump
*qbittorrent-1.2.0 (30 Oct 2008)
diff --git a/net-p2p/qbittorrent/qbittorrent-1.2.1.ebuild b/net-p2p/qbittorrent/qbittorrent-1.2.1.ebuild
new file mode 100644
index 000000000000..ddd851c7edee
--- /dev/null
+++ b/net-p2p/qbittorrent/qbittorrent-1.2.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-1.2.1.ebuild,v 1.1 2008/11/10 10:09:05 armin76 Exp $
+
+EAPI="1"
+
+inherit eutils qt4 multilib
+
+MY_P="${P/_/}"
+
+DESCRIPTION="BitTorrent client in C++ and Qt."
+HOMEPAGE="http://www.qbittorrent.org/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="|| ( x11-libs/qt-gui:4 =x11-libs/qt-4.3*:4 )
+ >=net-libs/rb_libtorrent-0.13.1
+ dev-libs/boost
+ net-misc/curl
+ dev-cpp/commoncpp2"
+RDEPEND="${DEPEND}
+ >=dev-lang/python-2.3"
+
+pkg_setup() {
+ # We need boost built with threads
+ if ! built_with_use --missing true "dev-libs/boost" threads; then
+ eerror "${PN} needs dev-libs/boost built with threads USE flag"
+ die "dev-libs/boost is built without threads USE flag"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Respect LDFLAGS
+ sed -i -e 's/-Wl,--as-needed/$(LDFLAGS)/g' src/src.pro
+}
+
+src_compile() {
+ # econf fails, since this uses qconf
+ ./configure --prefix=/usr --qtdir=/usr \
+ --with-libtorrent-inc=/usr/include \
+ --with-libtorrent-lib=/usr/$(get_libdir) \
+ || die "configure failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install || die "emake install failed"
+ dodoc AUTHORS Changelog NEWS README TODO
+}