summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2009-02-10 16:53:05 +0000
committerRaúl Porcel <armin76@gentoo.org>2009-02-10 16:53:05 +0000
commit802de36783fdd5422874c6b2831122c4438133da (patch)
treeaa1e49c947179df85a272b1b60ce16b19a77c39b /net-p2p/linuxdcpp
parentclean up (diff)
downloadgentoo-2-802de36783fdd5422874c6b2831122c4438133da.tar.gz
gentoo-2-802de36783fdd5422874c6b2831122c4438133da.tar.bz2
gentoo-2-802de36783fdd5422874c6b2831122c4438133da.zip
Version bump, switch 9999 to bzr, bug #236773
(Portage version: 2.1.6.4/cvs/Linux 2.6.27-gentoo-r8 i686)
Diffstat (limited to 'net-p2p/linuxdcpp')
-rw-r--r--net-p2p/linuxdcpp/ChangeLog10
-rw-r--r--net-p2p/linuxdcpp/linuxdcpp-1.0.3.ebuild49
-rw-r--r--net-p2p/linuxdcpp/linuxdcpp-9999.ebuild13
3 files changed, 62 insertions, 10 deletions
diff --git a/net-p2p/linuxdcpp/ChangeLog b/net-p2p/linuxdcpp/ChangeLog
index 20239baa1e5f..16bb136506cd 100644
--- a/net-p2p/linuxdcpp/ChangeLog
+++ b/net-p2p/linuxdcpp/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-p2p/linuxdcpp
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/linuxdcpp/ChangeLog,v 1.32 2008/07/10 12:56:30 armin76 Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/linuxdcpp/ChangeLog,v 1.33 2009/02/10 16:53:05 armin76 Exp $
+
+*linuxdcpp-1.0.3 (10 Feb 2009)
+
+ 10 Feb 2009; Raúl Porcel <armin76@gentoo.org> +linuxdcpp-1.0.3.ebuild,
+ linuxdcpp-9999.ebuild:
+ Version bump, switch 9999 to bzr, bug #236773
*linuxdcpp-1.0.2 (10 Jul 2008)
diff --git a/net-p2p/linuxdcpp/linuxdcpp-1.0.3.ebuild b/net-p2p/linuxdcpp/linuxdcpp-1.0.3.ebuild
new file mode 100644
index 000000000000..f36138d03278
--- /dev/null
+++ b/net-p2p/linuxdcpp/linuxdcpp-1.0.3.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/linuxdcpp/linuxdcpp-1.0.3.ebuild,v 1.1 2009/02/10 16:53:05 armin76 Exp $
+
+inherit eutils
+
+DESCRIPTION="Direct connect client, looks and works like famous DC++"
+HOMEPAGE="https://launchpad.net/linuxdcpp"
+SRC_URI="http://launchpad.net/linuxdcpp/1.0/${PV}/+download/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE="debug"
+
+RDEPEND=">=gnome-base/libglade-2.4
+ >=x11-libs/gtk+-2.6
+ app-arch/bzip2
+ dev-libs/openssl"
+DEPEND="${RDEPEND}
+ media-libs/fontconfig
+ >=dev-util/scons-0.96
+ dev-util/pkgconfig"
+
+src_compile() {
+ local myconf=""
+ use debug && myconf="${myconf} debug=1"
+
+ scons ${myconf} ${MAKEOPTS} CXXFLAGS="${CXXFLAGS}" PREFIX=/usr || die "scons failed"
+}
+
+src_install() {
+ insinto /usr/share/${PN}
+ doins -r ${PN} pixmaps glade
+
+ dodoc Readme.txt Changelog.txt Credits.txt
+
+ dosym /usr/share/${PN}/${PN} /usr/bin/${PN}
+ fperms +x /usr/share/${PN}/${PN}
+
+ doicon pixmaps/${PN}.png
+
+ make_desktop_entry ${PN} "${PN}" ${PN}
+}
+
+pkg_postinst() {
+ elog
+ elog "After adding first directory to shares you might need to restart linuxdcpp."
+ elog
+}
diff --git a/net-p2p/linuxdcpp/linuxdcpp-9999.ebuild b/net-p2p/linuxdcpp/linuxdcpp-9999.ebuild
index 4c93da8b84c2..023d66ba389e 100644
--- a/net-p2p/linuxdcpp/linuxdcpp-9999.ebuild
+++ b/net-p2p/linuxdcpp/linuxdcpp-9999.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/linuxdcpp/linuxdcpp-9999.ebuild,v 1.9 2008/02/29 20:29:56 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/linuxdcpp/linuxdcpp-9999.ebuild,v 1.10 2009/02/10 16:53:05 armin76 Exp $
-inherit cvs eutils
+inherit bzr eutils
DESCRIPTION="Direct connect client, looks and works like famous DC++"
HOMEPAGE="http://linuxdcpp.berlios.de"
@@ -12,12 +12,9 @@ SLOT="0"
KEYWORDS=""
IUSE="debug"
-ECVS_SERVER="cvs.linuxdcpp.berlios.de:/cvsroot/linuxdcpp"
-ECVS_MODULE="linuxdcpp"
-ECVS_AUTH="pserver"
-ECVS_USER="anonymous"
+EBZR_REPO_URI="lp:linuxdcpp"
-S="${WORKDIR}/${PN}"
+S="${WORKDIR}/${P}"
RDEPEND=">=gnome-base/libglade-2.4
>=x11-libs/gtk+-2.6