summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorzlg <zlg@gentoo.org>2015-05-22 06:00:49 +0000
committerzlg <zlg@gentoo.org>2015-05-22 06:00:49 +0000
commitae8cec3056442c9af404b2efece633af23d48497 (patch)
tree059bddbca57ea78b2770e4b46a4f30bee58cee6f /net-p2p/imule
parentVersion bump, wrt bug #503958 (diff)
downloadgentoo-2-ae8cec3056442c9af404b2efece633af23d48497.tar.gz
gentoo-2-ae8cec3056442c9af404b2efece633af23d48497.tar.bz2
gentoo-2-ae8cec3056442c9af404b2efece633af23d48497.zip
New ebuild wrt 281192. Thanks Andrey Aleksandrovich
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 5039E170)
Diffstat (limited to 'net-p2p/imule')
-rw-r--r--net-p2p/imule/ChangeLog10
-rw-r--r--net-p2p/imule/imule-2.3.2.3.ebuild51
-rw-r--r--net-p2p/imule/metadata.xml12
3 files changed, 73 insertions, 0 deletions
diff --git a/net-p2p/imule/ChangeLog b/net-p2p/imule/ChangeLog
new file mode 100644
index 000000000000..062988957231
--- /dev/null
+++ b/net-p2p/imule/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-p2p/imule
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/imule/ChangeLog,v 1.1 2015/05/22 06:00:49 zlg Exp $
+
+*imule-2.3.2.3 (22 May 2015)
+
+ 22 May 2015; Daniel Campbell <zlg@gentoo.org> +imule-2.3.2.3.ebuild,
+ +metadata.xml:
+ New ebuild wrt 281192. Thanks Andrey Aleksandrovich
+
diff --git a/net-p2p/imule/imule-2.3.2.3.ebuild b/net-p2p/imule/imule-2.3.2.3.ebuild
new file mode 100644
index 000000000000..aa118139f3ec
--- /dev/null
+++ b/net-p2p/imule/imule-2.3.2.3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/imule/imule-2.3.2.3.ebuild,v 1.1 2015/05/22 06:00:49 zlg Exp $
+
+EAPI="5"
+WX_GTK_VER="2.8"
+inherit wxwidgets
+
+MY_PN="iMule"
+
+DESCRIPTION="P2P sharing software which connects through I2P and Kad network"
+# New homepage has a few resources and a working nodes.dat file users need
+# in order to get iMule to work
+HOMEPAGE="http://echelon.i2p/imule"
+SRC_URI="http://echelon.i2p/imule/${PV}/${MY_PN}-${PV}-src.tbz http://dev.gentoo.org/~zlg/extra/net-p2p/imule/2015-03-22_nodes.dat"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="webserver static-libs nls"
+
+# wxGTK 2.8 is required; later versions result in failed compile
+# Other versions indicated are from the tarball's INSTALL file
+DEPEND="x11-libs/wxGTK:2.8
+ net-p2p/i2p
+ >=net-libs/libupnp-1.6.6
+ sys-devel/flex
+ sys-apps/texinfo
+ >=dev-libs/crypto++-5.1"
+RDEPEND="x11-libs/wxGTK:2.8 net-p2p/i2p"
+
+S="${WORKDIR}/${MY_PN}-${PV}-src"
+
+src_configure() {
+ WX_GTK_VER="2.8" need-wxwidgets unicode
+ # Enabling imulecmd results in a compilation error.
+ econf --with-wx-config=${WX_CONFIG} \
+ --enable-imule-daemon \
+ --enable-alc \
+ --enable-alcc \
+ --enable-optimize \
+ --disable-debug \
+ $(use_enable nls) \
+ $(use_enable webserver) \
+ $(use_enable static-libs static)
+}
+
+pkg_postinst() {
+ elog "iMule will not function without a valid 'nodes.dat' file and"
+ elog "an I2P router running."
+ elog "The nodes.dat file can be found at http://echelon.i2p/imule."
+}
diff --git a/net-p2p/imule/metadata.xml b/net-p2p/imule/metadata.xml
new file mode 100644
index 000000000000..f48160a14d46
--- /dev/null
+++ b/net-p2p/imule/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>java</herd>
+<maintainer><email>maintainer-wanted@gentoo.org</email></maintainer>
+<longdescription>A P2P file-sharing application designed to work on top of the I2P or Kad network stacks.</longdescription>
+<use>
+<flag name="nls">Adds Native Language Support using GNU gettext.</flag>
+<flag name="static-libs">Builds a statically-linked application.</flag>
+<flag name="webserver">Enables a webserver to administer remotely.</flag>
+</use>
+</pkgmetadata>