summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2007-07-08 08:32:28 +0000
committerDaniel Black <dragonheart@gentoo.org>2007-07-08 08:32:28 +0000
commitfe2f3040091c97b90bdc78f21a7140efcc6d9daf (patch)
treee76e5daa4e3b4543f17adbfab7745d35781918c7 /net-misc
parentVersion bump (diff)
downloadgentoo-2-fe2f3040091c97b90bdc78f21a7140efcc6d9daf.tar.gz
gentoo-2-fe2f3040091c97b90bdc78f21a7140efcc6d9daf.tar.bz2
gentoo-2-fe2f3040091c97b90bdc78f21a7140efcc6d9daf.zip
no LDFLAGS now - bug #183402
(Portage version: 2.1.2.9)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/curl/ChangeLog6
-rw-r--r--net-misc/curl/curl-7.16.3.ebuild4
-rw-r--r--net-misc/curl/files/curl-7.16.2-strip-ldflags.patch14
3 files changed, 21 insertions, 3 deletions
diff --git a/net-misc/curl/ChangeLog b/net-misc/curl/ChangeLog
index 93c4b8662f61..01db9f89bf64 100644
--- a/net-misc/curl/ChangeLog
+++ b/net-misc/curl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-misc/curl
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/curl/ChangeLog,v 1.84 2007/06/25 12:19:40 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/curl/ChangeLog,v 1.85 2007/07/08 08:32:28 dragonheart Exp $
+
+ 08 Jul 2007; Daniel Black <dragonheart@gentoo.org>
+ files/curl-7.16.2-strip-ldflags.patch, curl-7.16.3.ebuild:
+ no LDFLAGS now - bug #183402
*curl-7.16.3 (25 Jun 2007)
diff --git a/net-misc/curl/curl-7.16.3.ebuild b/net-misc/curl/curl-7.16.3.ebuild
index b1312b720efd..b6fa065eb524 100644
--- a/net-misc/curl/curl-7.16.3.ebuild
+++ b/net-misc/curl/curl-7.16.3.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/curl/curl-7.16.3.ebuild,v 1.1 2007/06/25 12:19:40 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/curl/curl-7.16.3.ebuild,v 1.2 2007/07/08 08:32:28 dragonheart Exp $
# NOTE: If you bump this ebuild, make sure you bump dev-python/pycurl!
-inherit libtool eutils
+inherit autotools eutils
#MY_P=${P/_pre/-}
DESCRIPTION="A Client that groks URLs"
diff --git a/net-misc/curl/files/curl-7.16.2-strip-ldflags.patch b/net-misc/curl/files/curl-7.16.2-strip-ldflags.patch
index 12e8586d8f0b..1c33fc5f8e1d 100644
--- a/net-misc/curl/files/curl-7.16.2-strip-ldflags.patch
+++ b/net-misc/curl/files/curl-7.16.2-strip-ldflags.patch
@@ -8,3 +8,17 @@
+Libs: -L${libdir} -lcurl @LIBS@
Libs.private: @LIBCURL_LIBS@ @LIBS@
Cflags: -I${includedir}
+--- curl-7.16.3/curl-config.in.orig 2007-06-28 22:22:51.000000000 +1000
++++ curl-7.16.3/curl-config.in 2007-06-28 22:23:10.000000000 +1000
+@@ -187,9 +187,9 @@
+ CURLLIBDIR=""
+ fi
+ if test "X@REQUIRE_LIB_DEPS@" = "Xyes"; then
+- echo ${CURLLIBDIR}-lcurl @LDFLAGS@ @LIBCURL_LIBS@ @LIBS@
++ echo ${CURLLIBDIR}-lcurl @LIBCURL_LIBS@ @LIBS@
+ else
+- echo ${CURLLIBDIR}-lcurl @LDFLAGS@ @LIBS@
++ echo ${CURLLIBDIR}-lcurl @LIBS@
+ fi
+ ;;
+