summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-10-21 07:39:55 +0000
committerMike Frysinger <vapier@gentoo.org>2010-10-21 07:39:55 +0000
commite030af52fcf9d01a0cfc9187b0b46f89ac5b0713 (patch)
tree03422f1c7f6425f1618c4d8f56c19f8df1b28e1a /net-misc
parentold (diff)
downloadgentoo-2-e030af52fcf9d01a0cfc9187b0b46f89ac5b0713.tar.gz
gentoo-2-e030af52fcf9d01a0cfc9187b0b46f89ac5b0713.tar.bz2
gentoo-2-e030af52fcf9d01a0cfc9187b0b46f89ac5b0713.zip
Version bump and make iconv/idn optional #341887 by Benedikt Böhm.
(Portage version: 2.2_rc96/cvs/Linux x86_64)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/whois/ChangeLog7
-rw-r--r--net-misc/whois/whois-5.0.8.ebuild53
2 files changed, 59 insertions, 1 deletions
diff --git a/net-misc/whois/ChangeLog b/net-misc/whois/ChangeLog
index aaca0666eb54..46fcd559c3a0 100644
--- a/net-misc/whois/ChangeLog
+++ b/net-misc/whois/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/whois
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/whois/ChangeLog,v 1.147 2010/09/25 15:13:27 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/whois/ChangeLog,v 1.148 2010/10/21 07:39:55 vapier Exp $
+
+*whois-5.0.8 (21 Oct 2010)
+
+ 21 Oct 2010; Mike Frysinger <vapier@gentoo.org> +whois-5.0.8.ebuild:
+ Version bump and make iconv/idn optional #341887 by Benedikt Böhm.
25 Sep 2010; Jeroen Roovers <jer@gentoo.org> whois-5.0.5.ebuild:
Stable for SPARC (bug #329663).
diff --git a/net-misc/whois/whois-5.0.8.ebuild b/net-misc/whois/whois-5.0.8.ebuild
new file mode 100644
index 000000000000..4031d2762d5b
--- /dev/null
+++ b/net-misc/whois/whois-5.0.8.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/whois/whois-5.0.8.ebuild,v 1.1 2010/10/21 07:39:55 vapier Exp $
+
+EAPI=3
+inherit eutils toolchain-funcs
+
+MY_P=${P/-/_}
+DESCRIPTION="improved Whois Client"
+HOMEPAGE="http://www.linux.it/~md/software/"
+SRC_URI="mirror://debian/pool/main/w/whois/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux"
+IUSE="iconv idn nls"
+RESTRICT="test" #59327
+
+RDEPEND="idn? ( net-dns/libidn )"
+DEPEND="${RDEPEND}
+ >=dev-lang/perl-5"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-4.7.2-config-file.patch
+
+ if use nls ; then
+ sed -i -e 's:#\(.*pos\):\1:' Makefile
+ else
+ sed -i -e '/ENABLE_NLS/s:define:undef:' config.h
+ fi
+}
+
+src_configure() { :;} # expected no-op
+
+src_compile() {
+ unset HAVE_ICONV HAVE_LIBIDN
+ use iconv && export HAVE_ICONV=1
+ use idn && export HAVE_LIBIDN=1
+ tc-export CC
+ emake CFLAGS="${CFLAGS} ${CPPFLAGS}" || die
+}
+
+src_install() {
+ emake BASEDIR="${ED}" prefix=/usr install || die
+ insinto /etc
+ doins whois.conf
+ dodoc README debian/changelog
+
+ if [[ ${USERLAND} != "GNU" ]]; then
+ mv "${ED}"/usr/share/man/man1/{whois,mdwhois}.1
+ mv "${ED}"/usr/bin/{whois,mdwhois}
+ fi
+}